diff options
author | Richard Purdie <richard@openedhand.com> | 2006-09-21 15:01:21 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-09-21 15:01:21 +0000 |
commit | ecd5296738e37bd5701eaba230fefcf7994f4110 (patch) | |
tree | 105038d0b74d939b082cabb2758917304aaf965c /meta/packages/libxsettings-client | |
parent | a48da11acaeec6aa3a21a0a0f30098b26e248ecc (diff) | |
download | poky-ecd5296738e37bd5701eaba230fefcf7994f4110.tar.gz |
libxsettings-client: Use version 0.10. Remove libxsettings
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@740 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libxsettings-client')
3 files changed, 23 insertions, 42 deletions
diff --git a/meta/packages/libxsettings-client/libxsettings-client_0.10.bb b/meta/packages/libxsettings-client/libxsettings-client_0.10.bb new file mode 100644 index 0000000000..45b2035076 --- /dev/null +++ b/meta/packages/libxsettings-client/libxsettings-client_0.10.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "Common code for XSETTINGS" | ||
2 | SECTION = "x/libs" | ||
3 | LICENSE = "BSD-X" | ||
4 | PRIORITY = "optional" | ||
5 | DEPENDS = "libx11 libxt" | ||
6 | # libxt is required to stop configure breaking builds by | ||
7 | # including system paths to find it if it isn't present. | ||
8 | |||
9 | headers = "xsettings-common.h xsettings-client.h" | ||
10 | |||
11 | SRC_URI = "http://projects.o-hand.com/matchbox/sources/optional-dependencies/Xsettings-client-0.10.tar.gz" | ||
12 | S = "${WORKDIR}/Xsettings-client-0.10" | ||
13 | |||
14 | inherit autotools gettext | ||
15 | |||
16 | do_stage () { | ||
17 | oe_libinstall -so libXsettings-client ${STAGING_LIBDIR} | ||
18 | |||
19 | mkdir -p ${STAGING_INCDIR}/gpe | ||
20 | for h in ${headers}; do | ||
21 | install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h | ||
22 | done | ||
23 | } | ||
diff --git a/meta/packages/libxsettings-client/libxsettings-client_0.14.bb b/meta/packages/libxsettings-client/libxsettings-client_0.14.bb deleted file mode 100644 index f2e77735f9..0000000000 --- a/meta/packages/libxsettings-client/libxsettings-client_0.14.bb +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | SECTION = "gpe/libs" | ||
2 | LICENSE = "BSD-X" | ||
3 | PRIORITY = "optional" | ||
4 | DEPENDS = "libxsettings libx11 libxt" | ||
5 | # libxt is required to stop configure breaking builds by | ||
6 | # including system paths to find it if it isn't present. | ||
7 | |||
8 | inherit autotools pkgconfig gpe | ||
9 | |||
10 | SRC_URI = "${GPE_MIRROR}/xsettings-client-${PV}.tar.bz2" | ||
11 | S = ${WORKDIR}/xsettings-client-${PV} | ||
12 | |||
13 | |||
14 | headers = "xsettings-client.h xsettings-common.h" | ||
15 | do_stage () { | ||
16 | oe_libinstall -so libXsettings-client ${STAGING_LIBDIR} | ||
17 | mkdir -p ${STAGING_INCDIR} | ||
18 | for h in ${headers}; do | ||
19 | install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h | ||
20 | done | ||
21 | } | ||
diff --git a/meta/packages/libxsettings-client/make_pkgconfig_x11.patch b/meta/packages/libxsettings-client/make_pkgconfig_x11.patch deleted file mode 100644 index 3a386672d2..0000000000 --- a/meta/packages/libxsettings-client/make_pkgconfig_x11.patch +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | --- libxsettings-client0-0.12/Makefile.old 2004-04-20 16:48:18.000000000 +1000 | ||
2 | +++ libxsettings-client0-0.12/Makefile 2004-04-20 16:58:07.000000000 +1000 | ||
3 | @@ -20,6 +20,9 @@ | ||
4 | CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\" | ||
5 | CPPFLAGS += -I../libxsettings | ||
6 | |||
7 | +CFLAGS += `pkg-config --cflags x11` | ||
8 | +LDFLAGS += `pkg-config --ldflags x11` | ||
9 | + | ||
10 | XSETTINGS_OBJS = $(patsubst %,%.os,$(XSETTINGS_MEMBERS)) | ||
11 | DEPS = $(patsubst %,%.d,$(MEMBERS) $(XSETTINGS_MEMBERS)) | ||
12 | SOURCES = $(patsubst %,%.c,$(MEMBERS) $(XSETTINGS_MEMBERS)) | ||
13 | @@ -39,7 +42,7 @@ | ||
14 | ln -sf $^ $@ | ||
15 | |||
16 | $(LIBXSETTINGS_SO): $(XSETTINGS_OBJS) | ||
17 | - $(CC) -o $@ $^ -shared -Wl,-soname -Wl,$(LIBXSETTINGS_SO) -nostartfiles -L/usr/X11R6/lib -lX11 -L../libxsettings -lXsettings | ||
18 | + $(CC) -o $@ $^ -shared -Wl,-soname -Wl,$(LIBXSETTINGS_SO) -nostartfiles $(LDFLAGS) -L../libxsettings -lXsettings | ||
19 | |||
20 | install-program: $(LIBXSETTINGS_SO) | ||
21 | install -d $(DESTDIR)$(PREFIX)/lib | ||