summaryrefslogtreecommitdiffstats
path: root/meta/packages/libxsettings-client/libxsettings-client_0.10.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2010-06-10 21:27:11 +0800
committerJoshua Lock <josh@linux.intel.com>2010-06-17 23:13:24 +0100
commitf879d7df27aeb93794418146f978cda37e32be78 (patch)
treed74a9d7cdc3220ff7fa5c04d2225a9c815be75b9 /meta/packages/libxsettings-client/libxsettings-client_0.10.bb
parentcea3fe7d6e38b345a8864638afecc7a17d9f47fb (diff)
downloadpoky-f879d7df27aeb93794418146f978cda37e32be78.tar.gz
libxsettings-client: fix metadata and add MIT-style-license
One tricky issue for license part. This package doesn't ship with its own COPYING file and autotools will install a GPLv2 one instead of the actual MIT-style license here. So create a MIT-style license on the fly to reflect the fact. Use new patch parameters. Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Kevin Tian <kevin.tian@intel.com> Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/packages/libxsettings-client/libxsettings-client_0.10.bb')
-rw-r--r--meta/packages/libxsettings-client/libxsettings-client_0.10.bb20
1 files changed, 17 insertions, 3 deletions
diff --git a/meta/packages/libxsettings-client/libxsettings-client_0.10.bb b/meta/packages/libxsettings-client/libxsettings-client_0.10.bb
index eba2df18ba..ecd6d181eb 100644
--- a/meta/packages/libxsettings-client/libxsettings-client_0.10.bb
+++ b/meta/packages/libxsettings-client/libxsettings-client_0.10.bb
@@ -1,16 +1,30 @@
1DESCRIPTION = "Common code for XSETTINGS" 1DESCRIPTION = "Common code for XSETTINGS"
2HOMEPAGE = "http://matchbox-project.org/sources/optional-dependencies/"
3BUGTRACKER = "http://bugzilla.openedhand.com/"
2SECTION = "x/libs" 4SECTION = "x/libs"
3LICENSE = "BSD-X" 5LICENSE = "MIT-style"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
7 file://xsettings-client.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
8 file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
4PRIORITY = "optional" 9PRIORITY = "optional"
5DEPENDS = "virtual/libx11" 10DEPENDS = "virtual/libx11"
6 11
7PR = "r2" 12PR = "r3"
8 13
9headers = "xsettings-common.h xsettings-client.h" 14headers = "xsettings-common.h xsettings-client.h"
10 15
11SRC_URI = "http://projects.o-hand.com/matchbox/sources/optional-dependencies/Xsettings-client-0.10.tar.gz \ 16SRC_URI = "http://projects.o-hand.com/matchbox/sources/optional-dependencies/Xsettings-client-0.10.tar.gz \
12 file://link-x11.patch;patch=1" 17 file://MIT-style-license \
18 file://link-x11.patch;apply=yes"
13 19
14S = "${WORKDIR}/Xsettings-client-0.10" 20S = "${WORKDIR}/Xsettings-client-0.10"
15 21
16inherit autotools gettext 22inherit autotools gettext
23
24do_configure_prepend() {
25 # This package doesn't ship with its own COPYING file and
26 # autotools will install a GPLv2 one instead of the actual MIT-style license here.
27 # Add the correct license here to avoid confusion.
28 cp -f ${WORKDIR}/MIT-style-license ${S}/COPYING
29}
30