diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-12-18 08:09:09 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2007-12-18 08:09:09 +0000 |
commit | c3fb3617fdbf43c5a9796eeceee5bcd0e54c9f65 (patch) | |
tree | 600d906920b09204024c5ff33a762104ada6c2a6 /meta/packages/libxml | |
parent | d4b9227e9598532bcc7fecefe6e33792c2c05d2d (diff) | |
download | poky-c3fb3617fdbf43c5a9796eeceee5bcd0e54c9f65.tar.gz |
libxml2: added fix for 'unable to find gzopen64()' when host is 64bit (taken from Debian)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3339 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libxml')
-rw-r--r-- | meta/packages/libxml/files/libxml-64bit.patch | 20 | ||||
-rw-r--r-- | meta/packages/libxml/libxml2-native_2.6.29.bb | 11 | ||||
-rw-r--r-- | meta/packages/libxml/libxml2.inc | 11 | ||||
-rw-r--r-- | meta/packages/libxml/libxml2_2.6.29.bb | 12 |
4 files changed, 37 insertions, 17 deletions
diff --git a/meta/packages/libxml/files/libxml-64bit.patch b/meta/packages/libxml/files/libxml-64bit.patch new file mode 100644 index 0000000000..fcb7d34fa7 --- /dev/null +++ b/meta/packages/libxml/files/libxml-64bit.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | --- | ||
2 | libxml.h | 3 +++ | ||
3 | 1 file changed, 3 insertions(+) | ||
4 | |||
5 | --- libxml2-2.6.29.orig/libxml.h | ||
6 | +++ libxml2-2.6.29/libxml.h | ||
7 | @@ -11,10 +11,13 @@ | ||
8 | |||
9 | #ifndef NO_LARGEFILE_SOURCE | ||
10 | #ifndef _LARGEFILE_SOURCE | ||
11 | #define _LARGEFILE_SOURCE | ||
12 | #endif | ||
13 | +#ifndef _LARGEFILE64_SOURCE | ||
14 | +#define _LARGEFILE64_SOURCE | ||
15 | +#endif | ||
16 | #ifndef _FILE_OFFSET_BITS | ||
17 | #define _FILE_OFFSET_BITS 64 | ||
18 | #endif | ||
19 | #endif | ||
20 | |||
diff --git a/meta/packages/libxml/libxml2-native_2.6.29.bb b/meta/packages/libxml/libxml2-native_2.6.29.bb index 7c397d471d..4f7a801495 100644 --- a/meta/packages/libxml/libxml2-native_2.6.29.bb +++ b/meta/packages/libxml/libxml2-native_2.6.29.bb | |||
@@ -1,16 +1,13 @@ | |||
1 | DESCRIPTION = "GNOME XML library" | 1 | require libxml2.inc |
2 | PR = "r3" | ||
3 | 2 | ||
4 | SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz" | 3 | PR = "r4" |
5 | 4 | ||
6 | DEPENDS = "python-native-runtime" | 5 | DEPENDS += "python-native-runtime" |
7 | 6 | ||
8 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}" | 7 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}" |
9 | S = "${WORKDIR}/libxml2-${PV}" | 8 | S = "${WORKDIR}/libxml2-${PV}" |
10 | 9 | ||
11 | inherit autotools native pkgconfig | 10 | inherit native |
12 | |||
13 | EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n" | ||
14 | 11 | ||
15 | do_stage () { | 12 | do_stage () { |
16 | oe_runmake install | 13 | oe_runmake install |
diff --git a/meta/packages/libxml/libxml2.inc b/meta/packages/libxml/libxml2.inc new file mode 100644 index 0000000000..4e6e527603 --- /dev/null +++ b/meta/packages/libxml/libxml2.inc | |||
@@ -0,0 +1,11 @@ | |||
1 | DESCRIPTION = "GNOME XML Parser library" | ||
2 | SECTION = "libs" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "MIT" | ||
5 | |||
6 | SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \ | ||
7 | file://libxml-64bit.patch;patch=1" | ||
8 | |||
9 | inherit autotools pkgconfig binconfig | ||
10 | |||
11 | EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n" | ||
diff --git a/meta/packages/libxml/libxml2_2.6.29.bb b/meta/packages/libxml/libxml2_2.6.29.bb index 521ba16d9b..3b4bac673a 100644 --- a/meta/packages/libxml/libxml2_2.6.29.bb +++ b/meta/packages/libxml/libxml2_2.6.29.bb | |||
@@ -1,14 +1,6 @@ | |||
1 | DESCRIPTION = "GNOME XML Parser library" | 1 | require libxml2.inc |
2 | SECTION = "libs" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE = "MIT" | ||
5 | PR = "r5" | ||
6 | 2 | ||
7 | SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz" | 3 | PR = "r6" |
8 | |||
9 | inherit autotools pkgconfig binconfig | ||
10 | |||
11 | EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n" | ||
12 | 4 | ||
13 | export LDFLAGS += "-ldl" | 5 | export LDFLAGS += "-ldl" |
14 | 6 | ||