summaryrefslogtreecommitdiffstats
path: root/meta/packages/libxml/libxml2_2.6.29.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-08-02 12:57:39 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-08-02 12:57:39 +0000
commit807535a52f8344076e6b9ae6d7a0f7171242c98e (patch)
tree2a45cd44633bc194ff6a6dbfd2c6751140d534c5 /meta/packages/libxml/libxml2_2.6.29.bb
parent22c85055348c01f86dffbe926a0eccf8fac3b1f9 (diff)
downloadpoky-807535a52f8344076e6b9ae6d7a0f7171242c98e.tar.gz
libxml2: update to 2.6.29 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2329 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libxml/libxml2_2.6.29.bb')
-rw-r--r--meta/packages/libxml/libxml2_2.6.29.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/libxml/libxml2_2.6.29.bb b/meta/packages/libxml/libxml2_2.6.29.bb
new file mode 100644
index 0000000000..12fb6ca08e
--- /dev/null
+++ b/meta/packages/libxml/libxml2_2.6.29.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "GNOME XML Parser library"
2SECTION = "libs"
3PRIORITY = "optional"
4LICENSE = "MIT"
5PR = "r4"
6
7SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
8
9inherit autotools pkgconfig binconfig
10
11EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
12
13export LDFLAGS += "-ldl"
14
15do_stage() {
16 autotools_stage_all
17 install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
18 #this is need it by php during its install
19 install -m 0755 xml2-config ${STAGING_BINDIR}
20}
21
22python populate_packages_prepend () {
23 # autonamer would call this libxml2-2, but we don't want that
24 if bb.data.getVar('DEBIAN_NAMES', d, 1):
25 bb.data.setVar('PKG_libxml2', 'libxml2', d)
26}
27
28PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
29
30FILES_${PN}-dev += "${bindir}/*-config"
31FILES_${PN}-utils += "${bindir}/*"