diff options
author | Chris Lord <chris@openedhand.com> | 2007-01-03 20:55:29 +0000 |
---|---|---|
committer | Chris Lord <chris@openedhand.com> | 2007-01-03 20:55:29 +0000 |
commit | 4ffe8f6b1ff640722880cf2cd88990956de87e30 (patch) | |
tree | 736a16d112da36e87f3709ee93555a48b534dba5 /meta/packages/libusb | |
parent | a34d402b9eaf56d23df83c19c422b7d0d9c708d1 (diff) | |
download | poky-4ffe8f6b1ff640722880cf2cd88990956de87e30.tar.gz |
Check in opensync/libsync/synctool bits - Mostly compiles, not tested
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1113 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libusb')
-rw-r--r-- | meta/packages/libusb/libusb-native_0.1.12.bb | 3 | ||||
-rw-r--r-- | meta/packages/libusb/libusb_0.1.12.bb | 35 |
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/libusb/libusb-native_0.1.12.bb b/meta/packages/libusb/libusb-native_0.1.12.bb new file mode 100644 index 0000000000..637ded28e4 --- /dev/null +++ b/meta/packages/libusb/libusb-native_0.1.12.bb | |||
@@ -0,0 +1,3 @@ | |||
1 | require libusb_${PV}.bb | ||
2 | inherit native | ||
3 | |||
diff --git a/meta/packages/libusb/libusb_0.1.12.bb b/meta/packages/libusb/libusb_0.1.12.bb new file mode 100644 index 0000000000..43c6ea92bd --- /dev/null +++ b/meta/packages/libusb/libusb_0.1.12.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | DESCRIPTION = "libusb is a library to provide userspace \ | ||
2 | access to USB devices." | ||
3 | HOMEPAGE = "http://libusb.sf.net" | ||
4 | SECTION = "libs" | ||
5 | LICENSE = "LGPL" | ||
6 | PR = "r1" | ||
7 | |||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.gz" | ||
9 | |||
10 | S = "${WORKDIR}/libusb-${PV}" | ||
11 | |||
12 | inherit autotools pkgconfig binconfig lib_package | ||
13 | |||
14 | PARALLEL_MAKE = "" | ||
15 | EXTRA_OECONF = "--disable-build-docs" | ||
16 | |||
17 | export CXXFLAGS += "-lstdc++" | ||
18 | |||
19 | do_stage() { | ||
20 | |||
21 | autotools_stage_all | ||
22 | install -m 755 ${S}/libusb-config ${STAGING_BINDIR} | ||
23 | # can we get rid of that? wouldn't a sed statement do as well? | ||
24 | sed -i 's:\-L${libdir} :-L${STAGING_LIBDIR} :' ${STAGING_BINDIR}/libusb-config | ||
25 | |||
26 | if [ "${STAGING_BINDIR}" != "${STAGING_BINDIR_CROSS}" ]; then | ||
27 | install -d ${STAGING_BINDIR_CROSS}/ | ||
28 | mv ${STAGING_BINDIR}/libusb-config ${STAGING_BINDIR_CROSS}/libusb-config | ||
29 | fi | ||
30 | |||
31 | } | ||
32 | |||
33 | PACKAGES =+ "libusbpp" | ||
34 | |||
35 | FILES_libusbpp = "${libdir}/libusbpp*.so.*" | ||