diff options
author | Richard Purdie <richard@openedhand.com> | 2008-04-13 22:15:59 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2008-04-13 22:15:59 +0000 |
commit | 21c0f07d4b791ba3e2d32c00562997e39b22d366 (patch) | |
tree | cd95bac067af83570e5efbea1f8f12ee7dfdf4b2 /meta/packages/libtool | |
parent | 2e46a28f63a9e015da156ddede382081b88d4b96 (diff) | |
download | poky-21c0f07d4b791ba3e2d32c00562997e39b22d366.tar.gz |
libtool: Add 2.2.2 (not default)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4244 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libtool')
-rw-r--r-- | meta/packages/libtool/libtool-2.2.2/add_dolt.patch | 15 | ||||
-rw-r--r-- | meta/packages/libtool/libtool-2.2.2/dolt.m4 | 129 | ||||
-rw-r--r-- | meta/packages/libtool/libtool-2.2.2/libdir-la.patch | 56 | ||||
-rw-r--r-- | meta/packages/libtool/libtool-2.2.2/nousrlib.patch | 11 | ||||
-rw-r--r-- | meta/packages/libtool/libtool-2.2.2/prefix.patch | 100 | ||||
-rw-r--r-- | meta/packages/libtool/libtool-2.2.2/tag.patch | 19 | ||||
-rw-r--r-- | meta/packages/libtool/libtool-2.2.2/uclibc.patch | 14 | ||||
-rw-r--r-- | meta/packages/libtool/libtool-cross_2.2.2.bb | 43 | ||||
-rw-r--r-- | meta/packages/libtool/libtool-native_2.2.2.bb | 34 | ||||
-rw-r--r-- | meta/packages/libtool/libtool_2.2.2.bb | 25 |
10 files changed, 446 insertions, 0 deletions
diff --git a/meta/packages/libtool/libtool-2.2.2/add_dolt.patch b/meta/packages/libtool/libtool-2.2.2/add_dolt.patch new file mode 100644 index 0000000000..45dd78a812 --- /dev/null +++ b/meta/packages/libtool/libtool-2.2.2/add_dolt.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | Index: libtool-1.5.10/libtool.m4 | ||
2 | =================================================================== | ||
3 | --- libtool-1.5.10.orig/libtool.m4 2008-04-10 16:08:19.000000000 +0100 | ||
4 | +++ libtool-1.5.10/libtool.m4 2008-04-10 16:08:44.000000000 +0100 | ||
5 | @@ -67,7 +67,9 @@ | ||
6 | ifdef([LT_AC_PROG_GCJ], | ||
7 | [define([LT_AC_PROG_GCJ], | ||
8 | defn([LT_AC_PROG_GCJ])[AC_LIBTOOL_GCJ])])])]) | ||
9 | -])])# AC_PROG_LIBTOOL | ||
10 | +]) | ||
11 | +DOLT | ||
12 | +])# AC_PROG_LIBTOOL | ||
13 | |||
14 | |||
15 | # _AC_PROG_LIBTOOL | ||
diff --git a/meta/packages/libtool/libtool-2.2.2/dolt.m4 b/meta/packages/libtool/libtool-2.2.2/dolt.m4 new file mode 100644 index 0000000000..9bedecf273 --- /dev/null +++ b/meta/packages/libtool/libtool-2.2.2/dolt.m4 | |||
@@ -0,0 +1,129 @@ | |||
1 | dnl dolt, a replacement for libtool | ||
2 | dnl Copyright © 2007-2008 Josh Triplett <josh@freedesktop.org> | ||
3 | dnl Copying and distribution of this file, with or without modification, | ||
4 | dnl are permitted in any medium without royalty provided the copyright | ||
5 | dnl notice and this notice are preserved. | ||
6 | dnl | ||
7 | dnl To use dolt, invoke the DOLT macro immediately after the libtool macros. | ||
8 | dnl Optionally, copy this file into acinclude.m4, to avoid the need to have it | ||
9 | dnl installed when running autoconf on your project. | ||
10 | |||
11 | AC_DEFUN([DOLT], [ | ||
12 | AC_REQUIRE([AC_CANONICAL_HOST]) | ||
13 | # dolt, a replacement for libtool | ||
14 | # Josh Triplett <josh@freedesktop.org> | ||
15 | AC_PATH_PROG(DOLT_BASH, bash) | ||
16 | AC_MSG_CHECKING([if dolt supports this host]) | ||
17 | dolt_supported=yes | ||
18 | if test x$DOLT_BASH = x; then | ||
19 | AC_MSG_ERROR([dolt: Bash not found, fatal error]) | ||
20 | fi | ||
21 | if test x$GCC != xyes; then | ||
22 | AC_MSG_ERROR([dolt: gcc not found, fatal error]) | ||
23 | fi | ||
24 | case $host in | ||
25 | i?86-*-linux*|x86_64-*-linux*|arm-*-linux*) ;; | ||
26 | *) AC_MSG_ERROR([dolt: incompatible host, fatal error]) ;; | ||
27 | esac | ||
28 | AC_MSG_RESULT([yes, replacing libtool]) | ||
29 | |||
30 | dnl Start writing out doltcompile. | ||
31 | cat <<__DOLTCOMPILE__EOF__ >doltcompile | ||
32 | #!$DOLT_BASH | ||
33 | __DOLTCOMPILE__EOF__ | ||
34 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
35 | args=("$[]@") | ||
36 | for ((arg=0; arg<${#args@<:@@@:>@}; arg++)) ; do | ||
37 | if test x"${args@<:@$arg@:>@}" = x-o ; then | ||
38 | objarg=$((arg+1)) | ||
39 | break | ||
40 | fi | ||
41 | done | ||
42 | if test x$objarg = x ; then | ||
43 | echo 'Error: no -o on compiler command line' 1>&2 | ||
44 | exit 1 | ||
45 | fi | ||
46 | lo="${args@<:@$objarg@:>@}" | ||
47 | obj="${lo%.lo}" | ||
48 | if test x"$lo" = x"$obj" ; then | ||
49 | echo "Error: libtool object file name \"$lo\" does not end in .lo" 1>&2 | ||
50 | exit 1 | ||
51 | fi | ||
52 | objbase="${obj##*/}" | ||
53 | __DOLTCOMPILE__EOF__ | ||
54 | |||
55 | dnl Write out shared compilation code. | ||
56 | if test x$enable_shared = xyes; then | ||
57 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
58 | libobjdir="${obj%$objbase}.libs" | ||
59 | if test ! -d "$libobjdir" ; then | ||
60 | mkdir "$libobjdir" | ||
61 | mkdir_ret=$? | ||
62 | if test "$mkdir_ret" -ne 0 && test ! -d "$libobjdir" ; then | ||
63 | exit $mkdir_ret | ||
64 | fi | ||
65 | fi | ||
66 | pic_object="$libobjdir/$objbase.o" | ||
67 | args@<:@$objarg@:>@="$pic_object" | ||
68 | "${args@<:@@@:>@}" -fPIC -DPIC | ||
69 | __DOLTCOMPILE__EOF__ | ||
70 | fi | ||
71 | |||
72 | dnl Write out static compilation code. | ||
73 | dnl Avoid duplicate compiler output if also building shared objects. | ||
74 | if test x$enable_static = xyes; then | ||
75 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
76 | non_pic_object="$obj.o" | ||
77 | args@<:@$objarg@:>@="$non_pic_object" | ||
78 | __DOLTCOMPILE__EOF__ | ||
79 | if test x$enable_shared = xyes; then | ||
80 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
81 | "${args@<:@@@:>@}" >/dev/null 2>&1 | ||
82 | __DOLTCOMPILE__EOF__ | ||
83 | else | ||
84 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
85 | "${args@<:@@@:>@}" | ||
86 | __DOLTCOMPILE__EOF__ | ||
87 | fi | ||
88 | fi | ||
89 | |||
90 | dnl Write out the code to write the .lo file. | ||
91 | dnl The second line of the .lo file must match "^# Generated by .*libtool" | ||
92 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
93 | { | ||
94 | echo "# $lo - a libtool object file" | ||
95 | echo "# Generated by doltcompile, not libtool" | ||
96 | __DOLTCOMPILE__EOF__ | ||
97 | |||
98 | if test x$enable_shared = xyes; then | ||
99 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
100 | echo "pic_object='$pic_object'" | ||
101 | __DOLTCOMPILE__EOF__ | ||
102 | else | ||
103 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
104 | echo pic_object=none | ||
105 | __DOLTCOMPILE__EOF__ | ||
106 | fi | ||
107 | |||
108 | if test x$enable_static = xyes; then | ||
109 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
110 | echo "non_pic_object='$non_pic_object'" | ||
111 | __DOLTCOMPILE__EOF__ | ||
112 | else | ||
113 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
114 | echo non_pic_object=none | ||
115 | __DOLTCOMPILE__EOF__ | ||
116 | fi | ||
117 | |||
118 | cat <<'__DOLTCOMPILE__EOF__' >>doltcompile | ||
119 | } > "$lo" | ||
120 | __DOLTCOMPILE__EOF__ | ||
121 | |||
122 | dnl Done writing out doltcompile; substitute it for libtool compilation. | ||
123 | chmod +x doltcompile | ||
124 | LTCOMPILE='$(top_builddir)/doltcompile $(COMPILE)' | ||
125 | AC_SUBST(LTCOMPILE) | ||
126 | LTCXXCOMPILE='$(top_builddir)/doltcompile $(CXXCOMPILE)' | ||
127 | AC_SUBST(LTCXXCOMPILE) | ||
128 | # end dolt | ||
129 | ]) | ||
diff --git a/meta/packages/libtool/libtool-2.2.2/libdir-la.patch b/meta/packages/libtool/libtool-2.2.2/libdir-la.patch new file mode 100644 index 0000000000..a726cb2b8c --- /dev/null +++ b/meta/packages/libtool/libtool-2.2.2/libdir-la.patch | |||
@@ -0,0 +1,56 @@ | |||
1 | Index: libtool-2.2.2/libltdl/config/ltmain.m4sh | ||
2 | =================================================================== | ||
3 | --- libtool-2.2.2.orig/libltdl/config/ltmain.m4sh 2008-04-02 01:20:54.000000000 +0100 | ||
4 | +++ libtool-2.2.2/libltdl/config/ltmain.m4sh 2008-04-13 22:32:15.000000000 +0100 | ||
5 | @@ -4453,8 +4453,14 @@ | ||
6 | absdir="$abs_ladir" | ||
7 | libdir="$abs_ladir" | ||
8 | else | ||
9 | - dir="$libdir" | ||
10 | - absdir="$libdir" | ||
11 | + # Adding 'libdir' from the .la file to our library search paths | ||
12 | + # breaks crosscompilation horribly. We cheat here and don't add | ||
13 | + # it, instead adding the path where we found the .la. -CL | ||
14 | + dir="$abs_ladir" | ||
15 | + absdir="$abs_ladir" | ||
16 | + libdir="$abs_ladir" | ||
17 | + #dir="$libdir" | ||
18 | + #absdir="$libdir" | ||
19 | fi | ||
20 | test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes | ||
21 | else | ||
22 | @@ -4973,10 +4979,22 @@ | ||
23 | fi | ||
24 | ;; | ||
25 | *) | ||
26 | - path="-L$absdir/$objdir" | ||
27 | + # OE sets installed=no in staging. We need to look in $objdir and $absdir, | ||
28 | + # preferring $objdir. RP 31/04/2008 | ||
29 | + if test -f "$absdir/$objdir/$depdepl" ; then | ||
30 | + depdepl="$absdir/$objdir/$depdepl" | ||
31 | + path="-L$absdir/$objdir" | ||
32 | + elif test -f "$absdir/$depdepl" ; then | ||
33 | + depdepl="$absdir/$depdepl" | ||
34 | + path="-L$absdir" | ||
35 | + else | ||
36 | + path="-L$absdir/$objdir" | ||
37 | + fi | ||
38 | ;; | ||
39 | esac | ||
40 | else | ||
41 | + # This would break cross compiling if we didn't change to installed=no in | ||
42 | + # staging. RP 31/04/2008 | ||
43 | eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib` | ||
44 | test -z "$libdir" && \ | ||
45 | func_fatal_error "\`$deplib' is not a valid libtool archive" | ||
46 | @@ -7046,6 +7064,10 @@ | ||
47 | # Replace all uninstalled libtool libraries with the installed ones | ||
48 | newdependency_libs= | ||
49 | for deplib in $dependency_libs; do | ||
50 | + # Replacing uninstalled with installed can easily break crosscompilation, | ||
51 | + # since the installed path is generally the wrong architecture. -CL | ||
52 | + newdependency_libs="$newdependency_libs $deplib" | ||
53 | + continue | ||
54 | case $deplib in | ||
55 | *.la) | ||
56 | func_basename "$deplib" | ||
diff --git a/meta/packages/libtool/libtool-2.2.2/nousrlib.patch b/meta/packages/libtool/libtool-2.2.2/nousrlib.patch new file mode 100644 index 0000000000..5e3e6b9a91 --- /dev/null +++ b/meta/packages/libtool/libtool-2.2.2/nousrlib.patch | |||
@@ -0,0 +1,11 @@ | |||
1 | --- libtool-2.2.2/libltdl/config/ltmain.m4sh.orig | ||
2 | +++ libtool-2.2.2/libltdl/config/ltmain.m4sh | ||
3 | @@ -2637,8 +2637,6 @@ | ||
4 | add="$libdir/$linklib" | ||
5 | fi | ||
6 | else | ||
7 | - # We cannot seem to hardcode it, guess we'll fake it. | ||
8 | - add_dir="-L$libdir" | ||
9 | # Try looking first in the location we're being installed to. | ||
10 | if test -n "$inst_prefix_dir"; then | ||
11 | case "$libdir" in | ||
diff --git a/meta/packages/libtool/libtool-2.2.2/prefix.patch b/meta/packages/libtool/libtool-2.2.2/prefix.patch new file mode 100644 index 0000000000..d7bdfe1ef4 --- /dev/null +++ b/meta/packages/libtool/libtool-2.2.2/prefix.patch | |||
@@ -0,0 +1,100 @@ | |||
1 | Index: libtool-2.2.2/libltdl/m4/libtool.m4 | ||
2 | =================================================================== | ||
3 | --- libtool-2.2.2.orig/libltdl/m4/libtool.m4 2008-04-13 22:43:05.000000000 +0100 | ||
4 | +++ libtool-2.2.2/libltdl/m4/libtool.m4 2008-04-13 22:43:05.000000000 +0100 | ||
5 | @@ -89,7 +89,8 @@ | ||
6 | LIBTOOL_DEPS="$ltmain" | ||
7 | |||
8 | # Always use our own libtool. | ||
9 | -LIBTOOL='$(SHELL) $(top_builddir)/libtool' | ||
10 | +LIBTOOL='$(SHELL) $(top_builddir)' | ||
11 | +LIBTOOL="$LIBTOOL/$host_alias-libtool" | ||
12 | AC_SUBST(LIBTOOL)dnl | ||
13 | |||
14 | _LT_SETUP | ||
15 | @@ -211,7 +212,7 @@ | ||
16 | no_glob_subst='s/\*/\\\*/g' | ||
17 | |||
18 | # Global variables: | ||
19 | -ofile=libtool | ||
20 | +ofile=${host_alias}-libtool | ||
21 | can_build_shared=yes | ||
22 | |||
23 | # All known linkers require a `.a' archive for static linking (except MSVC, | ||
24 | Index: libtool-2.2.2/Makefile.am | ||
25 | =================================================================== | ||
26 | --- libtool-2.2.2.orig/Makefile.am 2008-04-01 19:06:08.000000000 +0100 | ||
27 | +++ libtool-2.2.2/Makefile.am 2008-04-13 22:49:17.000000000 +0100 | ||
28 | @@ -31,7 +31,7 @@ | ||
29 | DIST_SUBDIRS = . | ||
30 | EXTRA_DIST = | ||
31 | |||
32 | -BUILT_SOURCES = libtool | ||
33 | +BUILT_SOURCES = $(host_alias)-libtool | ||
34 | |||
35 | CLEANFILES = | ||
36 | MOSTLYCLEANFILES = | ||
37 | @@ -64,7 +64,7 @@ | ||
38 | ## ---------------- ## | ||
39 | |||
40 | # The libtool distributor and the standalone libtool script. | ||
41 | -bin_SCRIPTS = libtoolize libtool | ||
42 | +bin_SCRIPTS = libtoolize $(host_alias)-libtool | ||
43 | |||
44 | libtoolize: $(srcdir)/libtoolize.in $(top_builddir)/config.status | ||
45 | rm -f libtoolize.tmp libtoolize | ||
46 | @@ -90,8 +90,8 @@ | ||
47 | # We used to do this with a 'stamp-vcl' file, but non-gmake builds | ||
48 | # would rerun configure on every invocation, so now we manually | ||
49 | # check the version numbers from the build rule when necessary. | ||
50 | -libtool: $(top_builddir)/config.status $(srcdir)/$(auxdir)/ltmain.sh ChangeLog | ||
51 | - @target=libtool; $(rebuild); \ | ||
52 | +$(host_alias)-libtool: $(top_builddir)/config.status $(srcdir)/$(auxdir)/ltmain.sh ChangeLog | ||
53 | + @target=$(host_alias)-libtool; $(rebuild); \ | ||
54 | if test -f "$$target"; then \ | ||
55 | set dummy `./$$target --version | sed 1q`; actualver="$$5"; \ | ||
56 | test "$$actualver" = "$$correctver" && rebuild=false; \ | ||
57 | @@ -100,8 +100,8 @@ | ||
58 | case $$prereq in *ChangeLog);; *) rebuild=:;; esac; \ | ||
59 | done; \ | ||
60 | if $$rebuild; then \ | ||
61 | - echo $(SHELL) ./config.status $$target; \ | ||
62 | - cd $(top_builddir) && $(SHELL) ./config.status $$target; \ | ||
63 | + echo $(SHELL) ./config.status libtool; \ | ||
64 | + cd $(top_builddir) && $(SHELL) ./config.status libtool; \ | ||
65 | fi | ||
66 | |||
67 | .PHONY: configure-subdirs | ||
68 | @@ -145,7 +145,7 @@ | ||
69 | ChangeLog.1999 ChangeLog.2000 ChangeLog.2001 \ | ||
70 | ChangeLog.2002 ChangeLog.2003 ChangeLog.2004 \ | ||
71 | ChangeLog.2005 ChangeLog.2006 ChangeLog.2007 | ||
72 | -CLEANFILES += libtool libtoolize libtoolize.tmp \ | ||
73 | +CLEANFILES += $(host_alias)-libtool libtoolize libtoolize.tmp \ | ||
74 | $(auxdir)/ltmain.tmp $(m4dir)/ltversion.tmp | ||
75 | |||
76 | ## We build ltversion.m4 here, instead of from config.status, | ||
77 | @@ -483,12 +483,12 @@ | ||
78 | |||
79 | BUILDCHECK_ENVIRONMENT = _lt_pkgdatadir="$(abs_top_srcdir)" \ | ||
80 | LIBTOOLIZE="$(abs_top_builddir)/libtoolize" \ | ||
81 | - LIBTOOL="$(abs_top_builddir)/libtool" \ | ||
82 | + LIBTOOL="$(abs_top_builddir)/$(host_alias)-libtool" \ | ||
83 | tst_aclocaldir="$(abs_top_srcdir)/libltdl/m4" | ||
84 | |||
85 | INSTALLCHECK_ENVIRONMENT = \ | ||
86 | LIBTOOLIZE="$(bindir)/`echo libtoolize | sed '$(program_transform_name)'`" \ | ||
87 | - LIBTOOL="$(bindir)/`echo libtool | sed '$(program_transform_name)'`" \ | ||
88 | + LIBTOOL="$(bindir)/`echo $(host_alias)-libtool | sed '$(program_transform_name)'`" \ | ||
89 | LTDLINCL="-I$(includedir)" \ | ||
90 | LIBLTDL="$(libdir)/libltdl.la" \ | ||
91 | tst_aclocaldir="$(aclocaldir)" | ||
92 | @@ -620,7 +620,7 @@ | ||
93 | TESTS += $(FC_TESTS) | ||
94 | endif | ||
95 | |||
96 | -tests/demo-conf.test: libtool | ||
97 | +tests/demo-conf.test: $(host_alias)-libtool | ||
98 | |||
99 | EXTRA_DIST += $(srcdir)/tests/defs.in tests/defs.m4sh \ | ||
100 | $(COMMON_TESTS) $(CXX_TESTS) $(F77_TESTS) $(FC_TESTS) | ||
diff --git a/meta/packages/libtool/libtool-2.2.2/tag.patch b/meta/packages/libtool/libtool-2.2.2/tag.patch new file mode 100644 index 0000000000..8921a3efb7 --- /dev/null +++ b/meta/packages/libtool/libtool-2.2.2/tag.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- libtool-1.5.6/ltmain.in~tag 2004-05-15 05:14:32.000000000 -0400 | ||
7 | +++ libtool-1.5.6/ltmain.in 2004-05-15 05:18:01.000000000 -0400 | ||
8 | @@ -226,8 +226,9 @@ | ||
9 | # line option must be used. | ||
10 | if test -z "$tagname"; then | ||
11 | $echo "$modename: unable to infer tagged configuration" | ||
12 | - $echo "$modename: specify a tag with \`--tag'" 1>&2 | ||
13 | - exit $EXIT_FAILURE | ||
14 | + $echo "$modename: defaulting to \`CC'" | ||
15 | + $echo "$modename: if this is not correct, specify a tag with \`--tag'" | ||
16 | +# exit $EXIT_FAILURE | ||
17 | # else | ||
18 | # $echo "$modename: using $tagname tagged configuration" | ||
19 | fi | ||
diff --git a/meta/packages/libtool/libtool-2.2.2/uclibc.patch b/meta/packages/libtool/libtool-2.2.2/uclibc.patch new file mode 100644 index 0000000000..8573a01008 --- /dev/null +++ b/meta/packages/libtool/libtool-2.2.2/uclibc.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | --- libtool-2.2.2/libltdl/m4/libtool.m4.orig | ||
2 | +++ libtool-2.2.2/libltdl/m4/libtool.m4 | ||
3 | @@ -2221,6 +2221,11 @@ | ||
4 | lt_cv_deplibs_check_method=pass_all | ||
5 | ;; | ||
6 | |||
7 | +linux-uclibc*) | ||
8 | + lt_cv_deplibs_check_method=pass_all | ||
9 | + lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so` | ||
10 | + ;; | ||
11 | + | ||
12 | netbsd*) | ||
13 | if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then | ||
14 | lt_cv_deplibs_check_method='match_pattern /lib[[^/]]+(\.so\.[[0-9]]+\.[[0-9]]+|_pic\.a)$' | ||
diff --git a/meta/packages/libtool/libtool-cross_2.2.2.bb b/meta/packages/libtool/libtool-cross_2.2.2.bb new file mode 100644 index 0000000000..37643e5503 --- /dev/null +++ b/meta/packages/libtool/libtool-cross_2.2.2.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | require libtool.inc | ||
2 | require libtool_${PV}.bb | ||
3 | |||
4 | PR = "r12" | ||
5 | PACKAGES = "" | ||
6 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}" | ||
7 | SRC_URI_append = " file://libdir-la.patch;patch=1 \ | ||
8 | file://prefix.patch;patch=1 \ | ||
9 | # file://tag.patch;patch=1 \ | ||
10 | file://nousrlib.patch;patch=1" | ||
11 | |||
12 | DOLT_PATCH = "" | ||
13 | DOLT_PATCH_arm = " file://add_dolt.patch;patch=1" | ||
14 | DOLT_PATCH_i586 = " file://add_dolt.patch;patch=1" | ||
15 | |||
16 | #SRC_URI_append_linux = "${DOLT_PATCH}" | ||
17 | #SRC_URI_append_linux-gnueabi = "${DOLT_PATCH}" | ||
18 | |||
19 | S = "${WORKDIR}/libtool-${PV}" | ||
20 | |||
21 | prefix = "${STAGING_DIR_NATIVE}${layout_prefix}" | ||
22 | exec_prefix = "${STAGING_DIR_NATIVE}${layout_exec_prefix}" | ||
23 | bindir = "${STAGING_BINDIR_NATIVE}" | ||
24 | |||
25 | do_compile () { | ||
26 | : | ||
27 | } | ||
28 | |||
29 | do_stage () { | ||
30 | install -m 0755 ${HOST_SYS}-libtool ${bindir}/${HOST_SYS}-libtool | ||
31 | install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/ | ||
32 | install -d ${STAGING_DATADIR}/libtool ${STAGING_DATADIR}/aclocal | ||
33 | install -c ${S}/libltdl/config/config.guess ${STAGING_DATADIR}/libtool/ | ||
34 | install -c ${S}/libltdl/config/config.sub ${STAGING_DATADIR}/libtool/ | ||
35 | install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${STAGING_DATADIR}/libtool/ | ||
36 | install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${STAGING_DATADIR}/aclocal/ | ||
37 | install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${STAGING_DATADIR}/aclocal/ | ||
38 | install -c -m 0644 ${WORKDIR}/dolt.m4 ${STAGING_DATADIR}/aclocal/ | ||
39 | } | ||
40 | |||
41 | do_install () { | ||
42 | : | ||
43 | } | ||
diff --git a/meta/packages/libtool/libtool-native_2.2.2.bb b/meta/packages/libtool/libtool-native_2.2.2.bb new file mode 100644 index 0000000000..8b27424a6e --- /dev/null +++ b/meta/packages/libtool/libtool-native_2.2.2.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | require libtool.inc | ||
2 | require libtool_${PV}.bb | ||
3 | |||
4 | PR = "r9" | ||
5 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}" | ||
6 | SRC_URI_append = " file://libdir-la.patch;patch=1 \ | ||
7 | file://prefix.patch;patch=1 \ | ||
8 | # file://tag.patch;patch=1 \ | ||
9 | file://nousrlib.patch;patch=1" | ||
10 | |||
11 | S = "${WORKDIR}/libtool-${PV}" | ||
12 | |||
13 | inherit native | ||
14 | |||
15 | do_stage () { | ||
16 | install -m 0755 ${HOST_SYS}-libtool ${STAGING_BINDIR}/${HOST_SYS}-libtool | ||
17 | install -m 0755 libtoolize ${STAGING_BINDIR}/libtoolize | ||
18 | oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR} | ||
19 | install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/ | ||
20 | install -d ${STAGING_DATADIR}/libtool/config/ ${STAGING_DATADIR}/aclocal/ | ||
21 | install -c ${S}/libltdl/config/config.guess ${STAGING_DATADIR}/libtool/ | ||
22 | install -c ${S}/libltdl/config/config.sub ${STAGING_DATADIR}/libtool/ | ||
23 | install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${STAGING_DATADIR}/libtool/config/ | ||
24 | install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${STAGING_DATADIR}/aclocal/ | ||
25 | install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${STAGING_DATADIR}/aclocal/ | ||
26 | install -c -m 0644 ${S}/libltdl/m4/ltoptions.m4 ${STAGING_DATADIR}/aclocal/ | ||
27 | install -c -m 0644 ${S}/libltdl/m4/ltversion.m4 ${STAGING_DATADIR}/aclocal/ | ||
28 | install -c -m 0644 ${S}/libltdl/m4/ltsugar.m4 ${STAGING_DATADIR}/aclocal/ | ||
29 | install -c -m 0644 ${S}/libltdl/m4/lt~obsolete.m4 ${STAGING_DATADIR}/aclocal/ | ||
30 | } | ||
31 | |||
32 | do_install () { | ||
33 | : | ||
34 | } | ||
diff --git a/meta/packages/libtool/libtool_2.2.2.bb b/meta/packages/libtool/libtool_2.2.2.bb new file mode 100644 index 0000000000..0fa71b7c78 --- /dev/null +++ b/meta/packages/libtool/libtool_2.2.2.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | require libtool.inc | ||
2 | |||
3 | PR = "r5" | ||
4 | |||
5 | SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \ | ||
6 | file://uclibc.patch;patch=1 \ | ||
7 | file://dolt.m4" | ||
8 | S = "${WORKDIR}/libtool-${PV}" | ||
9 | |||
10 | DEFAULT_PREFERENCE = "-1" | ||
11 | |||
12 | PACKAGES =+ "libltdl libltdl-dev libltdl-dbg" | ||
13 | FILES_${PN} += "${datadir}/aclocal*" | ||
14 | FILES_libltdl = "${libdir}/libltdl.so.*" | ||
15 | FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h" | ||
16 | FILES_libltdl-dbg = "${libdir}/.debug/" | ||
17 | |||
18 | inherit autotools | ||
19 | |||
20 | EXTRA_AUTORECONF = "--exclude=libtoolize" | ||
21 | |||
22 | do_stage () { | ||
23 | oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR} | ||
24 | install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/ | ||
25 | } | ||