summaryrefslogtreecommitdiffstats
path: root/meta/packages/libtool/libtool/cross_compile.patch
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-06-21 03:46:34 -0700
committerSaul Wold <Saul.Wold@intel.com>2010-07-08 22:05:20 -0700
commitd42466ea43827f1c6a5a972819dac273e381d33d (patch)
tree72c6a9d981257dc2c3fd2173bc56657b20c1061e /meta/packages/libtool/libtool/cross_compile.patch
parentf516cfcac0b2d56aebe1da2a00301c669ca77ab9 (diff)
downloadpoky-d42466ea43827f1c6a5a972819dac273e381d33d.tar.gz
libtool family: upgrade from 2.2.6 to 2.2.10
This upgrades these recipes: libtool_2.2.6.bb -> libtool_2.2.10.bb libtool-native_2.2.6.bb -> libtool-native_2.2.10.bb libtool-cross_2.2.6.bb -> libtool-cross_2.2.10.bb libtool-nativesdk_2.2.6.bb -> libtool-nativesdk_2.2.10.bb Also fixes build failure caused by having aclocal.m4 built with older version of libtool. Rebased these patches for the newer version sources add_dolt.patch cross_compile.patch dolt.m4 Changed this patch to fix documentation building for non-x86 archs prefix.patch Rebased and changed to fix the building of ncurses recipe: trailingslash.patch Also updated metadata variables like LICENSE & LIC_CHKSUM_FILES Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/libtool/libtool/cross_compile.patch')
-rw-r--r--meta/packages/libtool/libtool/cross_compile.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/packages/libtool/libtool/cross_compile.patch b/meta/packages/libtool/libtool/cross_compile.patch
new file mode 100644
index 0000000000..fc1f4b6fb2
--- /dev/null
+++ b/meta/packages/libtool/libtool/cross_compile.patch
@@ -0,0 +1,55 @@
1Tweaks to make cross-compiling work combined and updated from various
2older patches, some by Chris Larson.
3Not upstreable in this form.
4
5RP - 01/05/2008
6
7Index: libtool-2.2.10/libltdl/config/ltmain.m4sh
8===================================================================
9--- libtool-2.2.10.orig/libltdl/config/ltmain.m4sh
10+++ libtool-2.2.10/libltdl/config/ltmain.m4sh
11@@ -5147,8 +5147,14 @@ func_mode_link ()
12 absdir="$abs_ladir"
13 libdir="$abs_ladir"
14 else
15- dir="$libdir"
16- absdir="$libdir"
17+ # Adding 'libdir' from the .la file to our library search paths
18+ # breaks crosscompilation horribly. We cheat here and don't add
19+ # it, instead adding the path where we found the .la. -CL
20+ dir="$abs_ladir"
21+ absdir="$abs_ladir"
22+ libdir="$abs_ladir"
23+ #dir="$libdir"
24+ #absdir="$libdir"
25 fi
26 test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes
27 else
28@@ -5519,8 +5525,6 @@ func_mode_link ()
29 add="$libdir/$linklib"
30 fi
31 else
32- # We cannot seem to hardcode it, guess we'll fake it.
33- add_dir="-L$libdir"
34 # Try looking first in the location we're being installed to.
35 if test -n "$inst_prefix_dir"; then
36 case $libdir in
37@@ -5667,7 +5671,17 @@ func_mode_link ()
38 fi
39 ;;
40 *)
41- path="-L$absdir/$objdir"
42+ # OE sets installed=no in staging. We need to look in $objdir and $absdir,
43+ # preferring $objdir. RP 31/04/2008
44+ if test -f "$absdir/$objdir/$depdepl" ; then
45+ depdepl="$absdir/$objdir/$depdepl"
46+ path="-L$absdir/$objdir"
47+ elif test -f "$absdir/$depdepl" ; then
48+ depdepl="$absdir/$depdepl"
49+ path="-L$absdir"
50+ else
51+ path="-L$absdir/$objdir"
52+ fi
53 ;;
54 esac
55 else