summaryrefslogtreecommitdiffstats
path: root/meta/packages/libsdl/libsdl-sdk_1.2.11.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-01-17 10:45:16 +0000
committerRichard Purdie <richard@openedhand.com>2008-01-17 10:45:16 +0000
commitd59f40bbf405eec59c68fbe93fa982fb4e2b2897 (patch)
tree45f6cefa2fc721d616142c081d3b356946dc339a /meta/packages/libsdl/libsdl-sdk_1.2.11.bb
parent6b21b82e745d603012ae35e38db470fbb4b46d40 (diff)
downloadpoky-d59f40bbf405eec59c68fbe93fa982fb4e2b2897.tar.gz
Add libsdl-sdk
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3505 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libsdl/libsdl-sdk_1.2.11.bb')
-rw-r--r--meta/packages/libsdl/libsdl-sdk_1.2.11.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/packages/libsdl/libsdl-sdk_1.2.11.bb b/meta/packages/libsdl/libsdl-sdk_1.2.11.bb
new file mode 100644
index 0000000000..ea65903824
--- /dev/null
+++ b/meta/packages/libsdl/libsdl-sdk_1.2.11.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Simple DirectMedia Layer - native Edition"
2HOMEPAGE = "http://www.libsdl.org"
3SECTION = "libs"
4LICENSE = "LGPL"
5DEPENDS = "libx11-sdk libxext-sdk libxrandr-sdk libxrender-sdk"
6RDEPENDS = "libx11-sdk libxrandr-sdk libxrender-sdk libxext-sdk"
7PR = "r2"
8
9SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
10 file://acinclude.m4 \
11 file://kernel-asm-page.patch;patch=1 "
12S = "${WORKDIR}/SDL-${PV}"
13
14inherit autotools binconfig pkgconfig sdk
15
16EXTRA_OECONF = "--disable-static --disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
17 --enable-file --disable-oss --disable-alsa --disable-esd --disable-arts \
18 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
19 --disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
20 --disable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
21 --disable-video-xbios --disable-video-gem --disable-video-dummy \
22 --disable-video-opengl --enable-input-events --enable-pthreads \
23 --disable-video-picogui --disable-video-qtopia --enable-dlopen"
24
25do_configure() {
26 rm -f ${S}/acinclude.m4
27 cp ${WORKDIR}/acinclude.m4 ${S}/
28 gnu-configize
29 oe_runconf
30 cd ${S}
31 # prevent libtool from linking libs against libstdc++, libgcc, ...
32 cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
33 mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
34}
35
36do_stage() {
37 autotools_stage_all
38 install -m 0644 build/libSDLmain.a ${STAGING_LIBDIR}
39}