summaryrefslogtreecommitdiffstats
path: root/meta/packages/libowl
diff options
context:
space:
mode:
authorEnric Balletbo i Serra <eballetbo@gmail.com>2009-07-09 20:35:30 +0200
committerRichard Purdie <rpurdie@linux.intel.com>2009-07-09 21:58:47 +0100
commit86e45a8c0c7a2430da209c650947f8cff3f8cc6b (patch)
tree1b19b292f7910effd414a39073827323a92b2c08 /meta/packages/libowl
parent915d91845f762bffe28e4ef3af600bec62cd9dc5 (diff)
downloadpoky-86e45a8c0c7a2430da209c650947f8cff3f8cc6b.tar.gz
libowl: Use autotools_stage instead of broken custom staging function
This patch also fixes claws-mail, leafpad, pcmanfm, pimlico and puzzles recipes using the proper include for owlwindowmenu.h Signed-off-by: Enric Balletbo i Serra <eballetbo@gmail.com> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/libowl')
-rw-r--r--meta/packages/libowl/libowl_svn.bb17
1 files changed, 1 insertions, 16 deletions
diff --git a/meta/packages/libowl/libowl_svn.bb b/meta/packages/libowl/libowl_svn.bb
index c6aacdf75c..80dcb6b861 100644
--- a/meta/packages/libowl/libowl_svn.bb
+++ b/meta/packages/libowl/libowl_svn.bb
@@ -21,19 +21,4 @@ SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=${PN};proto=http"
21 21
22S = "${WORKDIR}/${PN}" 22S = "${WORKDIR}/${PN}"
23 23
24inherit autotools pkgconfig 24inherit autotools_stage pkgconfig
25
26do_compile_prepend() {
27 # have to unstage the library first so that the tests build
28 rm -f ${STAGING_LIBDIR}/libowl.*
29 rm -f ${STAGING_INCDIR}/owl*.h
30}
31
32do_stage() {
33 headers=`eval ls libowl/owl*.h`
34 for header in $headers; do
35 hdr_base=`eval basename $header`
36 install -m 644 $header ${STAGING_INCDIR}/$hdr_base
37 done
38 install -m 644 libowl/.libs/libowl.a ${STAGING_LIBDIR}/
39}