summaryrefslogtreecommitdiffstats
path: root/meta/packages/libmad
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2006-09-01 18:01:05 +0000
committerChris Lord <chris@openedhand.com>2006-09-01 18:01:05 +0000
commitf1f8c5a6a7234a7b618f98efbb3d28e414890fa9 (patch)
treec102f2cf6c35a43ba5591eb4f53e01f97408653b /meta/packages/libmad
parentb89a8f8820c5322ed060e74bfae6181fb1602251 (diff)
downloadpoky-f1f8c5a6a7234a7b618f98efbb3d28e414890fa9.tar.gz
Add gstreamer 0.10 - Mostly packages from OE + updates and gstreamer
binary registry patch git-svn-id: https://svn.o-hand.com/repos/poky/trunk@694 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libmad')
-rw-r--r--meta/packages/libmad/libmad_0.15.0b.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/packages/libmad/libmad_0.15.0b.bb b/meta/packages/libmad/libmad_0.15.0b.bb
new file mode 100644
index 0000000000..b3614db05a
--- /dev/null
+++ b/meta/packages/libmad/libmad_0.15.0b.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "MPEG Audio Decoder Library"
2SECTION = "libs"
3PRIORITY = "optional"
4MAINTAINER = "Greg Gilbert <greg@treke.net>"
5DEPENDS = "libid3tag"
6LICENSE = "GPL"
7PR = "r2"
8
9SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libmad-${PV}.tar.gz"
10S = "${WORKDIR}/libmad-${PV}"
11
12inherit autotools
13
14EXTRA_OECONF = "-enable-speed --enable-shared"
15# The ASO's don't take any account of thumb...
16EXTRA_OECONF_append_thumb = " --disable-aso --enable-fpm=default"
17
18do_configure_prepend () {
19# damn picky automake...
20 touch NEWS AUTHORS ChangeLog
21}
22
23do_stage() {
24 oe_libinstall -so libmad ${STAGING_LIBDIR}
25 install -m 0644 mad.h ${STAGING_INCDIR}
26}