diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2008-01-11 16:10:23 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2008-01-11 16:10:23 +0000 |
commit | 78b5898fc93c309b68c76a9fe09c34e8045e228b (patch) | |
tree | de2465466e649dc55c13eb2b622f68c0494220d1 /meta/packages/libmad/files | |
parent | 4da5771577fc6424039bb4ef767d98dbc860888b (diff) | |
download | poky-78b5898fc93c309b68c76a9fe09c34e8045e228b.tar.gz |
libmad: add pkg-config support
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3469 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libmad/files')
-rw-r--r-- | meta/packages/libmad/files/add-pkgconfig.patch | 68 |
1 files changed, 68 insertions, 0 deletions
diff --git a/meta/packages/libmad/files/add-pkgconfig.patch b/meta/packages/libmad/files/add-pkgconfig.patch new file mode 100644 index 0000000000..636b27a928 --- /dev/null +++ b/meta/packages/libmad/files/add-pkgconfig.patch | |||
@@ -0,0 +1,68 @@ | |||
1 | Here is a patch for adding pkg-config support to libmad. | ||
2 | It would make life a bit easier for distro maintainers if this was applied. | ||
3 | In case you didn't know, pkg-config is a tool for providing LDFLAGS and | ||
4 | CFLAGS for packages using shared libraries. It's on freedesktop.org. | ||
5 | Debian has already been distributing the pkg-config file mad.pc with | ||
6 | libmad for some time, and people developing on debian (notably xmms2 | ||
7 | developers) have started relying on this support being present, causing | ||
8 | some confusion for people installing from source and on some BSDs which | ||
9 | do not provide mad.pc (google: pkgconfig libmad). | ||
10 | |||
11 | EMH | ||
12 | |||
13 | --h31gzZEtNLTqOjlF | ||
14 | Content-Type: text/plain; charset=us-ascii | ||
15 | Content-Disposition: attachment; filename="libmad-0.15.1b-pkgconfig.patch" | ||
16 | |||
17 | diff -Naur libmad-0.15.1b.old/configure.ac libmad-0.15.1b/configure.ac | ||
18 | --- libmad-0.15.1b.old/configure.ac 2004-01-23 10:41:32.000000000 +0100 | ||
19 | +++ libmad-0.15.1b/configure.ac 2004-08-07 02:25:24.633462168 +0200 | ||
20 | @@ -429,5 +429,5 @@ | ||
21 | dnl AC_SUBST(LTLIBOBJS) | ||
22 | |||
23 | AC_CONFIG_FILES([Makefile msvc++/Makefile \ | ||
24 | - libmad.list]) | ||
25 | + libmad.list mad.pc]) | ||
26 | AC_OUTPUT | ||
27 | diff -Naur libmad-0.15.1b.old/mad.pc.in libmad-0.15.1b/mad.pc.in | ||
28 | --- libmad-0.15.1b.old/mad.pc.in 1970-01-01 01:00:00.000000000 +0100 | ||
29 | +++ libmad-0.15.1b/mad.pc.in 2004-08-07 02:04:59.617692872 +0200 | ||
30 | @@ -0,0 +1,14 @@ | ||
31 | +# libmad pkg-config source file | ||
32 | + | ||
33 | +prefix=@prefix@ | ||
34 | +exec_prefix=@exec_prefix@ | ||
35 | +libdir=@libdir@ | ||
36 | +includedir=@includedir@ | ||
37 | + | ||
38 | +Name: mad | ||
39 | +Description: MPEG Audio Decoder | ||
40 | +Version: @VERSION@ | ||
41 | +Requires: | ||
42 | +Conflicts: | ||
43 | +Libs: -L${libdir} -lmad -lm | ||
44 | +Cflags: -I${includedir} | ||
45 | diff -Naur libmad-0.15.1b.old/Makefile.am libmad-0.15.1b/Makefile.am | ||
46 | --- libmad-0.15.1b.old/Makefile.am 2004-02-17 03:02:03.000000000 +0100 | ||
47 | +++ libmad-0.15.1b/Makefile.am 2004-08-07 02:03:19.859858368 +0200 | ||
48 | @@ -24,6 +24,9 @@ | ||
49 | SUBDIRS = | ||
50 | DIST_SUBDIRS = msvc++ | ||
51 | |||
52 | +pkgconfigdir = $(libdir)/pkgconfig | ||
53 | +pkgconfig_DATA = mad.pc | ||
54 | + | ||
55 | lib_LTLIBRARIES = libmad.la | ||
56 | include_HEADERS = mad.h | ||
57 | |||
58 | @@ -34,7 +37,8 @@ | ||
59 | minimad_LDADD = libmad.la | ||
60 | |||
61 | EXTRA_DIST = mad.h.sed \ | ||
62 | - CHANGES COPYRIGHT CREDITS README TODO VERSION | ||
63 | + CHANGES COPYRIGHT CREDITS README TODO VERSION \ | ||
64 | + mad.pc.in | ||
65 | |||
66 | exported_headers = version.h fixed.h bit.h timer.h stream.h frame.h \ | ||
67 | synth.h decoder.h | ||
68 | |||