diff options
author | Tomas Frydrych <tf@openedhand.com> | 2007-01-12 21:26:44 +0000 |
---|---|---|
committer | Tomas Frydrych <tf@openedhand.com> | 2007-01-12 21:26:44 +0000 |
commit | 2eebb483924654661dbf2429a8434d14afac55a9 (patch) | |
tree | 880e1e5e6526925a03551577470e67b76c7f7e50 /meta/packages/libgsf/libgsf_1.10.0.bb | |
parent | 81c9ad8b0f826c1aab3ebe1eff6ccb88141bf0ad (diff) | |
download | poky-2eebb483924654661dbf2429a8434d14afac55a9.tar.gz |
add recipes for packages needed to build AbiWord (based on OE, but tweaked for 2.5.x)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1140 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libgsf/libgsf_1.10.0.bb')
-rw-r--r-- | meta/packages/libgsf/libgsf_1.10.0.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/packages/libgsf/libgsf_1.10.0.bb b/meta/packages/libgsf/libgsf_1.10.0.bb new file mode 100644 index 0000000000..ce464feba9 --- /dev/null +++ b/meta/packages/libgsf/libgsf_1.10.0.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | LICENSE = "GPL" | ||
2 | SECTION = "libs" | ||
3 | PR = "r1" | ||
4 | |||
5 | DEPENDS= "libxml2 glib-2.0 zlib gtk-doc libbonobo gnome-vfs" | ||
6 | |||
7 | PACKAGES =+ "${PN}-gnome ${PN}-gnome-dev " | ||
8 | |||
9 | FILES_${PN}-gnome = "${libdir}/libgsf-gnome-1.so.*" | ||
10 | FILES_${PN}-gnome-dev = "${libdir}/libgsf-gnome-1.* ${includedir}/libgsf-1/gsf-gnome" | ||
11 | |||
12 | inherit autotools pkgconfig gnome | ||
13 | |||
14 | libgsf_includes = "gsf-doc-meta-data.h gsf-infile.h gsf-input-textline.h \ | ||
15 | gsf-outfile-zip.h gsf-output-stdio.h gsf-impl-utils.h \ | ||
16 | gsf-input-bzip.h gsf-input.h gsf-outfile.h gsf-output.h \ | ||
17 | gsf-infile-impl.h gsf-input-gzip.h gsf-libxml.h \ | ||
18 | gsf-output-bzip.h gsf-structured-blob.h gsf-infile-msole.h \ | ||
19 | gsf-input-impl.h gsf-msole-utils.h gsf-output-gzip.h \ | ||
20 | gsf-timestamp.h gsf-infile-msvba.h gsf-input-iochannel.h \ | ||
21 | gsf-outfile-impl.h gsf-output-impl.h gsf-utils.h \ | ||
22 | gsf-infile-stdio.h gsf-input-memory.h gsf-outfile-msole.h \ | ||
23 | gsf-output-iochannel.h gsf.h gsf-infile-zip.h gsf-input-stdio.h \ | ||
24 | gsf-outfile-stdio.h gsf-output-memory.h" | ||
25 | |||
26 | libgsf_gnome_includes = "gsf-input-gnomevfs.h \ | ||
27 | gsf-output-gnomevfs.h \ | ||
28 | gsf-input-bonobo.h \ | ||
29 | gsf-output-bonobo.h \ | ||
30 | gsf-shared-bonobo-stream.h" | ||
31 | |||
32 | do_stage() { | ||
33 | oe_libinstall -so -C gsf libgsf-1 ${STAGING_LIBDIR} | ||
34 | |||
35 | mkdir -p ${STAGING_INCDIR}/libgsf-1/gsf/ | ||
36 | for i in ${libgsf_includes}; do | ||
37 | install -m 0644 gsf/$i ${STAGING_INCDIR}/libgsf-1/gsf/$i | ||
38 | done | ||
39 | |||
40 | oe_libinstall -so -C gsf-gnome libgsf-gnome-1 ${STAGING_LIBDIR} | ||
41 | |||
42 | mkdir -p ${STAGING_INCDIR}/libgsf-1/gsf-gnome/ | ||
43 | for i in ${libgsf_gnome_includes}; do | ||
44 | install -m 0644 gsf-gnome/$i ${STAGING_INCDIR}/libgsf-1/gsf-gnome/$i | ||
45 | done | ||
46 | } | ||