summaryrefslogtreecommitdiffstats
path: root/meta/packages/libgcrypt/files
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-03-19 22:00:26 +0000
committerRichard Purdie <richard@openedhand.com>2008-03-19 22:00:26 +0000
commitce1e2f2df5b245382aa90fb37aae879faf87a570 (patch)
tree12a8f06a6b63d0a3db9a54cbd421f58e48158957 /meta/packages/libgcrypt/files
parentd36c1d83f5d7735fdbcbc654e01a6c7a0a2b9ef2 (diff)
downloadpoky-ce1e2f2df5b245382aa90fb37aae879faf87a570.tar.gz
libgcrypt: Upgrade to 1.2.4 and add pkgconfig support
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4081 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libgcrypt/files')
-rw-r--r--meta/packages/libgcrypt/files/add-pkgconfig-support.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/packages/libgcrypt/files/add-pkgconfig-support.patch b/meta/packages/libgcrypt/files/add-pkgconfig-support.patch
new file mode 100644
index 0000000000..9b00e8262a
--- /dev/null
+++ b/meta/packages/libgcrypt/files/add-pkgconfig-support.patch
@@ -0,0 +1,62 @@
1diff -Nur libgcrypt-1.2.4/configure.ac libgcrypt11-1.2.4/configure.ac
2--- libgcrypt-1.2.4/configure.ac 2007-02-01 19:41:06.000000000 +0100
3+++ libgcrypt11-1.2.4/configure.ac 2007-02-11 13:05:36.000000000 +0100
4@@ -808,6 +808,7 @@
5 src/Makefile
6 src/gcrypt.h
7 src/libgcrypt-config
8+src/libgcrypt.pc
9 tests/Makefile
10 w32-dll/Makefile
11 ])
12diff -Nur libgcrypt-1.2.4/src/libgcrypt.pc.in libgcrypt11-1.2.4/src/libgcrypt.pc.in
13--- libgcrypt-1.2.4/src/libgcrypt.pc.in 1970-01-01 01:00:00.000000000 +0100
14+++ libgcrypt11-1.2.4/src/libgcrypt.pc.in 2007-02-11 13:03:30.000000000 +0100
15@@ -0,0 +1,32 @@
16+# Process this file with autoconf to produce a pkg-config metadata file.
17+# Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation
18+# Author: Simon Josefsson
19+#
20+# This file is free software; as a special exception the author gives
21+# unlimited permission to copy and/or distribute it, with or without
22+# modifications, as long as this notice is preserved.
23+#
24+# This file is distributed in the hope that it will be useful, but
25+# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
26+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
27+
28+prefix=@prefix@
29+exec_prefix=@exec_prefix@
30+libdir=@libdir@
31+includedir=@includedir@
32+
33+# API info
34+api_version=@LIBGCRYPT_CONFIG_API_VERSION@
35+
36+# Misc information.
37+symmetric_ciphers=@LIBGCRYPT_CIPHERS@
38+asymmetric_ciphers=@LIBGCRYPT_PUBKEY_CIPHERS@
39+digests=@LIBGCRYPT_DIGESTS@
40+
41+Name: libgcrypt
42+Description: GNU crypto library
43+URL: http://www.gnupg.org
44+Version: @VERSION@
45+Libs: -L${libdir} @LIBGCRYPT_CONFIG_LIBS@
46+Libs.private: @GPG_ERROR_LIBS@
47+Cflags: -I${includedir} @LIBGCRYPT_CONFIG_CFLAGS@ @GPG_ERROR_CFLAGS@
48diff -Nur libgcrypt-1.2.4/src/Makefile.am libgcrypt11-1.2.4/src/Makefile.am
49--- libgcrypt-1.2.4/src/Makefile.am 2006-11-30 16:38:18.000000000 +0100
50+++ libgcrypt11-1.2.4/src/Makefile.am 2007-02-11 13:10:03.000000000 +0100
51@@ -27,6 +27,11 @@
52
53 lib_LTLIBRARIES = libgcrypt.la
54
55+# Pkg-config script.
56+pkgconfigdir = $(libdir)/pkgconfig
57+pkgconfig_DATA = libgcrypt.pc
58+DISTCLEANFILES = $(pkgconfig_DATA)
59+
60 if HAVE_LD_VERSION_SCRIPT
61 libgcrypt_version_script_cmd = -Wl,--version-script=$(srcdir)/libgcrypt.vers
62 else