diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-05 17:10:56 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-13 12:15:25 +0000 |
commit | 1d82f91348ad9e0bb98477c8c90ca99995b5a41d (patch) | |
tree | d4d869b8eabf2b38e9e7704c05a7f6dac86223f4 /meta/packages/jpeg | |
parent | 65d097ca22f62b48ac43f0233887154352ee4659 (diff) | |
download | poky-1d82f91348ad9e0bb98477c8c90ca99995b5a41d.tar.gz |
jpeg: Convert to BBCLASSEXTEND (and drop unneeded custom staging function
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/jpeg')
-rw-r--r-- | meta/packages/jpeg/jpeg-native_6b.bb | 13 | ||||
-rw-r--r-- | meta/packages/jpeg/jpeg_6b.bb | 14 |
2 files changed, 3 insertions, 24 deletions
diff --git a/meta/packages/jpeg/jpeg-native_6b.bb b/meta/packages/jpeg/jpeg-native_6b.bb deleted file mode 100644 index 2591a7ab18..0000000000 --- a/meta/packages/jpeg/jpeg-native_6b.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | SECTION = "libs" | ||
2 | require jpeg_${PV}.bb | ||
3 | inherit native | ||
4 | DEPENDS = "" | ||
5 | |||
6 | do_stage() { | ||
7 | install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h | ||
8 | install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h | ||
9 | install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h | ||
10 | install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h | ||
11 | install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h | ||
12 | oe_libinstall -so libjpeg ${STAGING_LIBDIR} | ||
13 | } | ||
diff --git a/meta/packages/jpeg/jpeg_6b.bb b/meta/packages/jpeg/jpeg_6b.bb index d64fb0996a..ea05c6d344 100644 --- a/meta/packages/jpeg/jpeg_6b.bb +++ b/meta/packages/jpeg/jpeg_6b.bb | |||
@@ -4,8 +4,9 @@ SECTION = "libs" | |||
4 | PRIORITY = "required" | 4 | PRIORITY = "required" |
5 | 5 | ||
6 | DEPENDS = "libtool-cross" | 6 | DEPENDS = "libtool-cross" |
7 | DEPENDS_virtclass-native = "libtool-native" | ||
7 | 8 | ||
8 | PR = "r6" | 9 | PR = "r7" |
9 | 10 | ||
10 | SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \ | 11 | SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \ |
11 | file://debian.patch;patch=1 \ | 12 | file://debian.patch;patch=1 \ |
@@ -25,15 +26,6 @@ do_configure_prepend () { | |||
25 | rm -f ${S}/ltmain.sh | 26 | rm -f ${S}/ltmain.sh |
26 | } | 27 | } |
27 | 28 | ||
28 | do_stage() { | ||
29 | install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h | ||
30 | install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h | ||
31 | install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h | ||
32 | install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h | ||
33 | install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h | ||
34 | oe_libinstall -so libjpeg ${STAGING_LIBDIR} | ||
35 | } | ||
36 | |||
37 | do_install() { | 29 | do_install() { |
38 | install -d ${D}${bindir} ${D}${includedir} \ | 30 | install -d ${D}${bindir} ${D}${includedir} \ |
39 | ${D}${mandir}/man1 ${D}${libdir} | 31 | ${D}${mandir}/man1 ${D}${libdir} |
@@ -43,4 +35,4 @@ do_install() { | |||
43 | PACKAGES =+ "jpeg-tools " | 35 | PACKAGES =+ "jpeg-tools " |
44 | FILES_jpeg-tools = "${bindir}/*" | 36 | FILES_jpeg-tools = "${bindir}/*" |
45 | 37 | ||
46 | 38 | BBCLASSEXTEND = "native" | |