summaryrefslogtreecommitdiffstats
path: root/meta/packages/iproute2/iproute2.inc
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-06-25 17:48:52 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-29 17:13:38 +0100
commitb180d7f488f44d3dfb3f9a19604e9592c29b426e (patch)
treedc198fec816ec648c27298f9c7869b592727a221 /meta/packages/iproute2/iproute2.inc
parent7510eb1061d0795b515bd20eba1cbd39a9b644a2 (diff)
downloadpoky-b180d7f488f44d3dfb3f9a19604e9592c29b426e.tar.gz
iproute: upgrade to 2.6.34
(borrow from OE 2.6.34 recipe) [Patches-poky] REMOVE _iproute2-2.6.15_no_strip.diff_: not required now REMOVE _new-flex-fix.patch_: not required now [Patches-OE] TAKE _configure-cross.patch_: don't invoke gcc directly [Recipes] - Add metadata - fix SRC_URI for new version - no {S} now - use alternative to enable 'ip' instead of using busybox - move shared documents to right destination - not take from OE: * no need for specific do_configure Signed-off-by Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/iproute2/iproute2.inc')
-rw-r--r--meta/packages/iproute2/iproute2.inc21
1 files changed, 15 insertions, 6 deletions
diff --git a/meta/packages/iproute2/iproute2.inc b/meta/packages/iproute2/iproute2.inc
index 0d7b11028a..7246b87e9b 100644
--- a/meta/packages/iproute2/iproute2.inc
+++ b/meta/packages/iproute2/iproute2.inc
@@ -1,18 +1,27 @@
1DESCRIPTION = "kernel routing and traffic control utilities" 1DESCRIPTION = "kernel routing and traffic control utilities"
2HOMEPAGE = "http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2"
2SECTION = "base" 3SECTION = "base"
3LICENSE = "GPL" 4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
6 file://ip/ip.c;md5=186731afa4b42e30b9b37efa4ec90b93"
4DEPENDS = "flex-native bison-native" 7DEPENDS = "flex-native bison-native"
5 8
6# Set SRCDATE in the .bb file 9inherit update-alternatives
7SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${P}-${SRCDATE}.tar.gz"
8
9S = "${WORKDIR}/${P}-${SRCDATE}"
10 10
11EXTRA_OEMAKE = "CC='${CC}' KERNEL_INCLUDE=${STAGING_KERNEL_DIR}/include DOCDIR=${docdir}/iproute2 SUBDIRS='lib tc ip' SBINDIR=/sbin" 11EXTRA_OEMAKE = "CC='${CC}' KERNEL_INCLUDE=${STAGING_KERNEL_DIR}/include DOCDIR=${docdir}/iproute2 SUBDIRS='lib tc ip' SBINDIR=/sbin"
12 12
13do_install () { 13do_install () {
14 oe_runmake DESTDIR=${D} install 14 oe_runmake DESTDIR=${D} install
15 mv ${D}${base_sbindir}/ip ${D}${base_sbindir}/ip.iproute2
16 install -d ${D}${datadir}
17 mv ${D}/share/* ${D}${datadir}/ || true
18 rm ${D}/share -rf || true
15} 19}
16 20
17FILES_${PN} += "/usr/lib/tc/*" 21FILES_${PN} += "/usr/lib/tc/*"
18FILES_${PN}-dbg += "/usr/lib/tc/.debug" 22FILES_${PN}-dbg += "/usr/lib/tc/.debug"
23
24ALTERNATIVE_NAME = "ip"
25ALTERNATIVE_PATH = "${base_sbindir}/ip.iproute2"
26ALTERNATIVE_LINK = "${base_bindir}/ip"
27ALTERNATIVE_PRIORITY = "100"