diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/ipkg | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/ipkg')
20 files changed, 190 insertions, 0 deletions
diff --git a/meta/packages/ipkg/files/terse.patch b/meta/packages/ipkg/files/terse.patch new file mode 100644 index 0000000000..3c4d6bed7e --- /dev/null +++ b/meta/packages/ipkg/files/terse.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
4 | # | ||
5 | |||
6 | --- C/ipkg_cmd.c~terse | ||
7 | +++ C/ipkg_cmd.c | ||
8 | @@ -148,9 +146,7 @@ | ||
9 | int result; | ||
10 | p_userdata = userdata; | ||
11 | result = (cmd->fun)(conf, argc, argv); | ||
12 | - if ( result == 0 ) { | ||
13 | - ipkg_message(conf, IPKG_NOTICE, "Successfully terminated.\n"); | ||
14 | - } else { | ||
15 | + if ( result != 0 ) { | ||
16 | ipkg_message(conf, IPKG_NOTICE, "An error ocurred, return value: %d.\n", result); | ||
17 | } | ||
18 | |||
diff --git a/meta/packages/ipkg/files/uclibc.patch b/meta/packages/ipkg/files/uclibc.patch new file mode 100644 index 0000000000..d0d3a3ff7c --- /dev/null +++ b/meta/packages/ipkg/files/uclibc.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: C/libbb/libbb.h | ||
2 | =================================================================== | ||
3 | --- C.orig/libbb/libbb.h 2003-02-24 10:31:52.000000000 -0500 | ||
4 | +++ C/libbb/libbb.h 2005-01-20 03:07:10.031420944 -0500 | ||
5 | @@ -340,7 +340,7 @@ | ||
6 | #define CONSOLE_DEV "/dev/console" | ||
7 | |||
8 | /* Cope with mmu-less systems somewhat gracefully */ | ||
9 | -#if defined(__UCLIBC__) && !defined(__UCLIBC_HAS_MMU__) | ||
10 | +#if defined(__UCLIBC__) && !defined(__ARCH_HAS_MMU__) | ||
11 | #define fork vfork | ||
12 | #endif | ||
13 | |||
diff --git a/meta/packages/ipkg/files/uninclude-replace.patch b/meta/packages/ipkg/files/uninclude-replace.patch new file mode 100644 index 0000000000..a3ed2201fd --- /dev/null +++ b/meta/packages/ipkg/files/uninclude-replace.patch | |||
@@ -0,0 +1,10 @@ | |||
1 | --- C/includes.h 2003-03-28 19:36:22.000000000 +0000 | ||
2 | +++ C/includes.h 2004-07-28 03:41:11.000000000 +0100 | ||
3 | @@ -48,6 +48,6 @@ | ||
4 | # include <unistd.h> | ||
5 | #endif | ||
6 | |||
7 | -#include "replace/replace.h" | ||
8 | +//#include "replace/replace.h" | ||
9 | |||
10 | #endif | ||
diff --git a/meta/packages/ipkg/ipkg-collateral.bb b/meta/packages/ipkg/ipkg-collateral.bb new file mode 100644 index 0000000000..a4f7bb7e3a --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "ipkg configuration files" | ||
2 | SECTION = "base" | ||
3 | LICENSE = "MIT" | ||
4 | PR = "r2" | ||
5 | |||
6 | SRC_URI = " \ | ||
7 | file://ipkg.conf.comments \ | ||
8 | file://lists \ | ||
9 | file://dest \ | ||
10 | file://src \ | ||
11 | " | ||
12 | |||
13 | do_compile () { | ||
14 | cat ${WORKDIR}/ipkg.conf.comments >${WORKDIR}/ipkg.conf | ||
15 | cat ${WORKDIR}/src >>${WORKDIR}/ipkg.conf | ||
16 | cat ${WORKDIR}/dest >>${WORKDIR}/ipkg.conf | ||
17 | cat ${WORKDIR}/lists >>${WORKDIR}/ipkg.conf | ||
18 | } | ||
19 | |||
20 | do_install () { | ||
21 | install -d ${D}${sysconfdir}/ | ||
22 | install -m 0644 ${WORKDIR}/ipkg.conf ${D}${sysconfdir}/ipkg.conf | ||
23 | } | ||
diff --git a/meta/packages/ipkg/ipkg-collateral/akita/dest b/meta/packages/ipkg/ipkg-collateral/akita/dest new file mode 100644 index 0000000000..647490d30a --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/akita/dest | |||
@@ -0,0 +1,4 @@ | |||
1 | dest root / | ||
2 | dest home /home/packages/ | ||
3 | dest cf /media/cf/packages/ | ||
4 | dest sd /media/card/packages/ | ||
diff --git a/meta/packages/ipkg/ipkg-collateral/akita/lists b/meta/packages/ipkg/ipkg-collateral/akita/lists new file mode 100644 index 0000000000..cc776c595b --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/akita/lists | |||
@@ -0,0 +1,4 @@ | |||
1 | |||
2 | # Uncomment to move ipkg server-data into RAM | ||
3 | # lists_dir ext /var/lib/ipkg | ||
4 | |||
diff --git a/meta/packages/ipkg/ipkg-collateral/collie/dest b/meta/packages/ipkg/ipkg-collateral/collie/dest new file mode 100644 index 0000000000..c76101a5b2 --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/collie/dest | |||
@@ -0,0 +1,4 @@ | |||
1 | dest root / | ||
2 | dest cf /media/cf/packages/ | ||
3 | dest sd /media/card/packages/ | ||
4 | dest ram /media/ram/packages/ | ||
diff --git a/meta/packages/ipkg/ipkg-collateral/dest b/meta/packages/ipkg/ipkg-collateral/dest new file mode 100644 index 0000000000..088ca403da --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/dest | |||
@@ -0,0 +1 @@ | |||
dest root / | |||
diff --git a/meta/packages/ipkg/ipkg-collateral/ipkg.conf.comments b/meta/packages/ipkg/ipkg-collateral/ipkg.conf.comments new file mode 100644 index 0000000000..51623f4d53 --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/ipkg.conf.comments | |||
@@ -0,0 +1,23 @@ | |||
1 | # Must have one or more source entries of the form: | ||
2 | # | ||
3 | # src <src-name> <source-url> | ||
4 | # | ||
5 | # and one or more destination entries of the form: | ||
6 | # | ||
7 | # dest <dest-name> <target-path> | ||
8 | # | ||
9 | # where <src-name> and <dest-names> are identifiers that | ||
10 | # should match [a-zA-Z0-9._-]+, <source-url> should be a | ||
11 | # URL that points to a directory containing a Familiar | ||
12 | # Packages file, and <target-path> should be a directory | ||
13 | # that exists on the target system. | ||
14 | |||
15 | # Proxy Support | ||
16 | #option http_proxy http://proxy.tld:3128 | ||
17 | #option ftp_proxy http://proxy.tld:3128 | ||
18 | #option proxy_username <username> | ||
19 | #option proxy_password <password> | ||
20 | |||
21 | # Offline mode (for use in constructing flash images offline) | ||
22 | #option offline_root target | ||
23 | |||
diff --git a/meta/packages/ipkg/ipkg-collateral/jornada56x/dest b/meta/packages/ipkg/ipkg-collateral/jornada56x/dest new file mode 100644 index 0000000000..154ce57587 --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/jornada56x/dest | |||
@@ -0,0 +1,4 @@ | |||
1 | dest root / | ||
2 | dest cf /mnt/cf/packages/ | ||
3 | dest sd /mnt/card/packages/ | ||
4 | dest ram /mnt/ram/packages/ | ||
diff --git a/meta/packages/ipkg/ipkg-collateral/lists b/meta/packages/ipkg/ipkg-collateral/lists new file mode 100644 index 0000000000..3c524f8c77 --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/lists | |||
@@ -0,0 +1,2 @@ | |||
1 | lists_dir ext /var/lib/ipkg | ||
2 | |||
diff --git a/meta/packages/ipkg/ipkg-collateral/openmn/src b/meta/packages/ipkg/ipkg-collateral/openmn/src new file mode 100644 index 0000000000..97cdd4741c --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/openmn/src | |||
@@ -0,0 +1 @@ | |||
src mnci54 http://www.mn-solutions.de/feed/mnci54/base | |||
diff --git a/meta/packages/ipkg/ipkg-collateral/poodle/dest b/meta/packages/ipkg/ipkg-collateral/poodle/dest new file mode 100644 index 0000000000..9379964e57 --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/poodle/dest | |||
@@ -0,0 +1,4 @@ | |||
1 | dest root / | ||
2 | dest cf /media/cf/packages/ | ||
3 | dest sd /media/card/packages/ | ||
4 | dest home /home/packages/ | ||
diff --git a/meta/packages/ipkg/ipkg-collateral/simpad/dest b/meta/packages/ipkg/ipkg-collateral/simpad/dest new file mode 100644 index 0000000000..20d03ba822 --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/simpad/dest | |||
@@ -0,0 +1,3 @@ | |||
1 | dest root / | ||
2 | dest cf /mnt/cf/packages/ | ||
3 | dest ram /mnt/ram/packages/ | ||
diff --git a/meta/packages/ipkg/ipkg-collateral/src b/meta/packages/ipkg/ipkg-collateral/src new file mode 100644 index 0000000000..e69de29bb2 --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/src | |||
diff --git a/meta/packages/ipkg/ipkg-collateral/tosa/dest b/meta/packages/ipkg/ipkg-collateral/tosa/dest new file mode 100644 index 0000000000..c76101a5b2 --- /dev/null +++ b/meta/packages/ipkg/ipkg-collateral/tosa/dest | |||
@@ -0,0 +1,4 @@ | |||
1 | dest root / | ||
2 | dest cf /media/cf/packages/ | ||
3 | dest sd /media/card/packages/ | ||
4 | dest ram /media/ram/packages/ | ||
diff --git a/meta/packages/ipkg/ipkg-native.inc b/meta/packages/ipkg/ipkg-native.inc new file mode 100644 index 0000000000..b52b7b5e20 --- /dev/null +++ b/meta/packages/ipkg/ipkg-native.inc | |||
@@ -0,0 +1,12 @@ | |||
1 | # NOTE: ipkg now obeys ${libdir}, so ipkg-native now installs | ||
2 | # things into the wrong location inside of offline_root. Backup | ||
3 | # the target libdir and use that. | ||
4 | target_libdir := "${libdir}" | ||
5 | |||
6 | inherit native | ||
7 | |||
8 | EXTRA_OECONF += "--with-ipkgdir=${target_libdir}/ipkg" | ||
9 | |||
10 | DEPENDS = "libtool-native automake-native" | ||
11 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/ipkg-${PV}" | ||
12 | PROVIDES = "" | ||
diff --git a/meta/packages/ipkg/ipkg-native_0.99.154.bb b/meta/packages/ipkg/ipkg-native_0.99.154.bb new file mode 100644 index 0000000000..d59eab3a61 --- /dev/null +++ b/meta/packages/ipkg/ipkg-native_0.99.154.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | include ipkg_${PV}.bb | ||
2 | include ipkg-native.inc | ||
diff --git a/meta/packages/ipkg/ipkg.inc b/meta/packages/ipkg/ipkg.inc new file mode 100644 index 0000000000..8fc6c9efe0 --- /dev/null +++ b/meta/packages/ipkg/ipkg.inc | |||
@@ -0,0 +1,56 @@ | |||
1 | DESCRIPTION = "Itsy Package Manager" | ||
2 | DESCRIPTION_libipkg = "Itsy Package Manager Library" | ||
3 | SECTION = "base" | ||
4 | LICENSE = "GPL" | ||
5 | PROVIDES = "virtual/ipkg libipkg" | ||
6 | |||
7 | PACKAGES =+ "libipkg-dev libipkg" | ||
8 | FILES_libipkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so" | ||
9 | FILES_libipkg = "${libdir}" | ||
10 | AUTO_LIBNAME_PKGS = "libipkg" | ||
11 | |||
12 | SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')} \ | ||
13 | file://terse.patch;patch=1" | ||
14 | |||
15 | S = "${WORKDIR}/ipkg/C" | ||
16 | |||
17 | inherit autotools pkgconfig | ||
18 | |||
19 | # Define a variable to allow distros to run configure earlier. | ||
20 | # (for example, to enable loading of ethernet kernel modules before networking starts) | ||
21 | IPKG_INIT_POSITION = "98" | ||
22 | IPKG_INIT_POSITION_slugos = "41" | ||
23 | |||
24 | pkg_postinst_ipkg () { | ||
25 | #!/bin/sh | ||
26 | if [ "x$D" != "x" ]; then | ||
27 | install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d | ||
28 | # this happens at S98 where our good 'ole packages script used to run | ||
29 | echo -e "#!/bin/sh | ||
30 | ipkg-cl configure | ||
31 | " > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${IPKG_INIT_POSITION}configure | ||
32 | chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${IPKG_INIT_POSITION}configure | ||
33 | fi | ||
34 | |||
35 | update-alternatives --install ${bindir}/ipkg ipkg ${bindir}/ipkg-cl 100 | ||
36 | } | ||
37 | |||
38 | pkg_postrm_ipkg () { | ||
39 | #!/bin/sh | ||
40 | update-alternatives --remove ipkg ${bindir}/ipkg-cl | ||
41 | } | ||
42 | |||
43 | do_stage() { | ||
44 | oe_libinstall -so libipkg ${STAGING_LIBDIR} | ||
45 | install -d ${STAGING_INCDIR}/replace/ | ||
46 | install -m 0644 replace/replace.h ${STAGING_INCDIR}/replace/ | ||
47 | install -d ${STAGING_INCDIR}/libipkg/ | ||
48 | for f in *.h | ||
49 | do | ||
50 | install -m 0644 $f ${STAGING_INCDIR}/libipkg/ | ||
51 | done | ||
52 | } | ||
53 | |||
54 | # | ||
55 | # FIXME: Install /etc/ipkg.conf and /etc/ipkg/arch.conf | ||
56 | # | ||
diff --git a/meta/packages/ipkg/ipkg_0.99.154.bb b/meta/packages/ipkg/ipkg_0.99.154.bb new file mode 100644 index 0000000000..de6af147b6 --- /dev/null +++ b/meta/packages/ipkg/ipkg_0.99.154.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | include ipkg.inc | ||
2 | PR = "r3" | ||