diff options
author | Richard Purdie <richard@openedhand.com> | 2007-06-13 23:33:43 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2007-06-13 23:33:43 +0000 |
commit | f932b25caa2c9aad04184ec0e00ab7f977e2c532 (patch) | |
tree | 3020e409f3812e3a2fc87de0693c0099126b21ac /meta/packages/ipkg-utils | |
parent | 8f9dc2cb572a247238f8a15a527a4dd5383dc7fd (diff) | |
download | poky-f932b25caa2c9aad04184ec0e00ab7f977e2c532.tar.gz |
ipkg-utils: Add ipkg-list-fields python script needed for sdk generation
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1931 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/ipkg-utils')
3 files changed, 75 insertions, 4 deletions
diff --git a/meta/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb b/meta/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb index c57c14333a..b63bc67af7 100644 --- a/meta/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb +++ b/meta/packages/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | require ipkg-utils_${PV}.bb | 1 | require ipkg-utils_${PV}.bb |
2 | 2 | ||
3 | RDEPENDS = "" | 3 | RDEPENDS = "" |
4 | PR = "r13" | 4 | PR = "r14" |
5 | 5 | ||
6 | inherit native | 6 | inherit native |
7 | 7 | ||
diff --git a/meta/packages/ipkg-utils/ipkg-utils/fields_tweaks.patch b/meta/packages/ipkg-utils/ipkg-utils/fields_tweaks.patch new file mode 100644 index 0000000000..2b08e47ad0 --- /dev/null +++ b/meta/packages/ipkg-utils/ipkg-utils/fields_tweaks.patch | |||
@@ -0,0 +1,70 @@ | |||
1 | --- | ||
2 | Makefile | 2 ++ | ||
3 | ipkg-list-fields | 13 +++++++++++++ | ||
4 | ipkg.py | 8 +++++++- | ||
5 | 3 files changed, 22 insertions(+), 1 deletion(-) | ||
6 | |||
7 | Index: ipkg-utils/Makefile | ||
8 | =================================================================== | ||
9 | --- ipkg-utils.orig/Makefile 2007-06-13 22:45:47.000000000 +0100 | ||
10 | +++ ipkg-utils/Makefile 2007-06-13 22:46:50.000000000 +0100 | ||
11 | @@ -15,6 +15,8 @@ install: ${UTILS} | ||
12 | python setup.py install | ||
13 | chmod agu+rx ipkg-make-index | ||
14 | cp -f ipkg-make-index $(PREFIX)/bin | ||
15 | + chmod agu+rx ipkg-list-fields | ||
16 | + cp -f ipkg-list-fields $(PREFIX)/bin | ||
17 | |||
18 | binary: build | ||
19 | mkdir -p ipkg-build-binary/usr/bin | ||
20 | Index: ipkg-utils/ipkg-list-fields | ||
21 | =================================================================== | ||
22 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
23 | +++ ipkg-utils/ipkg-list-fields 2007-06-13 22:43:32.000000000 +0100 | ||
24 | @@ -0,0 +1,13 @@ | ||
25 | +#!/usr/bin/python | ||
26 | + | ||
27 | +import sys, ipkg | ||
28 | + | ||
29 | +def usage(): | ||
30 | + sys.stderr.write("%s ipk\n" % (sys.argv[0],)) | ||
31 | + sys.exit(-1) | ||
32 | + | ||
33 | +if (len(sys.argv) < 2): | ||
34 | + usage() | ||
35 | + | ||
36 | +print ipkg.Package(sys.argv[1]) | ||
37 | + | ||
38 | Index: ipkg-utils/ipkg.py | ||
39 | =================================================================== | ||
40 | --- ipkg-utils.orig/ipkg.py 2007-06-13 22:44:50.000000000 +0100 | ||
41 | +++ ipkg-utils/ipkg.py 2007-06-13 22:39:44.000000000 +0100 | ||
42 | @@ -139,6 +139,9 @@ class Package: | ||
43 | self.installed_size = None | ||
44 | self.filename = None | ||
45 | self.isdeb = 0 | ||
46 | + self.homepage = None | ||
47 | + self.oe = None | ||
48 | + self.priority = None | ||
49 | self.fn = fn | ||
50 | |||
51 | if fn: | ||
52 | @@ -211,7 +214,7 @@ class Package: | ||
53 | elif self.__dict__.has_key(name): | ||
54 | self.__dict__[name] = value | ||
55 | else: | ||
56 | - #print "Lost field %s, %s" % (name,value) | ||
57 | + print "Lost field %s, %s" % (name,value) | ||
58 | pass | ||
59 | |||
60 | if line and line[0] == '\n': | ||
61 | @@ -402,6 +405,9 @@ class Package: | ||
62 | if self.filename: out = out + "Filename: %s\n" % (self.filename) | ||
63 | if self.source: out = out + "Source: %s\n" % (self.source) | ||
64 | if self.description: out = out + "Description: %s\n" % (self.description) | ||
65 | + if self.oe: out = out + "OE: %s\n" % (self.oe) | ||
66 | + if self.homepage: out = out + "HomePage: %s\n" % (self.homepage) | ||
67 | + if self.priority: out = out + "Priority: %s\n" % (self.priority) | ||
68 | out = out + "\n" | ||
69 | |||
70 | return out | ||
diff --git a/meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb b/meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb index e8f52b65a4..cdf5efde0c 100644 --- a/meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb +++ b/meta/packages/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb | |||
@@ -5,17 +5,18 @@ LICENSE = "GPL" | |||
5 | CONFLICTS = "ipkg-link" | 5 | CONFLICTS = "ipkg-link" |
6 | RDEPENDS = "python" | 6 | RDEPENDS = "python" |
7 | SRCDATE = "20050404" | 7 | SRCDATE = "20050404" |
8 | PR = "r15" | 8 | PR = "r16" |
9 | 9 | ||
10 | SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils \ | 10 | SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils \ |
11 | file://ipkg-utils-fix.patch;patch=1 \ | 11 | file://ipkg-utils-fix.patch;patch=1 \ |
12 | file://ipkg-py-sane-vercompare.patch;patch=1 \ | 12 | file://ipkg-py-sane-vercompare.patch;patch=1 \ |
13 | file://ipkg-py-tarfile.patch;patch=1 \ | 13 | file://ipkg-py-tarfile.patch;patch=1 \ |
14 | file://ipkg-make-index-track-stamps.patch;patch=1" | 14 | file://ipkg-make-index-track-stamps.patch;patch=1 \ |
15 | file://fields_tweaks.patch;patch=1 " | ||
15 | 16 | ||
16 | S = "${WORKDIR}/ipkg-utils" | 17 | S = "${WORKDIR}/ipkg-utils" |
17 | 18 | ||
18 | INSTALL = "ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload ipkg-make-index ipkg-link ipkg.py" | 19 | INSTALL = "ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload ipkg-make-index ipkg-link ipkg.py ipkg-list-fields" |
19 | 20 | ||
20 | do_compile() { | 21 | do_compile() { |
21 | oe_runmake ipkg-compare-versions | 22 | oe_runmake ipkg-compare-versions |