summaryrefslogtreecommitdiffstats
path: root/meta/packages/images
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:45:19 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:45:19 +0000
commitd95941bb511fbef48afb0ff9c87cbe14b309b486 (patch)
treeb379edf34009ae3422644daa789e08926448d09c /meta/packages/images
parentb2f192faabe412adce79534e22efe9fb69ee40e2 (diff)
downloadpoky-d95941bb511fbef48afb0ff9c87cbe14b309b486.tar.gz
Move tasks into packages/tasks, images into packages/images, remove bootstrap-image
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@531 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/images')
-rw-r--r--meta/packages/images/oh-image-devel.bb24
-rw-r--r--meta/packages/images/oh-image-minimal.bb21
-rw-r--r--meta/packages/images/oh-image-sdk.bb27
-rw-r--r--meta/packages/images/oh-image.bb22
4 files changed, 94 insertions, 0 deletions
diff --git a/meta/packages/images/oh-image-devel.bb b/meta/packages/images/oh-image-devel.bb
new file mode 100644
index 0000000000..2865151b03
--- /dev/null
+++ b/meta/packages/images/oh-image-devel.bb
@@ -0,0 +1,24 @@
1PR = "r9"
2
3export IMAGE_BASENAME = "oh-devel"
4
5GUI_MACHINE_CLASS ?= "none"
6
7XSERVER ?= "xserver-kdrive-fbdev"
8
9DEPENDS = "task-oh"
10
11RDEPENDS = "\
12 task-oh-boot \
13 task-oh-boot-extras \
14 task-oh-base \
15 task-oh-standard \
16 task-oh-devtools \
17 task-oh-testapps \
18 ${XSERVER} "
19
20export IPKG_INSTALL = "${RDEPENDS}"
21#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
22
23inherit image_ipk
24LICENSE = MIT
diff --git a/meta/packages/images/oh-image-minimal.bb b/meta/packages/images/oh-image-minimal.bb
new file mode 100644
index 0000000000..b1e2050a1c
--- /dev/null
+++ b/meta/packages/images/oh-image-minimal.bb
@@ -0,0 +1,21 @@
1PR = "r0"
2
3export IMAGE_BASENAME = "oh-image-minimal"
4
5GUI_MACHINE_CLASS ?= "none"
6
7XSERVER ?= "xserver-kdrive-fbdev"
8
9DEPENDS = "task-oh"
10
11RDEPENDS = "\
12 task-oh-boot \
13 task-oh-boot-min-extras \
14 task-oh-base \
15 ${XSERVER} "
16
17export IPKG_INSTALL = "${RDEPENDS}"
18#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
19
20inherit image_ipk
21LICENSE = MIT
diff --git a/meta/packages/images/oh-image-sdk.bb b/meta/packages/images/oh-image-sdk.bb
new file mode 100644
index 0000000000..b5dfee740c
--- /dev/null
+++ b/meta/packages/images/oh-image-sdk.bb
@@ -0,0 +1,27 @@
1PR = "r9"
2
3export IMAGE_BASENAME = "oh-sdk"
4
5GUI_MACHINE_CLASS ?= "none"
6
7XSERVER ?= "xserver-kdrive-fbdev"
8
9DEPENDS = "\
10 task-oh \
11 task-oh-sdk"
12
13RDEPENDS = "\
14 task-oh-boot \
15 task-oh-boot-extras \
16 task-oh-base \
17 task-oh-standard \
18 task-oh-devtools \
19 task-oh-testapps \
20 task-oh-sdk \
21 ${XSERVER} "
22
23export IPKG_INSTALL = "${RDEPENDS}"
24#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
25
26inherit image_ipk
27LICENSE = MIT
diff --git a/meta/packages/images/oh-image.bb b/meta/packages/images/oh-image.bb
new file mode 100644
index 0000000000..7750eeb6f8
--- /dev/null
+++ b/meta/packages/images/oh-image.bb
@@ -0,0 +1,22 @@
1PR = "r10"
2
3export IMAGE_BASENAME = "oh-image"
4
5GUI_MACHINE_CLASS ?= "none"
6
7XSERVER ?= "xserver-kdrive-fbdev"
8
9DEPENDS = "task-oh"
10
11RDEPENDS = "\
12 task-oh-boot \
13 task-oh-boot-extras \
14 task-oh-base \
15 task-oh-standard \
16 ${XSERVER} "
17
18export IPKG_INSTALL = "${RDEPENDS}"
19#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
20
21inherit image_ipk
22LICENSE = MIT