diff options
author | Rusty Lynch <rusty.lynch@intel.com> | 2008-10-22 04:21:53 -0700 |
---|---|---|
committer | Rusty Lynch <rusty.lynch@intel.com> | 2008-10-22 04:21:53 -0700 |
commit | ca7fa46814bb7386c74e32c1f452aa8fb0906d67 (patch) | |
tree | 25350b020aa7c5578855a285c6b0a811937f9e68 /meta/packages/helix/ribosome.bb | |
parent | 06db259785557c31b2d07a3e5e181eb052e47754 (diff) | |
download | poky-ca7fa46814bb7386c74e32c1f452aa8fb0906d67.tar.gz |
* Adding initial ribosome (helix build system) and helix-libs recipes
Diffstat (limited to 'meta/packages/helix/ribosome.bb')
-rw-r--r-- | meta/packages/helix/ribosome.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/packages/helix/ribosome.bb b/meta/packages/helix/ribosome.bb new file mode 100644 index 0000000000..4339a6ce49 --- /dev/null +++ b/meta/packages/helix/ribosome.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | DESCRIPTION = "Ribosome: HelixCommunity Build System" | ||
2 | SECTION = "base" | ||
3 | HOMEPAGE = "http://helixcommunity.org" | ||
4 | LICENSE = "GPLv2" | ||
5 | |||
6 | _SNAPSHOT = "22102008" | ||
7 | _TARBALL_SERVER = "http://git.moblin.org/repos/users/rusty" | ||
8 | |||
9 | PV="r0" | ||
10 | |||
11 | SRC_URI = "${_TARBALL_SERVER}/ribosome-${_SNAPSHOT}.tar.bz2 \ | ||
12 | ${_TARBALL_SERVER}/client-bif-${_SNAPSHOT}.tar.bz2 \ | ||
13 | ${_TARBALL_SERVER}/common-bif-${_SNAPSHOT}.tar.bz2 \ | ||
14 | file://ribosome/clutter.bif \ | ||
15 | file://ribosome/buildrc" | ||
16 | |||
17 | S = "${WORKDIR}" | ||
18 | |||
19 | do_stage() { | ||
20 | # Install build system of doom | ||
21 | install -d ${STAGING_DIR_HOST}${libdir} | ||
22 | cp -a ribosome-${_SNAPSHOT} ${STAGING_DIR_HOST}${libdir}/ribosome | ||
23 | install -m 0644 ribosome/buildrc ${STAGING_DIR_HOST}${libdir}/ribosome/ | ||
24 | |||
25 | # Install client BIF's | ||
26 | install -d ${STAGING_DIR_HOST}${libdir}/ribosome/bif-cvs/helix/client/build/BIF | ||
27 | install -m 0644 client-bif-${_SNAPSHOT}/*.bif \ | ||
28 | ${STAGING_DIR_HOST}${libdir}/ribosome/bif-cvs/helix/client/build/BIF | ||
29 | |||
30 | # Install common BIF's | ||
31 | install -d ${STAGING_DIR_HOST}${libdir}/ribosome/bif-cvs/helix/common/build/BIF | ||
32 | install -m 0644 common-bif-${_SNAPSHOT}/*.bif \ | ||
33 | ${STAGING_DIR_HOST}${libdir}/ribosome/bif-cvs/helix/common/build/BIF | ||
34 | |||
35 | # Install our own custom BIF | ||
36 | install -m 0644 ribosome/*.bif ${STAGING_DIR_HOST}${libdir}/ribosome/bif-cvs/helix/client/build/BIF/ | ||
37 | } | ||