summaryrefslogtreecommitdiffstats
path: root/meta/packages/hal
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-04-03 06:56:51 +0000
committerRoss Burton <ross@openedhand.com>2007-04-03 06:56:51 +0000
commitf05e80b6639401e48a6004d352ccd1dc4b98c225 (patch)
treeec71db1d7a83d34c224d05423b01df830d75a25c /meta/packages/hal
parent8c81acadaf05fc84265d5da82ea4f066ba7e9fd0 (diff)
downloadpoky-f05e80b6639401e48a6004d352ccd1dc4b98c225.tar.gz
Update to hal 0.5.9
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1422 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/hal')
-rw-r--r--meta/packages/hal/hal_0.5.9.bb87
1 files changed, 87 insertions, 0 deletions
diff --git a/meta/packages/hal/hal_0.5.9.bb b/meta/packages/hal/hal_0.5.9.bb
new file mode 100644
index 0000000000..67298c2f69
--- /dev/null
+++ b/meta/packages/hal/hal_0.5.9.bb
@@ -0,0 +1,87 @@
1DESCRIPTION = "Hardware Abstraction Layer"
2HOMEPAGE = "http://freedesktop.org/Software/hal"
3SECTION = "unknown"
4LICENSE = "GPL LGPL AFL"
5
6DEPENDS = "virtual/kernel dbus-glib udev intltool expat libusb"
7RDEPENDS += "udev hal-info"
8#RDEPENDS_hal-device-manager = "python hal python-pygnome"
9RRECOMMENDS = "udev-utils"
10
11PR = "r1"
12
13SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
14 file://99_hal"
15
16S = "${WORKDIR}/hal-${PV}"
17
18inherit autotools pkgconfig
19
20EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
21 --with-expat=${STAGING_LIBDIR}/.. \
22 --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
23 --with-hotplug=${sysconfdir}/hotplug.d \
24 --disable-docbook-docs \
25 --disable-policy-kit \
26 --disable-acpi --disable-pmu --disable-pci \
27 --disable-pci-ids --disable-pnp-ids \
28 "
29
30do_install_append() {
31 install -d ${D}/etc/default/volatiles
32 install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
33}
34
35do_stage() {
36 autotools_stage_all
37 install -d ${STAGING_LIBDIR}
38 install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
39 install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
40}
41
42# At the time the postinst runs, dbus might not be setup so only restart if running
43pkg_postinst_hal () {
44 # can't do this offline
45 if [ "x$D" != "x" ]; then
46 exit 1
47 fi
48
49 /etc/init.d/populate-volatile.sh update
50
51 grep haldaemon /etc/group || addgroup haldaemon
52 grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
53
54 DBUSPID=`pidof dbus-daemon`
55
56 if [ "x$DBUSPID" != "x" ]; then
57 /etc/init.d/dbus-1 force-reload
58 fi
59}
60
61pkg_postrm_hal () {
62 deluser haldaemon || true
63 delgroup haldaemon || true
64}
65
66#PACKAGES += "hal-device-manager"
67
68#FILES_hal-device-manager = " \
69# ${datadir}/hal/device-manager/ \
70# ${bindir}/hal-device-manager"
71
72FILES_${PN} = "${sysconfdir} \
73 ${bindir}/lshal \
74 ${bindir}/hal-find-by-capability \
75 ${bindir}/hal-find-by-property \
76 ${bindir}/hal-device \
77 ${bindir}/hal-get-property \
78 ${bindir}/hal-set-property \
79 ${bindir}/hal-lock \
80 ${bindir}/hal-is-caller-locked-out \
81 ${sbindir} \
82 ${libdir}/libhal.so.* \
83 ${libdir}/libhal-storage.so.* \
84 ${libdir}/hal \
85 ${libexecdir} \
86 ${datadir}/hal/fdi \
87 ${datadir}/hal/scripts"