diff options
author | Qing He <qing.he@intel.com> | 2010-07-20 10:35:15 +0800 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-07-23 23:53:30 +0100 |
commit | 8bad27517486ff69b961a03f5d25a9c5aa5a2b7e (patch) | |
tree | 9fd78296c8ac858c01afa05e0f693cbf33bd416e /meta/packages/hal/hal_git.bb | |
parent | 63d56523555b000a4b52027b68d0e7f33bf6a2ec (diff) | |
download | poky-8bad27517486ff69b961a03f5d25a9c5aa5a2b7e.tar.gz |
hal: upgrade to version 0.5.14
from 0.5.13
changes:
- udev rules dir has been changing to /lib/udev/rules.d in udev
upstream, add an override to stay in /etc/rules.d for compatibility
- consolidate hal.inc and hal_git.bb, hal_git.bb is used as a
reference thus should have a negative preference
- change preferred version of hal to 0.5.14
- remove hal_0.5.11+0.5.12rc1
- remove RRECOMMENDS on udev-utils, the package is to be removed
Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/hal/hal_git.bb')
-rw-r--r-- | meta/packages/hal/hal_git.bb | 76 |
1 files changed, 3 insertions, 73 deletions
diff --git a/meta/packages/hal/hal_git.bb b/meta/packages/hal/hal_git.bb index 85bb777d5f..34ccfe9cf2 100644 --- a/meta/packages/hal/hal_git.bb +++ b/meta/packages/hal/hal_git.bb | |||
@@ -1,16 +1,7 @@ | |||
1 | DESCRIPTION = "Hardware Abstraction Layer" | 1 | require hal.inc |
2 | HOMEPAGE = "http://freedesktop.org/Software/hal" | ||
3 | BUGTRACKER = "http://bugs.freedesktop.org/buglist.cgi?product=hal" | ||
4 | SECTION = "unknown" | ||
5 | |||
6 | LICENSE = "GPLv2+ | AFL" | ||
7 | |||
8 | DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb" | ||
9 | RDEPENDS_${PN} += "udev hal-info" | ||
10 | RRECOMMENDS_${PN} += "udev-utils" | ||
11 | 2 | ||
12 | PV = "0.5.9.1+git${SRCDATE}" | 3 | PV = "0.5.9.1+git${SRCDATE}" |
13 | PR = "r4" | 4 | PR = "r5" |
14 | 5 | ||
15 | SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \ | 6 | SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \ |
16 | file://20hal \ | 7 | file://20hal \ |
@@ -18,65 +9,4 @@ SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \ | |||
18 | 9 | ||
19 | S = "${WORKDIR}/git" | 10 | S = "${WORKDIR}/git" |
20 | 11 | ||
21 | inherit autotools pkgconfig | 12 | DEFAULT_PREFERENCE = "-1" |
22 | |||
23 | EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \ | ||
24 | --with-expat=${STAGING_DIR_HOST}${prefix} \ | ||
25 | --with-dbus-sys=${sysconfdir}/dbus-1/system.d \ | ||
26 | --with-hotplug=${sysconfdir}/hotplug.d \ | ||
27 | --disable-docbook-docs \ | ||
28 | --disable-policy-kit \ | ||
29 | --disable-acpi --disable-acpi-acpid --disable-acpi-proc \ | ||
30 | --disable-sonypic \ | ||
31 | --disable-pmu --disable-pci \ | ||
32 | --disable-pci-ids --disable-pnp-ids \ | ||
33 | " | ||
34 | |||
35 | do_install_append() { | ||
36 | install -d ${D}/etc/default/volatiles | ||
37 | install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles | ||
38 | install -d ${D}/etc/dbus-1/event.d | ||
39 | install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d | ||
40 | } | ||
41 | |||
42 | # At the time the postinst runs, dbus might not be setup so only restart if running | ||
43 | pkg_postinst_hal () { | ||
44 | # can't do this offline | ||
45 | if [ "x$D" != "x" ]; then | ||
46 | exit 1 | ||
47 | fi | ||
48 | |||
49 | /etc/init.d/populate-volatile.sh update | ||
50 | |||
51 | grep haldaemon /etc/group || addgroup haldaemon | ||
52 | grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL | ||
53 | |||
54 | DBUSPID=`pidof dbus-daemon` | ||
55 | |||
56 | if [ "x$DBUSPID" != "x" ]; then | ||
57 | /etc/init.d/dbus-1 reload | ||
58 | fi | ||
59 | } | ||
60 | |||
61 | pkg_postrm_hal () { | ||
62 | deluser haldaemon || true | ||
63 | delgroup haldaemon || true | ||
64 | } | ||
65 | |||
66 | FILES_${PN} = "${sysconfdir} \ | ||
67 | ${bindir}/lshal \ | ||
68 | ${bindir}/hal-find-by-capability \ | ||
69 | ${bindir}/hal-find-by-property \ | ||
70 | ${bindir}/hal-device \ | ||
71 | ${bindir}/hal-get-property \ | ||
72 | ${bindir}/hal-set-property \ | ||
73 | ${bindir}/hal-lock \ | ||
74 | ${bindir}/hal-is-caller-locked-out \ | ||
75 | ${bindir}/hal-disable-polling \ | ||
76 | ${sbindir} \ | ||
77 | ${libdir}/libhal.so.* \ | ||
78 | ${libdir}/libhal-storage.so.* \ | ||
79 | ${libdir}/hal \ | ||
80 | ${libexecdir} \ | ||
81 | ${datadir}/hal/fdi \ | ||
82 | ${datadir}/hal/scripts" | ||