summaryrefslogtreecommitdiffstats
path: root/meta/packages/hal/hal_0.5.9.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-08-03 16:25:57 +0000
committerRoss Burton <ross@openedhand.com>2007-08-03 16:25:57 +0000
commit1900143c5bd02e780c87c8d1574f3da45350e8b8 (patch)
tree0d9a68c434169479dc7b38ccd1fd6e0f6c97ceb8 /meta/packages/hal/hal_0.5.9.1.bb
parent205d909071c5f4f7f681757bba0078d664bf61c3 (diff)
downloadpoky-1900143c5bd02e780c87c8d1574f3da45350e8b8.tar.gz
Upgrade hal-info and hal to 0.5.9.1
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2355 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/hal/hal_0.5.9.1.bb')
-rw-r--r--meta/packages/hal/hal_0.5.9.1.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/meta/packages/hal/hal_0.5.9.1.bb b/meta/packages/hal/hal_0.5.9.1.bb
new file mode 100644
index 0000000000..4e3c7ed926
--- /dev/null
+++ b/meta/packages/hal/hal_0.5.9.1.bb
@@ -0,0 +1,82 @@
1DESCRIPTION = "Hardware Abstraction Layer"
2HOMEPAGE = "http://freedesktop.org/Software/hal"
3SECTION = "unknown"
4LICENSE = "GPL LGPL AFL"
5
6DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb"
7RDEPENDS += "udev hal-info"
8RRECOMMENDS = "udev-utils"
9
10SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
11 file://sg-inhibit.patch;patch=1 \
12 file://99_hal"
13
14S = "${WORKDIR}/hal-${PV}"
15
16inherit autotools pkgconfig
17
18EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
19 --with-expat=${STAGING_LIBDIR}/.. \
20 --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
21 --with-hotplug=${sysconfdir}/hotplug.d \
22 --disable-docbook-docs \
23 --disable-policy-kit \
24 --disable-acpi --disable-acpi-acpid --disable-acpi-proc \
25 --disable-sonypic \
26 --disable-pmu --disable-pci \
27 --disable-pci-ids --disable-pnp-ids \
28 "
29
30do_install_append() {
31 install -d ${D}/etc/default/volatiles
32 install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
33}
34
35do_stage() {
36 autotools_stage_all
37 install -d ${STAGING_LIBDIR}
38 install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
39 install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
40}
41
42# At the time the postinst runs, dbus might not be setup so only restart if running
43pkg_postinst_hal () {
44 # can't do this offline
45 if [ "x$D" != "x" ]; then
46 exit 1
47 fi
48
49 /etc/init.d/populate-volatile.sh update
50
51 grep haldaemon /etc/group || addgroup haldaemon
52 grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
53
54 DBUSPID=`pidof dbus-daemon`
55
56 if [ "x$DBUSPID" != "x" ]; then
57 /etc/init.d/dbus-1 force-reload
58 fi
59}
60
61pkg_postrm_hal () {
62 deluser haldaemon || true
63 delgroup haldaemon || true
64}
65
66FILES_${PN} = "${sysconfdir} \
67 ${bindir}/lshal \
68 ${bindir}/hal-find-by-capability \
69 ${bindir}/hal-find-by-property \
70 ${bindir}/hal-device \
71 ${bindir}/hal-get-property \
72 ${bindir}/hal-set-property \
73 ${bindir}/hal-lock \
74 ${bindir}/hal-is-caller-locked-out \
75 ${bindir}/hal-disable-polling \
76 ${sbindir} \
77 ${libdir}/libhal.so.* \
78 ${libdir}/libhal-storage.so.* \
79 ${libdir}/hal \
80 ${libexecdir} \
81 ${datadir}/hal/fdi \
82 ${datadir}/hal/scripts"