summaryrefslogtreecommitdiffstats
path: root/meta/packages/guilt/guilt-native_0.33.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2010-08-10 15:01:37 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-20 16:35:39 +0100
commit2cf104f7e09d620b9c04122d15ce347db34f9577 (patch)
tree173af7dc87afd8e96ef694807bb1080ab2718591 /meta/packages/guilt/guilt-native_0.33.bb
parent15543017ec044b1b072a50335a6fd0a036def47e (diff)
downloadpoky-2cf104f7e09d620b9c04122d15ce347db34f9577.tar.gz
guilt: import guilt for kernel patch management
The Wind River kernel is "patched" via guilt to provide both git integration and quilt like patch management (if that is of interest). This is a modified 0.33 guilt with some changes to streamline interactions with the way that the Wind River kernel is constructed. That being said, the common semantics of guilt are not changed, and it can be used for other purposes. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/packages/guilt/guilt-native_0.33.bb')
-rw-r--r--meta/packages/guilt/guilt-native_0.33.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/packages/guilt/guilt-native_0.33.bb b/meta/packages/guilt/guilt-native_0.33.bb
new file mode 100644
index 0000000000..62d91f6953
--- /dev/null
+++ b/meta/packages/guilt/guilt-native_0.33.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "guilt is quilt like tool for git"
2LICENSE = "GPL"
3
4PR = r0
5PV = "0.33"
6
7inherit native
8
9SRC_URI = "http://www.kernel.org/pub/linux/kernel/people/jsipek/guilt/guilt-${PV}.tar.gz\
10 file://guilt-push.patch \
11 file://guilt-pop.patch \
12 file://guilt.patch \
13 file://guilt-init.patch \
14 file://guilt-import-commit.patch \
15 file://uninstall_force.patch \
16 file://guilt-push-no-series.patch \
17 file://make_git_commands_conditional.patch \
18 file://improve_auto_header_gen.patch \
19 file://guilt-set-git_exec_path.patch \
20 file://guilt-bash.patch \
21 file://optional_head_check.patch"
22
23# we don't compile, we just install
24do_compile() {
25 :
26}
27
28do_install() {
29 oe_runmake PREFIX=${D}/${base_prefix}/usr install
30} \ No newline at end of file