diff options
author | Thomas Wood <thomas@openedhand.com> | 2006-10-30 10:38:50 +0000 |
---|---|---|
committer | Thomas Wood <thomas@openedhand.com> | 2006-10-30 10:38:50 +0000 |
commit | 7597d5ba90cbcf3f0439fbabb62d7c718b249415 (patch) | |
tree | 71f7fbde5c069330a07d4130e5b9b7023910636a /meta/packages/gtk+ | |
parent | 2db354074d4cb8d550f69ed63df18a7f3127990b (diff) | |
download | poky-7597d5ba90cbcf3f0439fbabb62d7c718b249415.tar.gz |
Smaller filechooser patch for GTK+
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@840 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gtk+')
-rw-r--r-- | meta/packages/gtk+/gtk+-2.6.8/smaller-filechooser.patch | 47 | ||||
-rw-r--r-- | meta/packages/gtk+/gtk+_2.6.8.bb | 3 |
2 files changed, 49 insertions, 1 deletions
diff --git a/meta/packages/gtk+/gtk+-2.6.8/smaller-filechooser.patch b/meta/packages/gtk+/gtk+-2.6.8/smaller-filechooser.patch new file mode 100644 index 0000000000..3c6f7217e5 --- /dev/null +++ b/meta/packages/gtk+/gtk+-2.6.8/smaller-filechooser.patch | |||
@@ -0,0 +1,47 @@ | |||
1 | Index: gtkfilechooserdefault.c | ||
2 | =================================================================== | ||
3 | RCS file: /cvs/gnome/gtk+/gtk/gtkfilechooserdefault.c,v | ||
4 | retrieving revision 1.240.2.25 | ||
5 | diff -u -p -r1.240.2.25 gtkfilechooserdefault.c | ||
6 | --- gtk+/gtk/gtkfilechooserdefault.c 7 Jul 2005 17:14:09 -0000 1.240.2.25 | ||
7 | +++ gtk+/gtk/gtkfilechooserdefault.c 27 Oct 2006 14:22:28 -0000 | ||
8 | @@ -3728,6 +3728,7 @@ browse_widgets_create (GtkFileChooserDef | ||
9 | GtkWidget *vbox; | ||
10 | GtkWidget *hpaned; | ||
11 | GtkWidget *widget; | ||
12 | + GtkWidget *shortcuts_pane; | ||
13 | GtkSizeGroup *size_group; | ||
14 | |||
15 | /* size group is used by the [+][-] buttons and the filter combo */ | ||
16 | @@ -3740,12 +3741,29 @@ browse_widgets_create (GtkFileChooserDef | ||
17 | gtk_paned_set_position (GTK_PANED (hpaned), 200); /* FIXME: this sucks */ | ||
18 | gtk_box_pack_start (GTK_BOX (vbox), hpaned, TRUE, TRUE, 0); | ||
19 | |||
20 | - widget = shortcuts_pane_create (impl, size_group); | ||
21 | - gtk_paned_pack1 (GTK_PANED (hpaned), widget, FALSE, FALSE); | ||
22 | + shortcuts_pane = shortcuts_pane_create (impl, size_group); | ||
23 | + gtk_paned_pack1 (GTK_PANED (hpaned), shortcuts_pane, FALSE, FALSE); | ||
24 | widget = file_pane_create (impl, size_group); | ||
25 | gtk_paned_pack2 (GTK_PANED (hpaned), widget, TRUE, FALSE); | ||
26 | |||
27 | g_object_unref (size_group); | ||
28 | + | ||
29 | + | ||
30 | + /* remove excess baggage from the filechooser for small displays */ | ||
31 | + | ||
32 | + /* get the columns in the tree view and remove the last column (should be Modified column) */ | ||
33 | + GList *column_list; | ||
34 | + column_list = gtk_tree_view_get_columns (GTK_TREE_VIEW (impl->browse_files_tree_view)); | ||
35 | + gtk_tree_view_remove_column (GTK_TREE_VIEW (impl->browse_files_tree_view), (g_list_last (column_list))->data); | ||
36 | + g_list_free (column_list); | ||
37 | + | ||
38 | + /* hide the tree view headers */ | ||
39 | + gtk_tree_view_set_headers_visible (GTK_TREE_VIEW (impl->browse_files_tree_view), FALSE); | ||
40 | + | ||
41 | + /* hide the shortcuts pane */ | ||
42 | + gtk_widget_hide (GTK_WIDGET (shortcuts_pane)); | ||
43 | + | ||
44 | + | ||
45 | |||
46 | return vbox; | ||
47 | } | ||
diff --git a/meta/packages/gtk+/gtk+_2.6.8.bb b/meta/packages/gtk+/gtk+_2.6.8.bb index ee47448038..0b7ab6b313 100644 --- a/meta/packages/gtk+/gtk+_2.6.8.bb +++ b/meta/packages/gtk+/gtk+_2.6.8.bb | |||
@@ -17,7 +17,8 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \ | |||
17 | file://gtklabel-resize-patch;patch=1 \ | 17 | file://gtklabel-resize-patch;patch=1 \ |
18 | file://menu-deactivate.patch;patch=1 \ | 18 | file://menu-deactivate.patch;patch=1 \ |
19 | file://scroll-timings.patch;patch=1 \ | 19 | file://scroll-timings.patch;patch=1 \ |
20 | file://no-deprecation.patch;patch=1" | 20 | file://no-deprecation.patch;patch=1 \ |
21 | file://smaller-filechooser.patch;patch=1" | ||
21 | 22 | ||
22 | inherit autotools pkgconfig | 23 | inherit autotools pkgconfig |
23 | 24 | ||