summaryrefslogtreecommitdiffstats
path: root/meta/packages/gtk+
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-09-03 08:52:08 +0000
committerRoss Burton <ross@openedhand.com>2007-09-03 08:52:08 +0000
commitd9c89ac5d8197368cd25ca34b8e50a467f8ce3d5 (patch)
treeba5b262927d9c2b0312612d0078263d6cd4fdb93 /meta/packages/gtk+
parenta23b1535a2f00b7b9d6e433f31b29f98484230ca (diff)
downloadpoky-d9c89ac5d8197368cd25ca34b8e50a467f8ce3d5.tar.gz
Remove some patches we don't apply
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2667 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gtk+')
-rw-r--r--meta/packages/gtk+/gtk+-2.11.6/gtk+-handhelds.patch149
-rw-r--r--meta/packages/gtk+/gtk+-2.11.6/scroll-timings.patch11
-rw-r--r--meta/packages/gtk+/gtk+-2.11.6/single-click.patch56
-rw-r--r--meta/packages/gtk+/gtk+-2.11.6/spinbutton.patch130
-rw-r--r--meta/packages/gtk+/gtk+_2.11.6.bb6
5 files changed, 1 insertions, 351 deletions
diff --git a/meta/packages/gtk+/gtk+-2.11.6/gtk+-handhelds.patch b/meta/packages/gtk+/gtk+-2.11.6/gtk+-handhelds.patch
deleted file mode 100644
index 1ea86ce6b2..0000000000
--- a/meta/packages/gtk+/gtk+-2.11.6/gtk+-handhelds.patch
+++ /dev/null
@@ -1,149 +0,0 @@
1Index: gtk+-2.10.6/gtk/gtkarrow.c
2===================================================================
3--- gtk+-2.10.6.orig/gtk/gtkarrow.c 2006-05-14 05:25:28.000000000 +0100
4+++ gtk+-2.10.6/gtk/gtkarrow.c 2006-11-14 12:03:45.000000000 +0000
5@@ -31,7 +31,7 @@
6 #include "gtkintl.h"
7 #include "gtkalias.h"
8
9-#define MIN_ARROW_SIZE 15
10+#define MIN_ARROW_SIZE 7
11
12 enum {
13 PROP_0,
14@@ -53,6 +53,8 @@
15 guint prop_id,
16 GValue *value,
17 GParamSpec *pspec);
18+static void gtk_arrow_size_request (GtkWidget *arrow,
19+ GtkRequisition *requisition);
20
21
22 G_DEFINE_TYPE (GtkArrow, gtk_arrow, GTK_TYPE_MISC)
23@@ -88,6 +90,7 @@
24 GTK_PARAM_READWRITE));
25
26 widget_class->expose_event = gtk_arrow_expose;
27+ widget_class->size_request = gtk_arrow_size_request;
28 }
29
30 static void
31@@ -143,13 +146,18 @@
32 }
33
34 static void
35+gtk_arrow_size_request (GtkWidget *arrow,
36+ GtkRequisition *requisition)
37+{
38+ requisition->width = MIN_ARROW_SIZE + GTK_MISC (arrow)->xpad * 2;
39+ requisition->height = MIN_ARROW_SIZE + GTK_MISC (arrow)->ypad * 2;
40+}
41+
42+static void
43 gtk_arrow_init (GtkArrow *arrow)
44 {
45 GTK_WIDGET_SET_FLAGS (arrow, GTK_NO_WINDOW);
46
47- GTK_WIDGET (arrow)->requisition.width = MIN_ARROW_SIZE + GTK_MISC (arrow)->xpad * 2;
48- GTK_WIDGET (arrow)->requisition.height = MIN_ARROW_SIZE + GTK_MISC (arrow)->ypad * 2;
49-
50 arrow->arrow_type = GTK_ARROW_RIGHT;
51 arrow->shadow_type = GTK_SHADOW_OUT;
52 }
53Index: gtk+-2.10.6/gtk/gtkentry.c
54===================================================================
55--- gtk+-2.10.6.orig/gtk/gtkentry.c 2006-11-14 12:03:45.000000000 +0000
56+++ gtk+-2.10.6/gtk/gtkentry.c 2006-11-14 12:07:02.000000000 +0000
57@@ -577,6 +577,18 @@
58 0.0,
59 GTK_PARAM_READWRITE));
60
61+ // Added by gtk+-handhelds.patch
62+ gtk_widget_class_install_style_property (widget_class,
63+ g_param_spec_int ("min_width",
64+ P_("Minimum width"),
65+ P_("Minimum width of the entry field"),
66+ 0,
67+ G_MAXINT,
68+ MIN_ENTRY_WIDTH,
69+ G_PARAM_READABLE));
70+
71+
72+
73 /**
74 * GtkEntry:truncate-multiline:
75 *
76@@ -1286,7 +1298,7 @@
77 {
78 GtkEntry *entry = GTK_ENTRY (widget);
79 PangoFontMetrics *metrics;
80- gint xborder, yborder;
81+ gint xborder, yborder, min_width;
82 GtkBorder inner_border;
83 PangoContext *context;
84
85@@ -1302,8 +1314,10 @@
86 _gtk_entry_get_borders (entry, &xborder, &yborder);
87 _gtk_entry_effective_inner_border (entry, &inner_border);
88
89+ gtk_widget_style_get (widget, "min_width", &min_width, NULL);
90+
91 if (entry->width_chars < 0)
92- requisition->width = MIN_ENTRY_WIDTH + xborder * 2 + inner_border.left + inner_border.right;
93+ requisition->width = min_width + xborder * 2 + inner_border.left + inner_border.right;
94 else
95 {
96 gint char_width = pango_font_metrics_get_approximate_char_width (metrics);
97Index: gtk+-2.10.6/gtk/gtkrange.c
98===================================================================
99--- gtk+-2.10.6.orig/gtk/gtkrange.c 2006-11-14 12:03:44.000000000 +0000
100+++ gtk+-2.10.6/gtk/gtkrange.c 2006-11-14 12:07:40.000000000 +0000
101@@ -197,6 +197,7 @@
102 static gboolean gtk_range_key_press (GtkWidget *range,
103 GdkEventKey *event);
104
105+static GdkAtom recognize_protocols_atom, atom_atom;
106
107 static guint signals[LAST_SIGNAL];
108
109@@ -213,6 +214,9 @@
110 object_class = (GtkObjectClass*) class;
111 widget_class = (GtkWidgetClass*) class;
112
113+ recognize_protocols_atom = gdk_atom_intern ("RECOGNIZE_PROTOCOLS", FALSE);
114+ atom_atom = gdk_atom_intern ("ATOM", FALSE);
115+
116 gobject_class->set_property = gtk_range_set_property;
117 gobject_class->get_property = gtk_range_get_property;
118 gobject_class->finalize = gtk_range_finalize;
119@@ -1020,6 +1024,12 @@
120 &attributes, attributes_mask);
121 gdk_window_set_user_data (range->event_window, range);
122
123+ gdk_property_change (range->event_window,
124+ recognize_protocols_atom,
125+ atom_atom,
126+ 32, GDK_PROP_MODE_REPLACE,
127+ NULL, 0);
128+
129 widget->style = gtk_style_attach (widget->style, widget->window);
130 }
131
132@@ -1569,7 +1579,7 @@
133
134 /* ignore presses when we're already doing something else. */
135 if (range->layout->grab_location != MOUSE_OUTSIDE)
136- return FALSE;
137+ return TRUE;
138
139 range->layout->mouse_x = event->x;
140 range->layout->mouse_y = event->y;
141@@ -1778,7 +1788,7 @@
142 return TRUE;
143 }
144
145- return FALSE;
146+ return TRUE;
147 }
148
149 /**
diff --git a/meta/packages/gtk+/gtk+-2.11.6/scroll-timings.patch b/meta/packages/gtk+/gtk+-2.11.6/scroll-timings.patch
deleted file mode 100644
index 3f823a7880..0000000000
--- a/meta/packages/gtk+/gtk+-2.11.6/scroll-timings.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- gtk+-2.10.0/gtk/gtkrange.c.orig 2006-07-05 12:41:39.000000000 +0200
2+++ gtk+-2.10.0/gtk/gtkrange.c 2006-07-05 12:41:58.000000000 +0200
3@@ -39,7 +39,7 @@
4 #include "gtkalias.h"
5
6 #define SCROLL_DELAY_FACTOR 5 /* Scroll repeat multiplier */
7-#define UPDATE_DELAY 300 /* Delay for queued update */
8+#define UPDATE_DELAY 1000 /* Delay for queued update */
9
10 enum {
11 PROP_0,
diff --git a/meta/packages/gtk+/gtk+-2.11.6/single-click.patch b/meta/packages/gtk+/gtk+-2.11.6/single-click.patch
deleted file mode 100644
index 250f1629f5..0000000000
--- a/meta/packages/gtk+/gtk+-2.11.6/single-click.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1Index: gtk+-2.10.6/gtk/gtkcalendar.c
2===================================================================
3--- gtk+-2.10.6.orig/gtk/gtkcalendar.c
4+++ gtk+-2.10.6/gtk/gtkcalendar.c
5@@ -2482,9 +2482,11 @@ calendar_main_button_press (GtkCalendar
6 }
7
8 calendar_select_and_focus_day (calendar, day);
9- }
10+
11+ // This change causes the calendar to disappear after choosing a day
12+/* }
13 else if (event->type == GDK_2BUTTON_PRESS)
14- {
15+ {*/
16 priv->in_drag = 0;
17 if (day_month == MONTH_CURRENT)
18 g_signal_emit (calendar,
19Index: gtk+-2.10.6/gtk/gtkfilesel.c
20===================================================================
21--- gtk+-2.10.6.orig/gtk/gtkfilesel.c
22+++ gtk+-2.10.6/gtk/gtkfilesel.c
23@@ -2426,6 +2426,33 @@ gtk_file_selection_file_changed (GtkTree
24 if (fs->last_selected != NULL)
25 g_free (fs->last_selected);
26
27+ // Single-click directory entry
28+ if (new_names->len == 1)
29+ {
30+ GtkTreeView *tree_view;
31+ GtkTreeModel *model;
32+ GtkTreePath *path;
33+ GtkTreeIter iter;
34+ gboolean is_file;
35+
36+ tree_view = gtk_tree_selection_get_tree_view (selection);
37+
38+ if (gtk_tree_selection_get_selected (selection, &model, &iter))
39+ {
40+ path = gtk_tree_model_get_path (model, &iter);
41+ gtk_tree_model_get (model, &iter, ISFILE_COLUMN, &is_file, -1);
42+
43+ if (!is_file)
44+ {
45+ gtk_file_selection_dir_activate (tree_view, path,
46+ gtk_tree_view_get_column (tree_view, DIR_COLUMN),
47+ user_data);
48+ }
49+
50+ gtk_tree_path_free (path);
51+ }
52+ }
53+
54 fs->last_selected = g_strdup (g_ptr_array_index (new_names, index));
55 filename = get_real_filename (fs->last_selected, FALSE);
56
diff --git a/meta/packages/gtk+/gtk+-2.11.6/spinbutton.patch b/meta/packages/gtk+/gtk+-2.11.6/spinbutton.patch
deleted file mode 100644
index c26dc6d93c..0000000000
--- a/meta/packages/gtk+/gtk+-2.11.6/spinbutton.patch
+++ /dev/null
@@ -1,130 +0,0 @@
1Index: gtk+-2.10.6/gtk/gtkspinbutton.c
2===================================================================
3--- gtk+-2.10.6.orig/gtk/gtkspinbutton.c
4+++ gtk+-2.10.6/gtk/gtkspinbutton.c
5@@ -682,7 +682,7 @@ gtk_spin_button_size_allocate (GtkWidget
6
7 spin = GTK_SPIN_BUTTON (widget);
8 arrow_size = spin_button_get_arrow_size (spin);
9- panel_width = arrow_size + 2 * widget->style->xthickness;
10+ panel_width = (2 * arrow_size) + 4 * widget->style->xthickness;
11
12 widget->allocation = *allocation;
13
14@@ -815,19 +815,16 @@ gtk_spin_button_draw_arrow (GtkSpinButto
15 {
16 width = spin_button_get_arrow_size (spin_button) + 2 * widget->style->xthickness;
17
18+ y = widget->style->ythickness;
19+ height = widget->requisition.height - (2 * y);
20+
21 if (arrow_type == GTK_ARROW_UP)
22 {
23 x = 0;
24- y = 0;
25-
26- height = widget->requisition.height / 2;
27 }
28 else
29 {
30- x = 0;
31- y = widget->requisition.height / 2;
32-
33- height = (widget->requisition.height + 1) / 2;
34+ x = width;
35 }
36
37 if (spin_button_at_limit (spin_button, arrow_type))
38@@ -857,32 +854,17 @@ gtk_spin_button_draw_arrow (GtkSpinButto
39 shadow_type = GTK_SHADOW_OUT;
40 }
41 }
42-
43+
44 gtk_paint_box (widget->style, spin_button->panel,
45 state_type, shadow_type,
46 NULL, widget,
47- (arrow_type == GTK_ARROW_UP)? "spinbutton_up" : "spinbutton_down",
48+ NULL,
49 x, y, width, height);
50
51 height = widget->requisition.height;
52
53- if (arrow_type == GTK_ARROW_DOWN)
54- {
55- y = height / 2;
56- height = height - y - 2;
57- }
58- else
59- {
60- y = 2;
61- height = height / 2 - 2;
62- }
63-
64 width -= 3;
65-
66- if (widget && gtk_widget_get_direction (widget) == GTK_TEXT_DIR_RTL)
67- x = 2;
68- else
69- x = 1;
70+ height -= 3;
71
72 w = width / 2;
73 w -= w % 2 - 1; /* force odd */
74@@ -1062,7 +1044,7 @@ gtk_spin_button_button_press (GtkWidget
75 if (GTK_ENTRY (widget)->editable)
76 gtk_spin_button_update (spin);
77
78- if (event->y <= widget->requisition.height / 2)
79+ if (event->x <= (spin_button_get_arrow_size (spin) + widget->style->xthickness))
80 {
81 if (event->button == 1)
82 start_spinning (spin, GTK_ARROW_UP, spin->adjustment->step_increment);
83@@ -1097,44 +1079,11 @@ gtk_spin_button_button_release (GtkWidge
84
85 arrow_size = spin_button_get_arrow_size (spin);
86
87- if (event->button == spin->button)
88- {
89- int click_child = spin->click_child;
90+ gtk_spin_button_stop_spinning (spin);
91
92- gtk_spin_button_stop_spinning (spin);
93-
94- if (event->button == 3)
95- {
96- if (event->y >= 0 && event->x >= 0 &&
97- event->y <= widget->requisition.height &&
98- event->x <= arrow_size + 2 * widget->style->xthickness)
99- {
100- if (click_child == GTK_ARROW_UP &&
101- event->y <= widget->requisition.height / 2)
102- {
103- gdouble diff;
104-
105- diff = spin->adjustment->upper - spin->adjustment->value;
106- if (diff > EPSILON)
107- gtk_spin_button_real_spin (spin, diff);
108- }
109- else if (click_child == GTK_ARROW_DOWN &&
110- event->y > widget->requisition.height / 2)
111- {
112- gdouble diff;
113-
114- diff = spin->adjustment->value - spin->adjustment->lower;
115- if (diff > EPSILON)
116- gtk_spin_button_real_spin (spin, -diff);
117- }
118- }
119- }
120- spin_button_redraw (spin);
121+ spin_button_redraw (spin);
122
123- return TRUE;
124- }
125- else
126- return GTK_WIDGET_CLASS (gtk_spin_button_parent_class)->button_release_event (widget, event);
127+ return TRUE;
128 }
129
130 static gint
diff --git a/meta/packages/gtk+/gtk+_2.11.6.bb b/meta/packages/gtk+/gtk+_2.11.6.bb
index 570a782b12..8cdfa8bcb1 100644
--- a/meta/packages/gtk+/gtk+_2.11.6.bb
+++ b/meta/packages/gtk+/gtk+_2.11.6.bb
@@ -19,18 +19,14 @@ SRC_URI = "http://download.gnome.org/sources/gtk+/2.11/gtk+-${PV}.tar.bz2 \
19 file://cellrenderer-cairo.patch;patch=1;pnum=0 \ 19 file://cellrenderer-cairo.patch;patch=1;pnum=0 \
20 file://entry-cairo.patch;patch=1;pnum=0 \ 20 file://entry-cairo.patch;patch=1;pnum=0 \
21 file://toggle-font.diff;patch=1;pnum=0 \ 21 file://toggle-font.diff;patch=1;pnum=0 \
22 file://range-no-redraw.patch;patch=1;pnum=0 \
22 file://scrolled-placement.patch;patch=1;pnum=0" 23 file://scrolled-placement.patch;patch=1;pnum=0"
23# temporary 24# temporary
24# file://gtklabel-resize-patch;patch=1 \ 25# file://gtklabel-resize-patch;patch=1 \
25# file://menu-deactivate.patch;patch=1 \ 26# file://menu-deactivate.patch;patch=1 \
26# file://combo-arrow-size.patch;patch=1;pnum=0 \ 27# file://combo-arrow-size.patch;patch=1;pnum=0 \
27# file://range-no-redraw.patch;patch=1;pnum=0 \
28# die die die 28# die die die
29# file://scroll-timings.patch;patch=1 \
30# file://pangoxft2.10.6.diff;patch=1" 29# file://pangoxft2.10.6.diff;patch=1"
31# file://gtk+-handhelds.patch;patch=1
32# file://single-click.patch;patch=1
33# file://spinbutton.patch;patch=1 \
34 30
35EXTRA_OECONF = "--without-libtiff --disable-xkb --disable-glibtest --enable-display-migration" 31EXTRA_OECONF = "--without-libtiff --disable-xkb --disable-glibtest --enable-display-migration"
36 32