summaryrefslogtreecommitdiffstats
path: root/meta/packages/gtk+
diff options
context:
space:
mode:
authorRichard Purdie <richard@ted.(none)>2009-06-04 19:38:05 +0100
committerRichard Purdie <richard@ted.(none)>2009-06-04 19:38:05 +0100
commitae950c85d79acbaa03f8fbb0df067b22d0766623 (patch)
tree56c08089c4937ec82f141f7a98236c4dbfe95d9a /meta/packages/gtk+
parent0223f45de06c35c4f83e4f3a09e96a84f916f99d (diff)
downloadpoky-ae950c85d79acbaa03f8fbb0df067b22d0766623.tar.gz
gtk+: Fix a string referencing bug (path sent upstream)
Signed-off-by: Richard Purdie <richard@ted.(none)>
Diffstat (limited to 'meta/packages/gtk+')
-rw-r--r--meta/packages/gtk+/gtk+-2.14.2/0001-bgo-584832-Duplicate-the-exec-string-returned-by-gtk.patch31
-rw-r--r--meta/packages/gtk+/gtk+_2.14.2.bb3
2 files changed, 33 insertions, 1 deletions
diff --git a/meta/packages/gtk+/gtk+-2.14.2/0001-bgo-584832-Duplicate-the-exec-string-returned-by-gtk.patch b/meta/packages/gtk+/gtk+-2.14.2/0001-bgo-584832-Duplicate-the-exec-string-returned-by-gtk.patch
new file mode 100644
index 0000000000..e0d6ab9522
--- /dev/null
+++ b/meta/packages/gtk+/gtk+-2.14.2/0001-bgo-584832-Duplicate-the-exec-string-returned-by-gtk.patch
@@ -0,0 +1,31 @@
1From 69b9441eab2a7215509687dc22b48b6f212d22aa Mon Sep 17 00:00:00 2001
2From: Rob Bradford <rob@linux.intel.com>
3Date: Thu, 4 Jun 2009 15:43:20 +0100
4Subject: [PATCH] =?utf-8?q?bgo#584832=20=E2=80=93=20Duplicate=20the=20exec=20string=20returned=20by=20gtk=5Frecent=5Finfo=5Fget=5Fapplication=5Finfo?=
5MIME-Version: 1.0
6Content-Type: text/plain; charset=utf-8
7Content-Transfer-Encoding: 8bit
8
9This function states that the caller is responsible for freeing the string
10passed returned by reference. Unfortunately if you do this you get a crash
11since the internal value is returned without being duplicated.
12---
13 gtk/gtkrecentmanager.c | 2 +-
14 1 files changed, 1 insertions(+), 1 deletions(-)
15
16diff --git a/gtk/gtkrecentmanager.c b/gtk/gtkrecentmanager.c
17index 317b3d5..d062572 100644
18--- a/gtk/gtkrecentmanager.c
19+++ b/gtk/gtkrecentmanager.c
20@@ -1764,7 +1764,7 @@ gtk_recent_info_get_application_info (GtkRecentInfo *info,
21 }
22
23 if (app_exec)
24- *app_exec = ai->exec;
25+ *app_exec = g_strdup (ai->exec);
26
27 if (count)
28 *count = ai->count;
29--
301.6.3.1
31
diff --git a/meta/packages/gtk+/gtk+_2.14.2.bb b/meta/packages/gtk+/gtk+_2.14.2.bb
index f5190c5849..494355cd7a 100644
--- a/meta/packages/gtk+/gtk+_2.14.2.bb
+++ b/meta/packages/gtk+/gtk+_2.14.2.bb
@@ -1,6 +1,6 @@
1require gtk+.inc 1require gtk+.inc
2 2
3PR = "r2" 3PR = "r3"
4 4
5SRC_URI = "http://download.gnome.org/sources/gtk+/2.14/gtk+-${PV}.tar.bz2 \ 5SRC_URI = "http://download.gnome.org/sources/gtk+/2.14/gtk+-${PV}.tar.bz2 \
6 file://xsettings.patch;patch=1 \ 6 file://xsettings.patch;patch=1 \
@@ -10,6 +10,7 @@ SRC_URI = "http://download.gnome.org/sources/gtk+/2.14/gtk+-${PV}.tar.bz2 \
10 file://cellrenderer-cairo.patch;patch=1;pnum=0 \ 10 file://cellrenderer-cairo.patch;patch=1;pnum=0 \
11 file://entry-cairo.patch;patch=1;pnum=0 \ 11 file://entry-cairo.patch;patch=1;pnum=0 \
12 file://toggle-font.diff;patch=1;pnum=0 \ 12 file://toggle-font.diff;patch=1;pnum=0 \
13 file://0001-bgo-584832-Duplicate-the-exec-string-returned-by-gtk.patch;patch=1 \
13# TO MERGE 14# TO MERGE
14# file://filesystem-volumes.patch;patch=1 \ 15# file://filesystem-volumes.patch;patch=1 \
15# file://filechooser-props.patch;patch=1 \ 16# file://filechooser-props.patch;patch=1 \