diff options
author | Ross Burton <ross@openedhand.com> | 2008-01-08 14:14:09 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2008-01-08 14:14:09 +0000 |
commit | f4a618526681084dd8fb074e991ce3f791586ca5 (patch) | |
tree | c3c7657a4f52fa954a4a02861a687f4aa32b8412 /meta/packages/gstreamer | |
parent | 84c46a71481ae4ac3641d8e54eabc34c576b13d2 (diff) | |
download | poky-f4a618526681084dd8fb074e991ce3f791586ca5.tar.gz |
gstreamer: don't try and load .debug libraries
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3420 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gstreamer')
-rw-r--r-- | meta/packages/gstreamer/gstreamer-0.10.14/gstreamer-omit-debug-directories.patch | 24 | ||||
-rw-r--r-- | meta/packages/gstreamer/gstreamer_0.10.14.bb | 5 |
2 files changed, 27 insertions, 2 deletions
diff --git a/meta/packages/gstreamer/gstreamer-0.10.14/gstreamer-omit-debug-directories.patch b/meta/packages/gstreamer/gstreamer-0.10.14/gstreamer-omit-debug-directories.patch new file mode 100644 index 0000000000..1abce2ec7d --- /dev/null +++ b/meta/packages/gstreamer/gstreamer-0.10.14/gstreamer-omit-debug-directories.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | Index: gstreamer-cvs/gst/gstregistry.c | ||
2 | =================================================================== | ||
3 | RCS file: /cvs/gstreamer/gstreamer/gst/gstregistry.c,v | ||
4 | retrieving revision 1.75 | ||
5 | diff -u -r1.75 gstregistry.c | ||
6 | --- gstreamer-cvs/gst/gstregistry.c 31 Jul 2007 11:51:38 -0000 1.75 | ||
7 | +++ gstreamer-cvs/gst/gstregistry.c 8 Jan 2008 14:12:40 -0000 | ||
8 | @@ -813,6 +813,16 @@ | ||
9 | GST_LOG_OBJECT (registry, "examining file: %s", filename); | ||
10 | |||
11 | if (g_file_test (filename, G_FILE_TEST_IS_DIR)) { | ||
12 | + /* | ||
13 | + * skip .debug directories, these contain elf files that can crash | ||
14 | + * dlopen | ||
15 | + */ | ||
16 | + if (g_str_equal (dirent, ".debug")) { | ||
17 | + GST_LOG_OBJECT (registry, "found .debug directory, ignoring"); | ||
18 | + g_free (filename); | ||
19 | + continue; | ||
20 | + } | ||
21 | + | ||
22 | if (level > 0) { | ||
23 | GST_LOG_OBJECT (registry, "found directory, recursing"); | ||
24 | changed |= gst_registry_scan_path_level (registry, filename, level - 1); | ||
diff --git a/meta/packages/gstreamer/gstreamer_0.10.14.bb b/meta/packages/gstreamer/gstreamer_0.10.14.bb index 7a37770f7f..33deedc455 100644 --- a/meta/packages/gstreamer/gstreamer_0.10.14.bb +++ b/meta/packages/gstreamer/gstreamer_0.10.14.bb | |||
@@ -5,12 +5,13 @@ PRIORITY = "optional" | |||
5 | LICENSE = "LGPL" | 5 | LICENSE = "LGPL" |
6 | HOMEPAGE = "http://www.gstreamer.net/" | 6 | HOMEPAGE = "http://www.gstreamer.net/" |
7 | DEPENDS = "glib-2.0 gettext-native libxml2 bison-native flex-native" | 7 | DEPENDS = "glib-2.0 gettext-native libxml2 bison-native flex-native" |
8 | PR = "r1" | 8 | PR = "r2" |
9 | 9 | ||
10 | inherit autotools pkgconfig | 10 | inherit autotools pkgconfig |
11 | 11 | ||
12 | SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \ | 12 | SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \ |
13 | file://gst-inspect-check-error.patch;patch=1" | 13 | file://gst-inspect-check-error.patch;patch=1 \ |
14 | file://gstreamer-omit-debug-directories.patch;patch=1;pnum=0" | ||
14 | # file://gstregistrybinary.c \ | 15 | # file://gstregistrybinary.c \ |
15 | # file://gstregistrybinary.h \ | 16 | # file://gstregistrybinary.h \ |
16 | # file://gstreamer-0.9-binary-registry.patch;patch=1" | 17 | # file://gstreamer-0.9-binary-registry.patch;patch=1" |