summaryrefslogtreecommitdiffstats
path: root/meta/packages/gstreamer
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2008-06-19 12:58:02 +0000
committerRoss Burton <ross@openedhand.com>2008-06-19 12:58:02 +0000
commitba3f99d75024836fa95687397ba714f344d6d79f (patch)
tree04cf060ad14891aa163b950b25ea8a1c75825595 /meta/packages/gstreamer
parent0f31e7dbd2ae827905c4bee0c90253b73a152309 (diff)
downloadpoky-ba3f99d75024836fa95687397ba714f344d6d79f.tar.gz
gstreamer: upgrade to 0.10.20, drop merged patches
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4704 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gstreamer')
-rw-r--r--meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-0.9-binary-registry.patch65
-rw-r--r--meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-omit-debug-directories.patch24
-rw-r--r--meta/packages/gstreamer/gstreamer-0.10.20/gst-inspect-check-error.patch (renamed from meta/packages/gstreamer/gstreamer-0.10.17/gst-inspect-check-error.patch)0
-rw-r--r--meta/packages/gstreamer/gstreamer_0.10.20.bb (renamed from meta/packages/gstreamer/gstreamer_0.10.17.bb)7
4 files changed, 1 insertions, 95 deletions
diff --git a/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-0.9-binary-registry.patch b/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-0.9-binary-registry.patch
deleted file mode 100644
index e166fc37ee..0000000000
--- a/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-0.9-binary-registry.patch
+++ /dev/null
@@ -1,65 +0,0 @@
1diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gst.c gstreamer-0.10.9/gst/gst.c
2--- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gst.c 2006-07-11 21:16:04.000000000 +0100
3+++ gstreamer-0.10.9/gst/gst.c 2006-09-01 12:30:36.000000000 +0100
4@@ -553,7 +553,7 @@
5 GList *l;
6
7 GST_DEBUG ("reading registry cache: %s", registry_file);
8- gst_registry_xml_read_cache (default_registry, registry_file);
9+ gst_registry_binary_read_cache (default_registry, registry_file);
10
11 /* scan paths specified via --gst-plugin-path */
12 GST_DEBUG ("scanning paths added via --gst-plugin-path");
13@@ -624,7 +624,7 @@
14 }
15
16 GST_DEBUG ("writing registry cache");
17- if (!gst_registry_xml_write_cache (default_registry, registry_file)) {
18+ if (!gst_registry_binary_write_cache (default_registry, registry_file)) {
19 g_warning ("Problem writing registry cache to %s: %s", registry_file,
20 g_strerror (errno));
21 return FALSE;
22@@ -700,7 +700,7 @@
23
24 if (WEXITSTATUS (status) == EXIT_SUCCESS) {
25 GST_DEBUG ("parent reading registry cache");
26- gst_registry_xml_read_cache (default_registry, registry_file);
27+ gst_registry_binary_read_cache (default_registry, registry_file);
28 } else {
29 GST_DEBUG ("parent re-scanning registry");
30 scan_and_update_registry (default_registry, registry_file, FALSE);
31@@ -722,7 +722,7 @@
32 registry_file = g_strdup (g_getenv ("GST_REGISTRY"));
33 if (registry_file == NULL) {
34 registry_file = g_build_filename (g_get_home_dir (),
35- ".gstreamer-" GST_MAJORMINOR, "registry." HOST_CPU ".xml", NULL);
36+ ".gstreamer-" GST_MAJORMINOR, "registry." HOST_CPU ".bin", NULL);
37 }
38 #ifdef HAVE_FORK
39 if (g_getenv ("GST_REGISTRY_FORK") == NULL
40diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gstregistry.h gstreamer-0.10.9/gst/gstregistry.h
41--- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gstregistry.h 2006-07-11 21:16:04.000000000 +0100
42+++ gstreamer-0.10.9/gst/gstregistry.h 2006-09-01 12:30:36.000000000 +0100
43@@ -105,8 +105,8 @@
44 GstPlugin * gst_registry_lookup (GstRegistry *registry, const char *filename);
45 GstPluginFeature * gst_registry_lookup_feature (GstRegistry *registry, const char *name);
46
47-gboolean gst_registry_xml_read_cache (GstRegistry * registry, const char *location);
48-gboolean gst_registry_xml_write_cache (GstRegistry * registry, const char *location);
49+gboolean gst_registry_binary_read_cache (GstRegistry * registry, const char *location);
50+gboolean gst_registry_binary_write_cache (GstRegistry * registry, const char *location);
51
52 void _gst_registry_remove_cache_plugins (GstRegistry *registry);
53
54diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/Makefile.am gstreamer-0.10.9/gst/Makefile.am
55--- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/Makefile.am 2006-07-13 16:31:47.000000000 +0100
56+++ gstreamer-0.10.9/gst/Makefile.am 2006-09-01 12:30:36.000000000 +0100
57@@ -9,7 +9,7 @@
58 if GST_DISABLE_REGISTRY
59 GST_REGISTRY_SRC =
60 else
61-GST_REGISTRY_SRC = gstregistryxml.c
62+GST_REGISTRY_SRC = gstregistrybinary.c
63 endif
64
65 if GST_DISABLE_PARSE
diff --git a/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-omit-debug-directories.patch b/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-omit-debug-directories.patch
deleted file mode 100644
index 9f5d850f50..0000000000
--- a/meta/packages/gstreamer/gstreamer-0.10.17/gstreamer-omit-debug-directories.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1Index: gstreamer-0.10.4/gst/gstregistry.c
2===================================================================
3RCS file: /cvs/gstreamer/gstreamer/gst/gstregistry.c,v
4retrieving revision 1.75
5diff -u -r1.75 gstregistry.c
6--- gstreamer-0.10.4/gst/gstregistry.c 31 Jul 2007 11:51:38 -0000 1.75
7+++ gstreamer-0.10.4/gst/gstregistry.c 8 Jan 2008 14:12:40 -0000
8@@ -813,6 +813,16 @@
9 GST_LOG_OBJECT (registry, "examining file: %s", filename);
10
11 if (g_file_test (filename, G_FILE_TEST_IS_DIR)) {
12+ /*
13+ * skip .debug directories, these contain elf files that can crash
14+ * dlopen
15+ */
16+ if (g_str_equal (dirent, ".debug")) {
17+ GST_LOG_OBJECT (registry, "found .debug directory, ignoring");
18+ g_free (filename);
19+ continue;
20+ }
21+
22 if (level > 0) {
23 GST_LOG_OBJECT (registry, "found directory, recursing");
24 changed |= gst_registry_scan_path_level (registry, filename, level - 1);
diff --git a/meta/packages/gstreamer/gstreamer-0.10.17/gst-inspect-check-error.patch b/meta/packages/gstreamer/gstreamer-0.10.20/gst-inspect-check-error.patch
index 5da6cdd9c8..5da6cdd9c8 100644
--- a/meta/packages/gstreamer/gstreamer-0.10.17/gst-inspect-check-error.patch
+++ b/meta/packages/gstreamer/gstreamer-0.10.20/gst-inspect-check-error.patch
diff --git a/meta/packages/gstreamer/gstreamer_0.10.17.bb b/meta/packages/gstreamer/gstreamer_0.10.20.bb
index f608ca4361..7b9d1ab3e0 100644
--- a/meta/packages/gstreamer/gstreamer_0.10.17.bb
+++ b/meta/packages/gstreamer/gstreamer_0.10.20.bb
@@ -5,22 +5,17 @@ PRIORITY = "optional"
5LICENSE = "LGPL" 5LICENSE = "LGPL"
6HOMEPAGE = "http://www.gstreamer.net/" 6HOMEPAGE = "http://www.gstreamer.net/"
7DEPENDS = "glib-2.0 gettext-native libxml2 bison-native flex-native" 7DEPENDS = "glib-2.0 gettext-native libxml2 bison-native flex-native"
8PR = "r6"
9 8
10inherit autotools pkgconfig 9inherit autotools pkgconfig
11 10
12SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \ 11SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
13 file://gst-inspect-check-error.patch;patch=1 \ 12 file://gst-inspect-check-error.patch;patch=1 \
14 file://gstreamer-omit-debug-directories.patch;patch=1 \
15 file://po-makefile-fix.patch;patch=1" 13 file://po-makefile-fix.patch;patch=1"
16# file://gstregistrybinary.c \
17# file://gstregistrybinary.h \
18# file://gstreamer-0.9-binary-registry.patch;patch=1"
19EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no --disable-examples --disable-tests --disable-valgrind --disable-debug" 14EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no --disable-examples --disable-tests --disable-valgrind --disable-debug"
20 15
21do_configure_prepend() { 16do_configure_prepend() {
22 # This m4 file contains nastiness which conflicts with libtool 2.2.2 17 # This m4 file contains nastiness which conflicts with libtool 2.2.2
23 rm ${S}/common/m4/lib-link.m4 || true 18 rm -f ${S}/common/m4/lib-link.m4 || true
24} 19}
25 20
26#do_compile_prepend () { 21#do_compile_prepend () {