diff options
author | Ross Burton <ross@openedhand.com> | 2008-01-29 16:26:08 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2008-01-29 16:26:08 +0000 |
commit | fa66e62881bdef84b49b9eb0979bc345ae226619 (patch) | |
tree | 1c85e5727f0575c12fa87c1d37d55b7ac6b5700f /meta/packages/gstreamer/gstreamer-0.10.16 | |
parent | 740ad709adc56b51b12a83df64afabb18aaf9301 (diff) | |
download | poky-fa66e62881bdef84b49b9eb0979bc345ae226619.tar.gz |
gstreamer: bump to latest point release
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3616 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gstreamer/gstreamer-0.10.16')
3 files changed, 100 insertions, 0 deletions
diff --git a/meta/packages/gstreamer/gstreamer-0.10.16/gst-inspect-check-error.patch b/meta/packages/gstreamer/gstreamer-0.10.16/gst-inspect-check-error.patch new file mode 100644 index 0000000000..5da6cdd9c8 --- /dev/null +++ b/meta/packages/gstreamer/gstreamer-0.10.16/gst-inspect-check-error.patch | |||
@@ -0,0 +1,11 @@ | |||
1 | --- gstreamer-0.10.9/tools/gst-inspect.c.old 2006-09-12 11:56:53.000000000 +0100 | ||
2 | +++ gstreamer-0.10.9/tools/gst-inspect.c 2006-09-12 11:57:27.000000000 +0100 | ||
3 | @@ -1123,7 +1123,7 @@ | ||
4 | g_option_context_add_main_entries (ctx, options, GETTEXT_PACKAGE); | ||
5 | g_option_context_add_group (ctx, gst_init_get_option_group ()); | ||
6 | if (!g_option_context_parse (ctx, &argc, &argv, &err)) { | ||
7 | - g_print ("Error initializing: %s\n", err->message); | ||
8 | + g_print ("Error initializing: %s\n", err ? err->message : "(null)"); | ||
9 | exit (1); | ||
10 | } | ||
11 | g_option_context_free (ctx); | ||
diff --git a/meta/packages/gstreamer/gstreamer-0.10.16/gstreamer-0.9-binary-registry.patch b/meta/packages/gstreamer/gstreamer-0.10.16/gstreamer-0.9-binary-registry.patch new file mode 100644 index 0000000000..e166fc37ee --- /dev/null +++ b/meta/packages/gstreamer/gstreamer-0.10.16/gstreamer-0.9-binary-registry.patch | |||
@@ -0,0 +1,65 @@ | |||
1 | diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gst.c gstreamer-0.10.9/gst/gst.c | ||
2 | --- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gst.c 2006-07-11 21:16:04.000000000 +0100 | ||
3 | +++ gstreamer-0.10.9/gst/gst.c 2006-09-01 12:30:36.000000000 +0100 | ||
4 | @@ -553,7 +553,7 @@ | ||
5 | GList *l; | ||
6 | |||
7 | GST_DEBUG ("reading registry cache: %s", registry_file); | ||
8 | - gst_registry_xml_read_cache (default_registry, registry_file); | ||
9 | + gst_registry_binary_read_cache (default_registry, registry_file); | ||
10 | |||
11 | /* scan paths specified via --gst-plugin-path */ | ||
12 | GST_DEBUG ("scanning paths added via --gst-plugin-path"); | ||
13 | @@ -624,7 +624,7 @@ | ||
14 | } | ||
15 | |||
16 | GST_DEBUG ("writing registry cache"); | ||
17 | - if (!gst_registry_xml_write_cache (default_registry, registry_file)) { | ||
18 | + if (!gst_registry_binary_write_cache (default_registry, registry_file)) { | ||
19 | g_warning ("Problem writing registry cache to %s: %s", registry_file, | ||
20 | g_strerror (errno)); | ||
21 | return FALSE; | ||
22 | @@ -700,7 +700,7 @@ | ||
23 | |||
24 | if (WEXITSTATUS (status) == EXIT_SUCCESS) { | ||
25 | GST_DEBUG ("parent reading registry cache"); | ||
26 | - gst_registry_xml_read_cache (default_registry, registry_file); | ||
27 | + gst_registry_binary_read_cache (default_registry, registry_file); | ||
28 | } else { | ||
29 | GST_DEBUG ("parent re-scanning registry"); | ||
30 | scan_and_update_registry (default_registry, registry_file, FALSE); | ||
31 | @@ -722,7 +722,7 @@ | ||
32 | registry_file = g_strdup (g_getenv ("GST_REGISTRY")); | ||
33 | if (registry_file == NULL) { | ||
34 | registry_file = g_build_filename (g_get_home_dir (), | ||
35 | - ".gstreamer-" GST_MAJORMINOR, "registry." HOST_CPU ".xml", NULL); | ||
36 | + ".gstreamer-" GST_MAJORMINOR, "registry." HOST_CPU ".bin", NULL); | ||
37 | } | ||
38 | #ifdef HAVE_FORK | ||
39 | if (g_getenv ("GST_REGISTRY_FORK") == NULL | ||
40 | diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gstregistry.h gstreamer-0.10.9/gst/gstregistry.h | ||
41 | --- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/gstregistry.h 2006-07-11 21:16:04.000000000 +0100 | ||
42 | +++ gstreamer-0.10.9/gst/gstregistry.h 2006-09-01 12:30:36.000000000 +0100 | ||
43 | @@ -105,8 +105,8 @@ | ||
44 | GstPlugin * gst_registry_lookup (GstRegistry *registry, const char *filename); | ||
45 | GstPluginFeature * gst_registry_lookup_feature (GstRegistry *registry, const char *name); | ||
46 | |||
47 | -gboolean gst_registry_xml_read_cache (GstRegistry * registry, const char *location); | ||
48 | -gboolean gst_registry_xml_write_cache (GstRegistry * registry, const char *location); | ||
49 | +gboolean gst_registry_binary_read_cache (GstRegistry * registry, const char *location); | ||
50 | +gboolean gst_registry_binary_write_cache (GstRegistry * registry, const char *location); | ||
51 | |||
52 | void _gst_registry_remove_cache_plugins (GstRegistry *registry); | ||
53 | |||
54 | diff -urNd ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/Makefile.am gstreamer-0.10.9/gst/Makefile.am | ||
55 | --- ../gstreamer-0.10.9-r0/gstreamer-0.10.9/gst/Makefile.am 2006-07-13 16:31:47.000000000 +0100 | ||
56 | +++ gstreamer-0.10.9/gst/Makefile.am 2006-09-01 12:30:36.000000000 +0100 | ||
57 | @@ -9,7 +9,7 @@ | ||
58 | if GST_DISABLE_REGISTRY | ||
59 | GST_REGISTRY_SRC = | ||
60 | else | ||
61 | -GST_REGISTRY_SRC = gstregistryxml.c | ||
62 | +GST_REGISTRY_SRC = gstregistrybinary.c | ||
63 | endif | ||
64 | |||
65 | if GST_DISABLE_PARSE | ||
diff --git a/meta/packages/gstreamer/gstreamer-0.10.16/gstreamer-omit-debug-directories.patch b/meta/packages/gstreamer/gstreamer-0.10.16/gstreamer-omit-debug-directories.patch new file mode 100644 index 0000000000..9f5d850f50 --- /dev/null +++ b/meta/packages/gstreamer/gstreamer-0.10.16/gstreamer-omit-debug-directories.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | Index: gstreamer-0.10.4/gst/gstregistry.c | ||
2 | =================================================================== | ||
3 | RCS file: /cvs/gstreamer/gstreamer/gst/gstregistry.c,v | ||
4 | retrieving revision 1.75 | ||
5 | diff -u -r1.75 gstregistry.c | ||
6 | --- gstreamer-0.10.4/gst/gstregistry.c 31 Jul 2007 11:51:38 -0000 1.75 | ||
7 | +++ gstreamer-0.10.4/gst/gstregistry.c 8 Jan 2008 14:12:40 -0000 | ||
8 | @@ -813,6 +813,16 @@ | ||
9 | GST_LOG_OBJECT (registry, "examining file: %s", filename); | ||
10 | |||
11 | if (g_file_test (filename, G_FILE_TEST_IS_DIR)) { | ||
12 | + /* | ||
13 | + * skip .debug directories, these contain elf files that can crash | ||
14 | + * dlopen | ||
15 | + */ | ||
16 | + if (g_str_equal (dirent, ".debug")) { | ||
17 | + GST_LOG_OBJECT (registry, "found .debug directory, ignoring"); | ||
18 | + g_free (filename); | ||
19 | + continue; | ||
20 | + } | ||
21 | + | ||
22 | if (level > 0) { | ||
23 | GST_LOG_OBJECT (registry, "found directory, recursing"); | ||
24 | changed |= gst_registry_scan_path_level (registry, filename, level - 1); | ||