diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/gstreamer/gst-ffmpeg-0.10.1 | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gstreamer/gst-ffmpeg-0.10.1')
-rw-r--r-- | meta/packages/gstreamer/gst-ffmpeg-0.10.1/configure_fix.patch | 13 | ||||
-rw-r--r-- | meta/packages/gstreamer/gst-ffmpeg-0.10.1/no_beos.patch | 55 |
2 files changed, 0 insertions, 68 deletions
diff --git a/meta/packages/gstreamer/gst-ffmpeg-0.10.1/configure_fix.patch b/meta/packages/gstreamer/gst-ffmpeg-0.10.1/configure_fix.patch deleted file mode 100644 index 15f56492f7..0000000000 --- a/meta/packages/gstreamer/gst-ffmpeg-0.10.1/configure_fix.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Index: gst-ffmpeg-0.10.1/gst-libs/ext/ffmpeg/configure.ac | ||
2 | =================================================================== | ||
3 | --- gst-ffmpeg-0.10.1.orig/gst-libs/ext/ffmpeg/configure.ac 2008-03-19 23:21:04.000000000 +0000 | ||
4 | +++ gst-ffmpeg-0.10.1/gst-libs/ext/ffmpeg/configure.ac 2008-03-19 23:21:31.000000000 +0000 | ||
5 | @@ -775,7 +775,7 @@ | ||
6 | |||
7 | dnl Check for SDL, used in ffplay, and ffserver | ||
8 | AC_FF_ALLOW_DISABLE(CONFIG_FFPLAY, ffplay, ffmpeg media player,[ | ||
9 | - AM_PATH_SDL(, CONFIG_FFPLAY=yes, CONFIG_FPFLAY=no) | ||
10 | + CONFIG_FPFLAY=no | ||
11 | ]) | ||
12 | |||
13 | dnl media server or not? | ||
diff --git a/meta/packages/gstreamer/gst-ffmpeg-0.10.1/no_beos.patch b/meta/packages/gstreamer/gst-ffmpeg-0.10.1/no_beos.patch deleted file mode 100644 index 9ffcafff73..0000000000 --- a/meta/packages/gstreamer/gst-ffmpeg-0.10.1/no_beos.patch +++ /dev/null | |||
@@ -1,55 +0,0 @@ | |||
1 | The AC_LANG sections upset libtool 2.2.2, easiest fix is to remove them. | ||
2 | Using a .cpp file in a Makefile means configure.ac must use AC_PROG_CXX | ||
3 | so patch out the section from the makefile too. | ||
4 | |||
5 | RP - 14/4/08 | ||
6 | |||
7 | Index: gst-ffmpeg-0.10.1/gst-libs/ext/ffmpeg/configure.ac | ||
8 | =================================================================== | ||
9 | --- gst-ffmpeg-0.10.1.orig/gst-libs/ext/ffmpeg/configure.ac 2008-04-14 23:55:25.000000000 +0100 | ||
10 | +++ gst-ffmpeg-0.10.1/gst-libs/ext/ffmpeg/configure.ac 2008-04-14 23:56:18.000000000 +0100 | ||
11 | @@ -742,26 +742,7 @@ | ||
12 | |||
13 | dnl Beos Audio | ||
14 | AC_FF_ALLOW_DISABLE(CONFIG_AUDIO_BEOS, audio-beos, BeOS audio support,[ | ||
15 | - if test x$TARGET_OS = xbeos; then | ||
16 | - AC_LANG_CPLUSPLUS | ||
17 | - AC_CHECK_HEADER(SoundPlayer.h,[ | ||
18 | - OLD_CXXFLAGS="$CXXFLAGS" | ||
19 | - CXXFLAGS="$CXXFLAGS -lbe -lmedia" | ||
20 | - AC_MSG_CHECKING(For BeOS audio libraries) | ||
21 | - AC_TRY_COMPILE([ | ||
22 | -#include <Application.h> | ||
23 | -#include <SoundPlayer.h> | ||
24 | - ],[ | ||
25 | - BSoundPlayer *p = new BSoundPlayer(NULL,NULL,NULL); | ||
26 | - ],[ CONFIG_AUDIO_BEOS=yes && AC_MSG_RESULT(yes) ],[ | ||
27 | - CONFIG_AUDIO_BEOS=no && AC_MSG_RESULT(no) | ||
28 | - ]) | ||
29 | - CXXFLAGS="$OLD_CXXFLAGS" | ||
30 | - ], CONFIG_AUDIO_BEOS=no) | ||
31 | - AC_LANG_C | ||
32 | - else | ||
33 | CONFIG_AUDIO_BEOS=no | ||
34 | - fi | ||
35 | ]) | ||
36 | |||
37 | dnl Check for freetype2, used in vook/libdrawtext.so | ||
38 | Index: gst-ffmpeg-0.10.1/gst-libs/ext/ffmpeg/libavformat/Makefile.am | ||
39 | =================================================================== | ||
40 | --- gst-ffmpeg-0.10.1.orig/gst-libs/ext/ffmpeg/libavformat/Makefile.am 2008-04-14 23:58:44.000000000 +0100 | ||
41 | +++ gst-ffmpeg-0.10.1/gst-libs/ext/ffmpeg/libavformat/Makefile.am 2008-04-14 23:58:55.000000000 +0100 | ||
42 | @@ -24,13 +24,6 @@ | ||
43 | audiooss_SRC = audio.c | ||
44 | endif | ||
45 | |||
46 | -if CONFIG_AUDIO_BEOS | ||
47 | -audiobeos_SRC = beosaudio.cpp | ||
48 | -audiobeos_LIBS = \ | ||
49 | - -lbe \ | ||
50 | - -lmedia | ||
51 | -endif | ||
52 | - | ||
53 | if CONFIG_VIDEO4LINUX | ||
54 | v4l_SRC = grab.c v4l2.c | ||
55 | endif | ||