summaryrefslogtreecommitdiffstats
path: root/meta/packages/gpgme
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-16 22:28:18 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-16 22:28:18 +0000
commit81d1490b1d03f1a8b9500b648c9dfc74ca390de1 (patch)
tree164fa494be4242bab51e224f935912025b27cd45 /meta/packages/gpgme
parent668ae67a4fa15e65e26d1c5f480061fe07e4b9db (diff)
downloadpoky-81d1490b1d03f1a8b9500b648c9dfc74ca390de1.tar.gz
gpgme: Convert to autotools_stage_all
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gpgme')
-rw-r--r--meta/packages/gpgme/gpgme_1.1.4.bb14
1 files changed, 1 insertions, 13 deletions
diff --git a/meta/packages/gpgme/gpgme_1.1.4.bb b/meta/packages/gpgme/gpgme_1.1.4.bb
index 8ac8bb3398..826b317351 100644
--- a/meta/packages/gpgme/gpgme_1.1.4.bb
+++ b/meta/packages/gpgme/gpgme_1.1.4.bb
@@ -7,19 +7,7 @@ PR = "r3"
7EXTRA_OECONF = "--with-pth=${STAGING_DIR}/${HOST_SYS} --without-pth-test \ 7EXTRA_OECONF = "--with-pth=${STAGING_DIR}/${HOST_SYS} --without-pth-test \
8 --with-gpg=${bindir}/gpg --without-gpgsm" 8 --with-gpg=${bindir}/gpg --without-gpgsm"
9 9
10inherit autotools binconfig 10inherit autotools_stage binconfig
11
12do_stage() {
13 autotools_stage_includes
14
15 install -d ${STAGING_LIBDIR}
16 oe_libinstall -C gpgme -so libgpgme ${STAGING_LIBDIR}
17 oe_libinstall -C gpgme -so libgpgme-pth ${STAGING_LIBDIR}
18 oe_libinstall -C gpgme -so libgpgme-pthread ${STAGING_LIBDIR}
19
20 install -d ${STAGING_DATADIR}/aclocal
21 install -m 0644 gpgme/gpgme.m4 ${STAGING_DATADIR}/aclocal/
22}
23 11
24PACKAGES =+ "${PN}-pth ${PN}-pthread" 12PACKAGES =+ "${PN}-pth ${PN}-pthread"
25FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*" 13FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"