diff options
author | Qing He <qing.he@intel.com> | 2010-06-23 15:07:39 +0800 |
---|---|---|
committer | Saul Wold <Saul.Wold@intel.com> | 2010-07-08 21:11:00 -0700 |
commit | 424278c7bcccf0334ad4680ded30372616d2c9ab (patch) | |
tree | 682c4edf7fe8853bef3c34b3135bd9b00d6e2e03 /meta/packages/gnutls | |
parent | 8a556a8ca5dfd22e06de57eaf7744ace1d0974a5 (diff) | |
download | poky-424278c7bcccf0334ad4680ded30372616d2c9ab.tar.gz |
gnutls: upgrade to version 2.8.6
from 2.4.2
add homepage and bugtracker
clarify licensing to GPL & LGPL for different sub packages
changes:
- use EXTRA_OECONF to explicitly specify libgcrypt path
- remove multiple aclocal.m4s and distributed libtool m4
scripts to produce sanity environment, otherwise it may
complain about libtool version mismatch at compilation
- rebase configure_madness.patch to adapt new autotools
scripts, change libgnutls.pc.in and libgnutls-extra.pc.in
to fix pkg-config issues
- rebase the other patches
- remove duplicated inheritence
- depends explictly on libgcrypt (>= 1.4.2), or configure
fails
- use standalone version of libtasn1, and add it as a build
dependency on libatsn1
- add --disable-rpath in EXTRA_OECONF to avoid the rpath
pollution by --with-<pkg>-prefix=
Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/gnutls')
-rw-r--r-- | meta/packages/gnutls/gnutls-2.4.2/configure_madness.patch | 57 | ||||
-rw-r--r-- | meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch | 64 | ||||
-rw-r--r-- | meta/packages/gnutls/gnutls-2.8.6/gnutls-openssl.patch (renamed from meta/packages/gnutls/gnutls-2.4.2/gnutls-openssl.patch) | 4 | ||||
-rw-r--r-- | meta/packages/gnutls/gnutls-2.8.6/gnutls-texinfo-euro.patch (renamed from meta/packages/gnutls/gnutls-2.4.2/gnutls-texinfo-euro.patch) | 4 | ||||
-rw-r--r-- | meta/packages/gnutls/gnutls.inc | 26 | ||||
-rw-r--r-- | meta/packages/gnutls/gnutls_2.4.2.bb | 9 | ||||
-rw-r--r-- | meta/packages/gnutls/gnutls_2.8.6.bb | 7 |
7 files changed, 97 insertions, 74 deletions
diff --git a/meta/packages/gnutls/gnutls-2.4.2/configure_madness.patch b/meta/packages/gnutls/gnutls-2.4.2/configure_madness.patch deleted file mode 100644 index 19b6b498b4..0000000000 --- a/meta/packages/gnutls/gnutls-2.4.2/configure_madness.patch +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | --- | ||
2 | configure.in | 8 ++++---- | ||
3 | lib/gnutls.pc.in | 3 ++- | ||
4 | libextra/gnutls-extra.pc.in | 3 ++- | ||
5 | 3 files changed, 8 insertions(+), 6 deletions(-) | ||
6 | |||
7 | --- gnutls-2.4.0.orig/configure.in | ||
8 | +++ gnutls-2.4.0/configure.in | ||
9 | @@ -637,17 +637,17 @@ AC_MSG_RESULT([*** | ||
10 | *** Detecting options for shared libraries... | ||
11 | ]) | ||
12 | AC_LIBTOOL_WIN32_DLL | ||
13 | AC_PROG_LIBTOOL | ||
14 | |||
15 | -LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS" | ||
16 | -LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS -I${includedir}" | ||
17 | +LIBGNUTLS_LIBS="-lgnutls $LIBTASN1_LIBS $LIBGCRYPT_LIBS $LIBS" | ||
18 | +LIBGNUTLS_CFLAGS="$LIBGCRYPT_CFLAGS $LIBTASN1_CFLAGS" | ||
19 | AC_SUBST(LIBGNUTLS_LIBS) | ||
20 | AC_SUBST(LIBGNUTLS_CFLAGS) | ||
21 | |||
22 | -LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS" | ||
23 | -LIBGNUTLS_EXTRA_CFLAGS="-I${includedir}" | ||
24 | +LIBGNUTLS_EXTRA_LIBS=" -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS" | ||
25 | +LIBGNUTLS_EXTRA_CFLAGS="" | ||
26 | AC_SUBST(LIBGNUTLS_EXTRA_LIBS) | ||
27 | AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS) | ||
28 | export ac_full | ||
29 | |||
30 | AM_CFLAGS="${AM_CFLAGS} ${LIBGCRYPT_CFLAGS}" | ||
31 | --- gnutls-2.4.0.orig/lib/gnutls.pc.in | ||
32 | +++ gnutls-2.4.0/lib/gnutls.pc.in | ||
33 | @@ -16,8 +16,9 @@ libdir=@libdir@ | ||
34 | includedir=@includedir@ | ||
35 | |||
36 | Name: GnuTLS | ||
37 | Description: Transport Security Layer implementation for the GNU system | ||
38 | Version: @VERSION@ | ||
39 | +Requires.private: libgcrypt | ||
40 | Libs: -L${libdir} -lgnutls | ||
41 | -Libs.private: @LIBGNUTLS_LIBS@ | ||
42 | +Libs.private: -L${libdir} -lgnutls | ||
43 | Cflags: -I${includedir} | ||
44 | --- gnutls-2.4.0.orig/libextra/gnutls-extra.pc.in | ||
45 | +++ gnutls-2.4.0/libextra/gnutls-extra.pc.in | ||
46 | @@ -16,9 +16,10 @@ libdir=@libdir@ | ||
47 | includedir=@includedir@ | ||
48 | |||
49 | Name: GnuTLS-extra | ||
50 | Description: Additional add-ons for GnuTLS licensed under GPL | ||
51 | Requires: gnutls | ||
52 | +Requires.private: gnutls | ||
53 | Version: @VERSION@ | ||
54 | Libs: -L${libdir} -lgnutls-extra | ||
55 | -Libs.private: @LIBGNUTLS_EXTRA_LIBS@ | ||
56 | +Libs.private: -L${libdir} -lgnutls-extra | ||
57 | Cflags: -I${includedir} | ||
diff --git a/meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch b/meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch new file mode 100644 index 0000000000..247e324564 --- /dev/null +++ b/meta/packages/gnutls/gnutls-2.8.6/configure-fix.patch | |||
@@ -0,0 +1,64 @@ | |||
1 | rebased from original configure_madness.patch | ||
2 | |||
3 | libtasn1 provides an .pc file in upstream, | ||
4 | and a libgcrypt.pc is added in libgcrypt recipe, | ||
5 | so use Requires.private for these two. | ||
6 | |||
7 | against 2.8.6 | ||
8 | |||
9 | 07/02/2010 - qhe | ||
10 | |||
11 | --- | ||
12 | diff --git a/lib/configure.ac b/lib/configure.ac | ||
13 | index 80d3375..1a486f7 100644 | ||
14 | --- a/lib/configure.ac | ||
15 | +++ b/lib/configure.ac | ||
16 | @@ -81,8 +81,8 @@ fi | ||
17 | |||
18 | lgl_INIT | ||
19 | |||
20 | -LIBGNUTLS_LIBS="-L${libdir} -lgnutls $LIBS" | ||
21 | -LIBGNUTLS_CFLAGS="-I${includedir}" | ||
22 | +LIBGNUTLS_LIBS="-lgnutls $LIBS" | ||
23 | +LIBGNUTLS_CFLAGS="" | ||
24 | AC_SUBST(LIBGNUTLS_LIBS) | ||
25 | AC_SUBST(LIBGNUTLS_CFLAGS) | ||
26 | |||
27 | diff --git a/lib/gnutls.pc.in b/lib/gnutls.pc.in | ||
28 | index 3b01c17..de31469 100644 | ||
29 | --- a/lib/gnutls.pc.in | ||
30 | +++ b/lib/gnutls.pc.in | ||
31 | @@ -20,6 +20,6 @@ Name: GnuTLS | ||
32 | Description: Transport Security Layer implementation for the GNU system | ||
33 | URL: http://www.gnu.org/software/gnutls/ | ||
34 | Version: @VERSION@ | ||
35 | +Requires.private: libgcrypt, libtasn1 | ||
36 | Libs: -L${libdir} -lgnutls | ||
37 | -Libs.private: @LIBGNUTLS_LIBS@ @LTLIBTASN1@ | ||
38 | Cflags: -I${includedir} | ||
39 | diff --git a/libextra/configure.ac b/libextra/configure.ac | ||
40 | index c08e73f..3313886 100644 | ||
41 | --- a/libextra/configure.ac | ||
42 | +++ b/libextra/configure.ac | ||
43 | @@ -40,8 +40,8 @@ LIBGNUTLS_EXTRA_HOOKS | ||
44 | |||
45 | xgl_INIT | ||
46 | |||
47 | -LIBGNUTLS_EXTRA_LIBS="-L${libdir} -lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS" | ||
48 | -LIBGNUTLS_EXTRA_CFLAGS="-I${includedir}" | ||
49 | +LIBGNUTLS_EXTRA_LIBS="-lgnutls-extra $LZO_LIBS $LIBGNUTLS_LIBS" | ||
50 | +LIBGNUTLS_EXTRA_CFLAGS="" | ||
51 | AC_SUBST(LIBGNUTLS_EXTRA_LIBS) | ||
52 | AC_SUBST(LIBGNUTLS_EXTRA_CFLAGS) | ||
53 | |||
54 | diff --git a/libextra/gnutls-extra.pc.in b/libextra/gnutls-extra.pc.in | ||
55 | index 9e7b8f6..e228ec9 100644 | ||
56 | --- a/libextra/gnutls-extra.pc.in | ||
57 | +++ b/libextra/gnutls-extra.pc.in | ||
58 | @@ -21,5 +21,5 @@ URL: http://www.gnu.org/software/gnutls/ | ||
59 | Requires: gnutls | ||
60 | Version: @VERSION@ | ||
61 | Libs: -L${libdir} -lgnutls-extra | ||
62 | -Libs.private: @LIBGNUTLS_EXTRA_LIBS@ | ||
63 | +Libs.private: -llzo2 | ||
64 | Cflags: -I${includedir} | ||
diff --git a/meta/packages/gnutls/gnutls-2.4.2/gnutls-openssl.patch b/meta/packages/gnutls/gnutls-2.8.6/gnutls-openssl.patch index e2c189592f..413de06472 100644 --- a/meta/packages/gnutls/gnutls-2.4.2/gnutls-openssl.patch +++ b/meta/packages/gnutls/gnutls-2.8.6/gnutls-openssl.patch | |||
@@ -108,8 +108,8 @@ Index: gnutls-1.6.0/libextra/gnutls_openssl.c | |||
108 | 108 | ||
109 | Index: gnutls-1.6.0/includes/gnutls/openssl.h | 109 | Index: gnutls-1.6.0/includes/gnutls/openssl.h |
110 | =================================================================== | 110 | =================================================================== |
111 | --- gnutls-1.6.0.orig/includes/gnutls/openssl.h 2006-03-08 11:44:58.000000000 +0100 | 111 | --- gnutls-1.6.0.orig/libextra/includes/gnutls/openssl.h 2006-03-08 11:44:58.000000000 +0100 |
112 | +++ gnutls-1.6.0/includes/gnutls/openssl.h 2006-12-12 15:07:26.032227000 +0100 | 112 | +++ gnutls-1.6.0/libextra/includes/gnutls/openssl.h 2006-12-12 15:07:26.032227000 +0100 |
113 | @@ -164,6 +164,11 @@ | 113 | @@ -164,6 +164,11 @@ |
114 | 114 | ||
115 | gnutls_transport_ptr_t rfd; | 115 | gnutls_transport_ptr_t rfd; |
diff --git a/meta/packages/gnutls/gnutls-2.4.2/gnutls-texinfo-euro.patch b/meta/packages/gnutls/gnutls-2.8.6/gnutls-texinfo-euro.patch index e2a2762424..a2d2f03870 100644 --- a/meta/packages/gnutls/gnutls-2.4.2/gnutls-texinfo-euro.patch +++ b/meta/packages/gnutls/gnutls-2.8.6/gnutls-texinfo-euro.patch | |||
@@ -1,8 +1,8 @@ | |||
1 | The version of texinfo in Debian Sarge does not understand the @euro{} command. | 1 | The version of texinfo in Debian Sarge does not understand the @euro{} command. |
2 | This patch replaces the @euro{} command with the word "euro". | 2 | This patch replaces the @euro{} command with the word "euro". |
3 | 3 | ||
4 | --- gnutls-1.3.5/doc/signatures.texi.orig 2006-04-26 08:06:40.918268000 +0930 | 4 | --- gnutls-1.3.5/doc/gnutls.texi.orig 2006-04-26 08:06:40.918268000 +0930 |
5 | +++ gnutls-1.3.5/doc/signatures.texi 2006-04-26 08:06:52.446515440 +0930 | 5 | +++ gnutls-1.3.5/doc/gnutls.texi 2006-04-26 08:06:52.446515440 +0930 |
6 | @@ -11,8 +11,8 @@ | 6 | @@ -11,8 +11,8 @@ |
7 | long as it is difficult enough to generate two different messages with | 7 | long as it is difficult enough to generate two different messages with |
8 | the same hash algorithm output. In that case the same signature could | 8 | the same hash algorithm output. In that case the same signature could |
diff --git a/meta/packages/gnutls/gnutls.inc b/meta/packages/gnutls/gnutls.inc index 474812598a..76f4ca63fd 100644 --- a/meta/packages/gnutls/gnutls.inc +++ b/meta/packages/gnutls/gnutls.inc | |||
@@ -1,14 +1,32 @@ | |||
1 | DESCRIPTION = "GNU Transport Layer Security Library" | 1 | DESCRIPTION = "GNU Transport Layer Security Library" |
2 | HOMEPAGE = "http://www.gnu.org/software/gnutls/" | 2 | HOMEPAGE = "http://www.gnu.org/software/gnutls/" |
3 | DEPENDS = "zlib libgcrypt lzo gettext" | 3 | BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls" |
4 | DEPENDS = "zlib lzo gettext libtasn1 libgcrypt (>= 1.4.2)" | ||
4 | 5 | ||
5 | LICENSE = "LGPL" | 6 | LICENSE = "GPLv3+ & LGPLv2.1+" |
7 | LICENSE_${PN} = "LGPLv2.1+" | ||
8 | LICENSE_${PN}-xx = "GPLv2.1+" | ||
9 | LICENSE_${PN}-bin = "GPLv3+" | ||
10 | LICENSE_${PN}-extra = "GPLv3+" | ||
11 | LICENSE_${PN}-openssl = "GPLv3+" | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ | ||
13 | file://lib/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \ | ||
14 | file://libextra/COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
6 | 15 | ||
7 | SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2" | 16 | SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2" |
8 | 17 | ||
9 | inherit autotools binconfig pkgconfig pkgconfig | 18 | inherit autotools binconfig pkgconfig |
10 | 19 | ||
11 | EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1 --with-included-libcfg --with-libz-prefix=${STAGING_DIR_HOST}${prefix} --with-lzo --disable-guile" | 20 | EXTRA_OECONF="--with-included-opencdk --with-included-libcfg --disable-rpath \ |
21 | --with-libtasn1-prefix=${STAGING_DIR_HOST}${prefix} \ | ||
22 | --with-libgcrypt-prefix=${STAGING_DIR_HOST}${prefix} \ | ||
23 | --with-libz-prefix=${STAGING_DIR_HOST}${prefix} --with-lzo --disable-guile" | ||
24 | |||
25 | do_configure_prepend() { | ||
26 | for dir in . lib libextra; do | ||
27 | rm ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4 | ||
28 | done | ||
29 | } | ||
12 | 30 | ||
13 | PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin ${PN}-xx" | 31 | PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin ${PN}-xx" |
14 | 32 | ||
diff --git a/meta/packages/gnutls/gnutls_2.4.2.bb b/meta/packages/gnutls/gnutls_2.4.2.bb deleted file mode 100644 index 150c97cb85..0000000000 --- a/meta/packages/gnutls/gnutls_2.4.2.bb +++ /dev/null | |||
@@ -1,9 +0,0 @@ | |||
1 | require gnutls.inc | ||
2 | |||
3 | PR = "r1" | ||
4 | |||
5 | SRC_URI += "\ | ||
6 | file://gnutls-openssl.patch;patch=1 \ | ||
7 | file://gnutls-texinfo-euro.patch;patch=1 \ | ||
8 | file://configure_madness.patch;patch=1 \ | ||
9 | " | ||
diff --git a/meta/packages/gnutls/gnutls_2.8.6.bb b/meta/packages/gnutls/gnutls_2.8.6.bb new file mode 100644 index 0000000000..d8adc6ba17 --- /dev/null +++ b/meta/packages/gnutls/gnutls_2.8.6.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | require gnutls.inc | ||
2 | |||
3 | PR = "r0" | ||
4 | |||
5 | SRC_URI += "file://gnutls-openssl.patch \ | ||
6 | file://gnutls-texinfo-euro.patch \ | ||
7 | file://configure-fix.patch" | ||