diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-01-27 15:44:07 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-01-27 15:44:07 +0000 |
commit | 463c2d644939f54854d27cf0f0afc0a3bf762968 (patch) | |
tree | 5746da8641a862c313bdf3e54e85533534be4557 /meta/packages/gnome | |
parent | d9c8f31557504b38b0b084791e49539b07334f1e (diff) | |
download | poky-463c2d644939f54854d27cf0f0afc0a3bf762968.tar.gz |
metacity-clutter: Add cross compile patch so compiles on x86_64 work for i386 targets
Diffstat (limited to 'meta/packages/gnome')
-rw-r--r-- | meta/packages/gnome/metacity-clutter/crosscompile.patch | 55 | ||||
-rw-r--r-- | meta/packages/gnome/metacity-clutter_git.bb | 9 |
2 files changed, 62 insertions, 2 deletions
diff --git a/meta/packages/gnome/metacity-clutter/crosscompile.patch b/meta/packages/gnome/metacity-clutter/crosscompile.patch new file mode 100644 index 0000000000..b27383b09a --- /dev/null +++ b/meta/packages/gnome/metacity-clutter/crosscompile.patch | |||
@@ -0,0 +1,55 @@ | |||
1 | Index: git/configure.in | ||
2 | =================================================================== | ||
3 | --- git.orig/configure.in 2009-01-27 14:49:10.000000000 +0000 | ||
4 | +++ git/configure.in 2009-01-27 15:29:41.000000000 +0000 | ||
5 | @@ -46,6 +46,32 @@ | ||
6 | AC_LIBTOOL_WIN32_DLL | ||
7 | AM_PROG_LIBTOOL | ||
8 | |||
9 | +if test x"$CC_FOR_BUILD" = x; then | ||
10 | + if test x"$cross_compiling" = xyes; then | ||
11 | + AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc) | ||
12 | + else | ||
13 | + CC_FOR_BUILD="$CC" | ||
14 | + fi | ||
15 | +fi | ||
16 | +AC_SUBST([CC_FOR_BUILD]) | ||
17 | +if test x"$CFLAGS_FOR_BUILD" = x; then | ||
18 | + if test x"$cross_compiling" = xyes; then | ||
19 | + AC_CHECK_PROGS(CFLAGS_FOR_BUILD, gcc cc) | ||
20 | + else | ||
21 | + CFLAGS_FOR_BUILD="$CFLAGS" | ||
22 | + fi | ||
23 | +fi | ||
24 | +AC_SUBST([CFLAGS_FOR_BUILD]) | ||
25 | +if test x"$LDFLAGS_FOR_BUILD" = x; then | ||
26 | + if test x"$cross_compiling" = xyes; then | ||
27 | + AC_CHECK_PROGS(LDFLAGS_FOR_BUILD, gcc cc) | ||
28 | + else | ||
29 | + LDFLAGS_FOR_BUILD="$LDFLAGS" | ||
30 | + fi | ||
31 | +fi | ||
32 | +AC_SUBST([LDFLAGS_FOR_BUILD]) | ||
33 | + | ||
34 | + | ||
35 | #### Integer sizes | ||
36 | |||
37 | AC_CHECK_SIZEOF(char) | ||
38 | Index: git/src/Makefile.am | ||
39 | =================================================================== | ||
40 | --- git.orig/src/Makefile.am 2009-01-27 15:25:31.000000000 +0000 | ||
41 | +++ git/src/Makefile.am 2009-01-27 15:39:54.000000000 +0000 | ||
42 | @@ -168,11 +168,9 @@ | ||
43 | metacity_dialog_SOURCES= \ | ||
44 | ui/metacity-dialog.c | ||
45 | |||
46 | -schema_bindings_SOURCES = \ | ||
47 | - core/schema-bindings.c \ | ||
48 | - metacity.schemas.in.in | ||
49 | +schema_bindings: | ||
50 | + @CC_FOR_BUILD@ core/schema-bindings.c -I./include -I ../ @CFLAGS_FOR_BUILD@ @LDFLAGS_FOR_BUILD@ -o schema_bindings | ||
51 | |||
52 | -schema_bindings_LDADD = @METACITY_LIBS@ | ||
53 | metacity.schemas.in: schema_bindings ${srcdir}/metacity.schemas.in.in | ||
54 | @echo Generating keybinding schemas... ${srcdir}/metacity.schemas.in.in | ||
55 | ${builddir}/schema_bindings ${srcdir}/metacity.schemas.in.in ${builddir}/metacity.schemas.in | ||
diff --git a/meta/packages/gnome/metacity-clutter_git.bb b/meta/packages/gnome/metacity-clutter_git.bb index 94e25a8b4a..00d9a9427e 100644 --- a/meta/packages/gnome/metacity-clutter_git.bb +++ b/meta/packages/gnome/metacity-clutter_git.bb | |||
@@ -1,13 +1,14 @@ | |||
1 | SECTION = "x11/wm" | 1 | SECTION = "x11/wm" |
2 | DESCRIPTION = "Metacity is the boring window manager for the adult in you." | 2 | DESCRIPTION = "Metacity is the boring window manager for the adult in you." |
3 | LICENSE = "GPL" | 3 | LICENSE = "GPL" |
4 | DEPENDS = "startup-notification gtk+ gconf clutter-0.8 gdk-pixbuf-csource-native intltool" | 4 | DEPENDS = "startup-notification gtk+ gconf clutter-0.8 gdk-pixbuf-csource-native intltool glib-2.0-native" |
5 | PR = "r7" | 5 | PR = "r8" |
6 | PV = "2.25.1+git${SRCREV}" | 6 | PV = "2.25.1+git${SRCREV}" |
7 | inherit gnome update-alternatives | 7 | inherit gnome update-alternatives |
8 | 8 | ||
9 | SRC_URI = "git://git.o-hand.com/metacity-clutter.git;protocol=git;branch=clutter \ | 9 | SRC_URI = "git://git.o-hand.com/metacity-clutter.git;protocol=git;branch=clutter \ |
10 | file://nodocs.patch;patch=1 \ | 10 | file://nodocs.patch;patch=1 \ |
11 | file://crosscompile.patch;patch=1 \ | ||
11 | file://fix_pkgconfig.patch;patch=1" | 12 | file://fix_pkgconfig.patch;patch=1" |
12 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
13 | 14 | ||
@@ -23,6 +24,10 @@ EXTRA_OECONF += "--disable-verbose \ | |||
23 | FILES_${PN} += "${datadir}/themes ${libdir}/metacity/plugins/clutter/*.so" | 24 | FILES_${PN} += "${datadir}/themes ${libdir}/metacity/plugins/clutter/*.so" |
24 | FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*" | 25 | FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*" |
25 | 26 | ||
27 | export CC_FOR_BUILD = "${BUILD_CC}" | ||
28 | export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE}/glib-2.0 -I${STAGING_INCDIR_NATIVE}/glib-2.0/include" | ||
29 | export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS} -L${STAGING_LIBDIR_NATIVE} -lglib-2.0" | ||
30 | |||
26 | do_configure_prepend () { | 31 | do_configure_prepend () { |
27 | echo "EXTRA_DIST=" > ${S}/gnome-doc-utils.make | 32 | echo "EXTRA_DIST=" > ${S}/gnome-doc-utils.make |
28 | } | 33 | } |