diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2008-06-20 13:58:15 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2008-06-20 13:58:15 +0000 |
commit | f3b60f7bda68c397406374adadeec4032d27bc76 (patch) | |
tree | 45683c9d4b3daeda5518edacec0220ebff85180e /meta/packages/gmp/gmp-4.2.2 | |
parent | fcbca8870cbeb3a49cebcd3e596408070e6a1cd4 (diff) | |
download | poky-f3b60f7bda68c397406374adadeec4032d27bc76.tar.gz |
gmp: update to 4.2.2 - this will unbreak Pinky on distibutions with gcc 4.3 (from trunk)
git-svn-id: https://svn.o-hand.com/repos/poky/branches/pinky@4716 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gmp/gmp-4.2.2')
-rw-r--r-- | meta/packages/gmp/gmp-4.2.2/amd64.patch | 14 | ||||
-rw-r--r-- | meta/packages/gmp/gmp-4.2.2/configure.patch | 195 | ||||
-rw-r--r-- | meta/packages/gmp/gmp-4.2.2/sh4-asmfix.patch | 26 |
3 files changed, 235 insertions, 0 deletions
diff --git a/meta/packages/gmp/gmp-4.2.2/amd64.patch b/meta/packages/gmp/gmp-4.2.2/amd64.patch new file mode 100644 index 0000000000..67be9dd350 --- /dev/null +++ b/meta/packages/gmp/gmp-4.2.2/amd64.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | --- gmp-4.1.4/longlong.h.orig 2004-04-22 00:34:28.000000000 +0200 | ||
2 | +++ gmp-4.1.4/longlong.h 2005-07-18 01:13:06.000000000 +0200 | ||
3 | @@ -738,8 +738,10 @@ | ||
4 | count is only an int. */ | ||
5 | #define count_trailing_zeros(count, x) \ | ||
6 | do { \ | ||
7 | + UDItype __cbtmp; \ | ||
8 | ASSERT ((x) != 0); \ | ||
9 | - __asm__ ("bsfq %1,%q0" : "=r" (count) : "rm" ((UDItype)(x))); \ | ||
10 | + __asm__ ("bsfq %1,%0" : "=r" (__cbtmp) : "rm" ((UDItype)(x))); \ | ||
11 | + (count) = __cbtmp; \ | ||
12 | } while (0) | ||
13 | #endif /* x86_64 */ | ||
14 | |||
diff --git a/meta/packages/gmp/gmp-4.2.2/configure.patch b/meta/packages/gmp/gmp-4.2.2/configure.patch new file mode 100644 index 0000000000..b563bd0586 --- /dev/null +++ b/meta/packages/gmp/gmp-4.2.2/configure.patch | |||
@@ -0,0 +1,195 @@ | |||
1 | acinclude.m4 | 26 ++++++++++++++------------ | ||
2 | configure.in | 24 +++++++++--------------- | ||
3 | 2 files changed, 23 insertions(+), 27 deletions(-) | ||
4 | |||
5 | Index: gmp-4.2.2/acinclude.m4 | ||
6 | =================================================================== | ||
7 | --- gmp-4.2.2.orig/acinclude.m4 2007-09-01 11:09:03.000000000 +0100 | ||
8 | +++ gmp-4.2.2/acinclude.m4 2008-04-30 17:19:16.000000000 +0100 | ||
9 | @@ -30,20 +30,20 @@ | ||
10 | dnl conftest.exe - various DOS compilers | ||
11 | |||
12 | |||
13 | -define(IA64_PATTERN, | ||
14 | +define([IA64_PATTERN], | ||
15 | [[ia64*-*-* | itanium-*-* | itanium2-*-*]]) | ||
16 | |||
17 | dnl Need to be careful not to match m6811, m6812, m68hc11 and m68hc12, all | ||
18 | dnl of which config.sub accepts. (Though none of which are likely to work | ||
19 | dnl with GMP.) | ||
20 | dnl | ||
21 | -define(M68K_PATTERN, | ||
22 | +define([M68K_PATTERN], | ||
23 | [[m68k-*-* | m68[0-9][0-9][0-9]-*-*]]) | ||
24 | |||
25 | -define(POWERPC64_PATTERN, | ||
26 | +define([POWERPC64_PATTERN], | ||
27 | [[powerpc64-*-* | powerpc64le-*-* | powerpc620-*-* | powerpc630-*-* | powerpc970-*-* | power[3-9]-*-*]]) | ||
28 | |||
29 | -define(X86_PATTERN, | ||
30 | +define([X86_PATTERN], | ||
31 | [[i?86*-*-* | k[5-8]*-*-* | pentium*-*-* | athlon-*-* | viac3*-*-*]]) | ||
32 | |||
33 | |||
34 | @@ -62,7 +62,7 @@ | ||
35 | dnl x86/k6 -> k6 | ||
36 | dnl x86/k6/mmx -> k6_mmx | ||
37 | |||
38 | -define(GMP_FAT_SUFFIX, | ||
39 | +define([GMP_FAT_SUFFIX], | ||
40 | [[$1=`echo $2 | sed -e '/\//s:^[^/]*/::' -e 's:[\\/]:_:g'`]]) | ||
41 | |||
42 | |||
43 | @@ -71,7 +71,7 @@ | ||
44 | dnl Emit code to remove any occurance of ITEM from $LISTVAR. ITEM can be a | ||
45 | dnl shell expression like $foo if desired. | ||
46 | |||
47 | -define(GMP_REMOVE_FROM_LIST, | ||
48 | +define([GMP_REMOVE_FROM_LIST], | ||
49 | [remove_from_list_tmp= | ||
50 | for remove_from_list_i in $[][$1]; do | ||
51 | if test $remove_from_list_i = [$2]; then :; | ||
52 | @@ -87,12 +87,12 @@ | ||
53 | dnl ---------------------- | ||
54 | dnl Strip entries subdir from $path and $fat_path. | ||
55 | |||
56 | -define(GMP_STRIP_PATH, | ||
57 | +define([GMP_STRIP_PATH], | ||
58 | [GMP_STRIP_PATH_VAR(path, [$1]) | ||
59 | GMP_STRIP_PATH_VAR(fat_path, [$1]) | ||
60 | ]) | ||
61 | |||
62 | -define(GMP_STRIP_PATH_VAR, | ||
63 | +define([GMP_STRIP_PATH_VAR], | ||
64 | [tmp_path= | ||
65 | for i in $[][$1]; do | ||
66 | case $i in | ||
67 | @@ -113,7 +113,7 @@ | ||
68 | dnl Dummy values for __GMP_BITS_PER_MP_LIMB and GMP_LIMB_BITS are enough | ||
69 | dnl for all current configure-time uses of gmp.h. | ||
70 | |||
71 | -define(GMP_INCLUDE_GMP_H, | ||
72 | +define([GMP_INCLUDE_GMP_H], | ||
73 | [[#define __GMP_WITHIN_CONFIGURE 1 /* ignore template stuff */ | ||
74 | #define GMP_NAIL_BITS $GMP_NAIL_BITS | ||
75 | #define __GMP_BITS_PER_MP_LIMB 123 /* dummy for GMP_NUMB_BITS etc */ | ||
76 | @@ -129,7 +129,7 @@ | ||
77 | dnl FILE. The regexps here aren't very rugged, but are enough for gmp. | ||
78 | dnl /dev/null as a parameter prevents a hang if $2 is accidentally omitted. | ||
79 | |||
80 | -define(GMP_HEADER_GETVAL, | ||
81 | +define([GMP_HEADER_GETVAL], | ||
82 | [patsubst(patsubst( | ||
83 | esyscmd([grep "^#define $1 " $2 /dev/null 2>/dev/null]), | ||
84 | [^.*$1[ ]+],[]), | ||
85 | @@ -143,7 +143,7 @@ | ||
86 | dnl autoconf time. Two digits like 3.0 if patchlevel <= 0, or three digits | ||
87 | dnl like 3.0.1 if patchlevel > 0. | ||
88 | |||
89 | -define(GMP_VERSION, | ||
90 | +define([GMP_VERSION], | ||
91 | [GMP_HEADER_GETVAL(__GNU_MP_VERSION,gmp-h.in)[]dnl | ||
92 | .GMP_HEADER_GETVAL(__GNU_MP_VERSION_MINOR,gmp-h.in)[]dnl | ||
93 | ifelse(m4_eval(GMP_HEADER_GETVAL(__GNU_MP_VERSION_PATCHLEVEL,gmp-h.in) > 0),1, | ||
94 | @@ -1489,7 +1489,9 @@ | ||
95 | echo ["define(<CONFIG_TOP_SRCDIR>,<\`$tmp'>)"] >>$gmp_tmpconfigm4 | ||
96 | |||
97 | # All CPUs use asm-defs.m4 | ||
98 | -echo ["include][(CONFIG_TOP_SRCDIR\`/mpn/asm-defs.m4')"] >>$gmp_tmpconfigm4i | ||
99 | +echo -n ["include("] >>$gmp_tmpconfigm4i | ||
100 | +echo -n ["CONFIG_TOP_SRCDIR\`/mpn/asm-defs.m4'"] >>$gmp_tmpconfigm4i | ||
101 | +echo [")"] >>$gmp_tmpconfigm4i | ||
102 | ]) | ||
103 | |||
104 | |||
105 | Index: gmp-4.2.2/configure.in | ||
106 | =================================================================== | ||
107 | --- gmp-4.2.2.orig/configure.in 2007-09-09 17:39:14.000000000 +0100 | ||
108 | +++ gmp-4.2.2/configure.in 2008-04-30 17:09:10.000000000 +0100 | ||
109 | @@ -29,12 +29,6 @@ | ||
110 | AC_PREREQ(2.59) | ||
111 | AC_INIT(GNU MP, GMP_VERSION, gmp-bugs@swox.com, gmp) | ||
112 | AC_CONFIG_SRCDIR(gmp-impl.h) | ||
113 | -m4_pattern_forbid([^[ \t]*GMP_]) | ||
114 | -m4_pattern_allow(GMP_LDFLAGS) | ||
115 | -m4_pattern_allow(GMP_LIMB_BITS) | ||
116 | -m4_pattern_allow(GMP_MPARAM_H_SUGGEST) | ||
117 | -m4_pattern_allow(GMP_NAIL_BITS) | ||
118 | -m4_pattern_allow(GMP_NUMB_BITS) | ||
119 | |||
120 | # If --target is not used then $target_alias is empty, but if say | ||
121 | # "./configure athlon-pc-freebsd3.5" is used, then all three of | ||
122 | @@ -275,7 +269,7 @@ | ||
123 | # After GMP specific searches and tests, the standard autoconf AC_PROG_CC is | ||
124 | # called. User selections of CC etc are respected. | ||
125 | # | ||
126 | -# Care is taken not to use macros like AC_TRY_COMPILE during the GMP | ||
127 | +# Care is taken not to use macros like AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[]])],[],[]) during the GMP | ||
128 | # pre-testing, since they of course depend on AC_PROG_CC, and also some of | ||
129 | # them cache their results, which is not wanted. | ||
130 | # | ||
131 | @@ -367,7 +361,7 @@ | ||
132 | # FIXME: We'd like to prefer an ANSI compiler, perhaps by preferring | ||
133 | # c89 over cc here. But note that on HP-UX c89 provides a castrated | ||
134 | # environment, and would want to be excluded somehow. Maybe | ||
135 | -# AC_PROG_CC_STDC already does enough to stick cc into ANSI mode and | ||
136 | +# already does enough to stick cc into ANSI mode and | ||
137 | # we don't need to worry. | ||
138 | # | ||
139 | cclist="gcc cc" | ||
140 | @@ -1518,7 +1512,7 @@ | ||
141 | CFLAGS_or_unset=${CFLAGS-'(unset)'} | ||
142 | CPPFLAGS_or_unset=${CPPFLAGS-'(unset)'} | ||
143 | |||
144 | -cat >&AC_FD_CC <<EOF | ||
145 | +cat >&AS_MESSAGE_LOG_FD() <<EOF | ||
146 | User: | ||
147 | ABI=$ABI | ||
148 | CC=$CC | ||
149 | @@ -1889,7 +1883,6 @@ | ||
150 | |||
151 | # The C compiler and preprocessor, put into ANSI mode if possible. | ||
152 | AC_PROG_CC | ||
153 | -AC_PROG_CC_STDC | ||
154 | AC_PROG_CPP | ||
155 | GMP_H_ANSI | ||
156 | |||
157 | @@ -1912,11 +1905,11 @@ | ||
158 | |||
159 | # The C++ compiler, if desired. | ||
160 | want_cxx=no | ||
161 | +AC_PROG_CXX | ||
162 | if test $enable_cxx != no; then | ||
163 | test_CXXFLAGS=${CXXFLAGS+set} | ||
164 | - AC_PROG_CXX | ||
165 | |||
166 | - echo "CXXFLAGS chosen by autoconf: $CXXFLAGS" >&AC_FD_CC | ||
167 | + echo "CXXFLAGS chosen by autoconf: $CXXFLAGS" >&AS_MESSAGE_LOG_FD() | ||
168 | cxxflags_ac_prog_cxx=$CXXFLAGS | ||
169 | cxxflags_list=ac_prog_cxx | ||
170 | |||
171 | @@ -2022,7 +2015,7 @@ | ||
172 | esac | ||
173 | |||
174 | |||
175 | -cat >&AC_FD_CC <<EOF | ||
176 | +cat >&AS_MESSAGE_LOG_FD() <<EOF | ||
177 | Decided: | ||
178 | ABI=$ABI | ||
179 | CC=$CC | ||
180 | @@ -3199,7 +3192,7 @@ | ||
181 | # FIXME: Upcoming version of autoconf/automake may not like broken lines. | ||
182 | # Right now automake isn't accepting the new AC_CONFIG_FILES scheme. | ||
183 | |||
184 | -AC_OUTPUT(Makefile \ | ||
185 | +AC_CONFIG_FILES([Makefile \ | ||
186 | mpbsd/Makefile mpf/Makefile mpn/Makefile mpq/Makefile \ | ||
187 | mpz/Makefile printf/Makefile scanf/Makefile cxx/Makefile \ | ||
188 | tests/Makefile tests/devel/Makefile tests/mpbsd/Makefile \ | ||
189 | @@ -3208,4 +3201,5 @@ | ||
190 | tests/cxx/Makefile \ | ||
191 | doc/Makefile tune/Makefile \ | ||
192 | demos/Makefile demos/calc/Makefile demos/expr/Makefile \ | ||
193 | - gmp.h:gmp-h.in mp.h:mp-h.in) | ||
194 | + gmp.h:gmp-h.in mp.h:mp-h.in]) | ||
195 | +AC_OUTPUT | ||
diff --git a/meta/packages/gmp/gmp-4.2.2/sh4-asmfix.patch b/meta/packages/gmp/gmp-4.2.2/sh4-asmfix.patch new file mode 100644 index 0000000000..1a01f61533 --- /dev/null +++ b/meta/packages/gmp/gmp-4.2.2/sh4-asmfix.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | --- gmp-4.1.4/mpn/sh/add_n.s 2005/11/17 08:44:00 1.1 | ||
2 | +++ gmp-4.1.4/mpn/sh/add_n.s 2005/11/17 08:18:57 | ||
3 | @@ -29,8 +29,8 @@ | ||
4 | |||
5 | .text | ||
6 | .align 2 | ||
7 | - .global ___gmpn_add_n | ||
8 | -___gmpn_add_n: | ||
9 | + .global __gmpn_add_n | ||
10 | +__gmpn_add_n: | ||
11 | mov #0,r3 ! clear cy save reg | ||
12 | |||
13 | Loop: mov.l @r5+,r1 | ||
14 | --- gmp-4.1.4/mpn/sh/sub_n.s 2005/11/17 08:44:04 1.1 | ||
15 | +++ gmp-4.1.4/mpn/sh/sub_n.s 2005/11/17 08:18:59 | ||
16 | @@ -29,8 +29,8 @@ | ||
17 | |||
18 | .text | ||
19 | .align 2 | ||
20 | - .global ___gmpn_sub_n | ||
21 | -___gmpn_sub_n: | ||
22 | + .global __gmpn_sub_n | ||
23 | +__gmpn_sub_n: | ||
24 | mov #0,r3 ! clear cy save reg | ||
25 | |||
26 | Loop: mov.l @r5+,r1 | ||