summaryrefslogtreecommitdiffstats
path: root/meta/packages/gmp/gmp-4.2.1/disable-stdc.patch
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-08-13 17:34:24 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-13 23:38:16 +0100
commit26db53b91f1b37523f2d01632dae241f62dd59f5 (patch)
tree4b5692e3d3b717768a33e41089e7a73b2756208b /meta/packages/gmp/gmp-4.2.1/disable-stdc.patch
parentf53504d28c47d8edda4f091db1cf463c9578dc04 (diff)
downloadpoky-26db53b91f1b37523f2d01632dae241f62dd59f5.tar.gz
gmp: add GPLv2 version (4.2.1)
The latest GPLv2 version of gmp is 4.2.1, which was released in 2006/05. This GPLv2 recipe is written in clean house approach, w/o looking at either v3 source code and recipe. One patch (disable-stdc.patch) is added, which is also written from scratch and licensed under GPLv2 test with 'calc' which is shipped by gmp package Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/gmp/gmp-4.2.1/disable-stdc.patch')
-rw-r--r--meta/packages/gmp/gmp-4.2.1/disable-stdc.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/packages/gmp/gmp-4.2.1/disable-stdc.patch b/meta/packages/gmp/gmp-4.2.1/disable-stdc.patch
new file mode 100644
index 0000000000..83c9eae36a
--- /dev/null
+++ b/meta/packages/gmp/gmp-4.2.1/disable-stdc.patch
@@ -0,0 +1,31 @@
1# "extern inline" in traditional gcc means that the function should be
2# inlined wherever it's seen, while in C99, "extern inline" means that i
3# the function should only be inlined where the inline definition is
4# seen while in other places it's not inlined:
5# http://gcc.gnu.org/ml/gcc/2006-11/msg00006.html
6#
7# gmp checks "--std=gnu99" to use C99 convention however it internally
8# defines some "extern inline" functions in gmp.h, which is included
9# by mainly .c files and finally lead a flood of redefinition function
10# errors when linking objects together.
11#
12# So disable C99/ANSI detection to stick to tranditional gcc behavior
13#
14# by Kevin Tian <kevin.tian@intel.com>, 2010-08-13
15#
16# (this patch is licensed under GPLv2+)
17
18diff --git a/configure.in b/configure.in
19index 450cc92..aab0b59 100644
20--- a/configure.in
21+++ b/configure.in
22@@ -1869,9 +1869,7 @@ AC_SUBST(DEFN_LONG_LONG_LIMB)
23
24 # The C compiler and preprocessor, put into ANSI mode if possible.
25 AC_PROG_CC
26-AC_PROG_CC_STDC
27 AC_PROG_CPP
28-GMP_H_ANSI
29
30
31 # The C compiler on the build system, and associated tests.