diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-09-16 23:09:44 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-09-17 22:24:36 +0100 |
commit | af85ce4b4e675feb5796f87137c86d70c2f15b9a (patch) | |
tree | f19dbb9bcf1eec671b26685458f7cc47ebb3721e /meta/packages/glibc | |
parent | 046ae6a38d829048663fe1afb1f67de1fbe2e3b5 (diff) | |
download | poky-af85ce4b4e675feb5796f87137c86d70c2f15b9a.tar.gz |
Remove layout_* variables
Remove layout_* variables and replace them with variables specific to the
different classes. The layout variables were only useful for the native/cross
classes and caused more confusion than they solved. They didn't scale to the
sdk class. It now clear a small set of native/cross variables fulfil the needs.
This patch also changes native.bbclass to use "/" as the STAGING_DIR which makes
sense since we're installing binaries into the locations we're compiling them for.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/glibc')
-rw-r--r-- | meta/packages/glibc/glibc-initial.inc | 10 | ||||
-rw-r--r-- | meta/packages/glibc/glibc_2.4.bb | 2 | ||||
-rw-r--r-- | meta/packages/glibc/glibc_2.5.bb | 2 | ||||
-rw-r--r-- | meta/packages/glibc/glibc_2.6.1.bb | 3 | ||||
-rw-r--r-- | meta/packages/glibc/glibc_2.9.bb | 2 | ||||
-rw-r--r-- | meta/packages/glibc/glibc_csl-2005q3-2.bb | 2 |
6 files changed, 10 insertions, 11 deletions
diff --git a/meta/packages/glibc/glibc-initial.inc b/meta/packages/glibc/glibc-initial.inc index 21b7631d3e..127e93e9d3 100644 --- a/meta/packages/glibc/glibc-initial.inc +++ b/meta/packages/glibc/glibc-initial.inc | |||
@@ -12,7 +12,7 @@ do_configure () { | |||
12 | find ${S} -name "configure" | xargs touch | 12 | find ${S} -name "configure" | xargs touch |
13 | ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \ | 13 | ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \ |
14 | --without-cvs --disable-sanity-checks \ | 14 | --without-cvs --disable-sanity-checks \ |
15 | --with-headers=${STAGING_DIR_TARGET}${layout_includedir} \ | 15 | --with-headers=${STAGING_DIR_TARGET}${includedir} \ |
16 | --enable-hacker-mode | 16 | --enable-hacker-mode |
17 | if grep -q GLIBC_2.3 ${S}/ChangeLog; then | 17 | if grep -q GLIBC_2.3 ${S}/ChangeLog; then |
18 | # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler. | 18 | # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler. |
@@ -32,7 +32,7 @@ do_compile () { | |||
32 | 32 | ||
33 | do_stage () { | 33 | do_stage () { |
34 | oe_runmake cross-compiling=yes install_root=${STAGING_DIR_HOST} \ | 34 | oe_runmake cross-compiling=yes install_root=${STAGING_DIR_HOST} \ |
35 | includedir='${layout_includedir}' prefix='${layout_prefix}' \ | 35 | includedir='${includedir}' prefix='${prefix}' \ |
36 | install-bootstrap-headers=yes install-headers | 36 | install-bootstrap-headers=yes install-headers |
37 | 37 | ||
38 | oe_runmake csu/subdir_lib | 38 | oe_runmake csu/subdir_lib |
@@ -46,10 +46,10 @@ do_stage () { | |||
46 | if [ -e ${B}/bits/stdio_lim.h ]; then | 46 | if [ -e ${B}/bits/stdio_lim.h ]; then |
47 | cp ${B}/bits/stdio_lim.h ${STAGING_INCDIR}/bits/ | 47 | cp ${B}/bits/stdio_lim.h ${STAGING_INCDIR}/bits/ |
48 | fi | 48 | fi |
49 | mkdir -p ${STAGING_DIR_TARGET}${layout_libdir} | 49 | mkdir -p ${STAGING_DIR_TARGET}${libdir} |
50 | install -m 644 csu/crt[1in].o ${STAGING_DIR_TARGET}${layout_libdir} | 50 | install -m 644 csu/crt[1in].o ${STAGING_DIR_TARGET}${libdir} |
51 | ${CC} -nostdlib -nostartfiles -shared -x c /dev/null \ | 51 | ${CC} -nostdlib -nostartfiles -shared -x c /dev/null \ |
52 | -o ${STAGING_DIR_TARGET}${layout_libdir}/libc.so | 52 | -o ${STAGING_DIR_TARGET}${libdir}/libc.so |
53 | } | 53 | } |
54 | 54 | ||
55 | do_install () { | 55 | do_install () { |
diff --git a/meta/packages/glibc/glibc_2.4.bb b/meta/packages/glibc/glibc_2.4.bb index 6a5e9f37d7..3f184a6b13 100644 --- a/meta/packages/glibc/glibc_2.4.bb +++ b/meta/packages/glibc/glibc_2.4.bb | |||
@@ -4,7 +4,7 @@ PR = "r13" | |||
4 | 4 | ||
5 | # the -isystem in bitbake.conf screws up glibc do_stage | 5 | # the -isystem in bitbake.conf screws up glibc do_stage |
6 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" | 6 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" |
7 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}" | 7 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}" |
8 | 8 | ||
9 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4" | 9 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4" |
10 | 10 | ||
diff --git a/meta/packages/glibc/glibc_2.5.bb b/meta/packages/glibc/glibc_2.5.bb index 0cab17f128..5f95280584 100644 --- a/meta/packages/glibc/glibc_2.5.bb +++ b/meta/packages/glibc/glibc_2.5.bb | |||
@@ -4,7 +4,7 @@ PR = "r8" | |||
4 | 4 | ||
5 | # the -isystem in bitbake.conf screws up glibc do_stage | 5 | # the -isystem in bitbake.conf screws up glibc do_stage |
6 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" | 6 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" |
7 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}" | 7 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}" |
8 | 8 | ||
9 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4" | 9 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4" |
10 | 10 | ||
diff --git a/meta/packages/glibc/glibc_2.6.1.bb b/meta/packages/glibc/glibc_2.6.1.bb index f98864276e..3d39e0f748 100644 --- a/meta/packages/glibc/glibc_2.6.1.bb +++ b/meta/packages/glibc/glibc_2.6.1.bb | |||
@@ -1,4 +1,3 @@ | |||
1 | require glibc.inc | ||
2 | PR = "r6" | 1 | PR = "r6" |
3 | 2 | ||
4 | ARM_INSTRUCTION_SET = "arm" | 3 | ARM_INSTRUCTION_SET = "arm" |
@@ -8,7 +7,7 @@ RPROVIDES_${PN}-dev = "libc6-dev" | |||
8 | 7 | ||
9 | # the -isystem in bitbake.conf screws up glibc do_stage | 8 | # the -isystem in bitbake.conf screws up glibc do_stage |
10 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" | 9 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" |
11 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}" | 10 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}" |
12 | 11 | ||
13 | 12 | ||
14 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4" | 13 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4" |
diff --git a/meta/packages/glibc/glibc_2.9.bb b/meta/packages/glibc/glibc_2.9.bb index 24b07163e1..ea178366ac 100644 --- a/meta/packages/glibc/glibc_2.9.bb +++ b/meta/packages/glibc/glibc_2.9.bb | |||
@@ -9,7 +9,7 @@ PR = "r1" | |||
9 | 9 | ||
10 | # the -isystem in bitbake.conf screws up glibc do_stage | 10 | # the -isystem in bitbake.conf screws up glibc do_stage |
11 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" | 11 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" |
12 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}" | 12 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}" |
13 | 13 | ||
14 | GLIBC_ADDONS ?= "ports,nptl,libidn" | 14 | GLIBC_ADDONS ?= "ports,nptl,libidn" |
15 | 15 | ||
diff --git a/meta/packages/glibc/glibc_csl-2005q3-2.bb b/meta/packages/glibc/glibc_csl-2005q3-2.bb index c82121f027..d2aa11605b 100644 --- a/meta/packages/glibc/glibc_csl-2005q3-2.bb +++ b/meta/packages/glibc/glibc_csl-2005q3-2.bb | |||
@@ -6,7 +6,7 @@ PR = "r11" | |||
6 | 6 | ||
7 | # the -isystem in bitbake.conf screws up glibc do_stage | 7 | # the -isystem in bitbake.conf screws up glibc do_stage |
8 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" | 8 | BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}" |
9 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}" | 9 | TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}" |
10 | 10 | ||
11 | GLIBC_ADDONS ?= "nptl,libidn" | 11 | GLIBC_ADDONS ?= "nptl,libidn" |
12 | 12 | ||