diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-28 17:48:27 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-28 17:48:27 +0000 |
commit | 5599ea7fb19258cc7695c9a38219c75338578759 (patch) | |
tree | 721b5eed1be9e3f6520f90e00875730c8410e6d2 /meta/packages/glibc | |
parent | c5b80f33c555d4fd0576f31bafad022ceba508ae (diff) | |
download | poky-5599ea7fb19258cc7695c9a38219c75338578759.tar.gz |
glibc: Limit the locales that are generated under qemu. Note this patch totally trashes the other locales and would therefore need refinement for OE.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@583 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/glibc')
-rw-r--r-- | meta/packages/glibc/glibc-package.bbclass | 7 | ||||
-rw-r--r-- | meta/packages/glibc/glibc.inc | 17 | ||||
-rw-r--r-- | meta/packages/glibc/glibc_2.3.5+cvs20050627.bb | 3 |
3 files changed, 27 insertions, 0 deletions
diff --git a/meta/packages/glibc/glibc-package.bbclass b/meta/packages/glibc/glibc-package.bbclass index d6decfb709..680831e822 100644 --- a/meta/packages/glibc/glibc-package.bbclass +++ b/meta/packages/glibc/glibc-package.bbclass | |||
@@ -77,6 +77,13 @@ do_install() { | |||
77 | grep -v $i ${WORKDIR}/SUPPORTED > ${WORKDIR}/SUPPORTED.tmp | 77 | grep -v $i ${WORKDIR}/SUPPORTED > ${WORKDIR}/SUPPORTED.tmp |
78 | mv ${WORKDIR}/SUPPORTED.tmp ${WORKDIR}/SUPPORTED | 78 | mv ${WORKDIR}/SUPPORTED.tmp ${WORKDIR}/SUPPORTED |
79 | done | 79 | done |
80 | # If indicated, only build a limited selection of locales | ||
81 | if [ "${LIMIT_BUILT_LOCALES}" != "${LIMIT_BUILT_LOCALES}" ]; then | ||
82 | for i in ${LIMIT_BUILT_LOCALES}; do | ||
83 | grep $i ${WORKDIR}/SUPPORTED > ${WORKDIR}/SUPPORTED.tmp | ||
84 | mv ${WORKDIR}/SUPPORTED.tmp ${WORKDIR}/SUPPORTED | ||
85 | done | ||
86 | fi | ||
80 | rm -f ${D}/etc/rpc | 87 | rm -f ${D}/etc/rpc |
81 | } | 88 | } |
82 | 89 | ||
diff --git a/meta/packages/glibc/glibc.inc b/meta/packages/glibc/glibc.inc new file mode 100644 index 0000000000..4459f76a87 --- /dev/null +++ b/meta/packages/glibc/glibc.inc | |||
@@ -0,0 +1,17 @@ | |||
1 | |||
2 | do_rig_locales() { | ||
3 | # If indicated, only build a limited selection of locales | ||
4 | if [ "x${LIMIT_BUILT_LOCALES}" != "${LIMIT_BUILT_LOCALES}" ]; then | ||
5 | INFILE="${S}/localedata/SUPPORTED" | ||
6 | OUTFILE="${S}/localedata/SUPPORTED.tmp" | ||
7 | head -n 3 $INFILE > $OUTFILE | ||
8 | for i in ${LIMIT_BUILT_LOCALES}; do | ||
9 | echo | ||
10 | grep $i $INFILE >> $OUTFILE | ||
11 | done | ||
12 | head --lines=-1 $OUTFILE > $INFILE | ||
13 | tail --lines=1 $OUTFILE | sed 's#\\##' >> $INFILE | ||
14 | fi | ||
15 | } | ||
16 | |||
17 | addtask rig_locales before do_compile after do_configure | ||
diff --git a/meta/packages/glibc/glibc_2.3.5+cvs20050627.bb b/meta/packages/glibc/glibc_2.3.5+cvs20050627.bb index c8f1d56841..b6af34efdd 100644 --- a/meta/packages/glibc/glibc_2.3.5+cvs20050627.bb +++ b/meta/packages/glibc/glibc_2.3.5+cvs20050627.bb | |||
@@ -14,6 +14,8 @@ GLIBC_EXTRA_OECONF ?= "" | |||
14 | 14 | ||
15 | GLIBC_BROKEN_LOCALES = "sid_ET tr_TR mn_MN" | 15 | GLIBC_BROKEN_LOCALES = "sid_ET tr_TR mn_MN" |
16 | 16 | ||
17 | LIMIT_BUILT_LOCALES = "en_GB" | ||
18 | |||
17 | # | 19 | # |
18 | # For now, we will skip building of a gcc package if it is a uclibc one | 20 | # For now, we will skip building of a gcc package if it is a uclibc one |
19 | # and our build is not a uclibc one, and we skip a glibc one if our build | 21 | # and our build is not a uclibc one, and we skip a glibc one if our build |
@@ -173,3 +175,4 @@ do_stage() { | |||
173 | } | 175 | } |
174 | 176 | ||
175 | include glibc-package.bbclass | 177 | include glibc-package.bbclass |
178 | include glibc.inc | ||