summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-09-19 13:02:25 +0000
committerRichard Purdie <richard@openedhand.com>2007-09-19 13:02:25 +0000
commite32f910a5be9614f50e860fbd78ea1627555e038 (patch)
treee04fcba0d41835179024ff264428e1b7c2e91607 /meta/packages/glibc
parent405a6a68a644bdbdf303bca95d24e668efcfd2e5 (diff)
downloadpoky-e32f910a5be9614f50e860fbd78ea1627555e038.tar.gz
glibc-initial: Install headers into staging, not cross
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2764 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/glibc')
-rw-r--r--meta/packages/glibc/glibc-initial_2.4.bb8
-rw-r--r--meta/packages/glibc/glibc-initial_2.5.bb8
-rw-r--r--meta/packages/glibc/glibc-initial_csl-2005q3-2.bb8
3 files changed, 12 insertions, 12 deletions
diff --git a/meta/packages/glibc/glibc-initial_2.4.bb b/meta/packages/glibc/glibc-initial_2.4.bb
index ff458d3285..861478f7d5 100644
--- a/meta/packages/glibc/glibc-initial_2.4.bb
+++ b/meta/packages/glibc/glibc-initial_2.4.bb
@@ -32,14 +32,14 @@ do_compile () {
32} 32}
33 33
34do_stage () { 34do_stage () {
35 oe_runmake cross-compiling=yes install_root=${CROSS_DIR}/${TARGET_SYS} prefix="" install-headers 35 oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers
36 36
37 # Two headers -- stubs.h and features.h -- aren't installed by install-headers, 37 # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
38 # so do them by hand. We can tolerate an empty stubs.h for the moment. 38 # so do them by hand. We can tolerate an empty stubs.h for the moment.
39 # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html 39 # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
40 mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/gnu 40 mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu
41 touch ${CROSS_DIR}/${TARGET_SYS}/include/gnu/stubs.h 41 touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h
42 cp ${S}/include/features.h ${CROSS_DIR}/${TARGET_SYS}/include/features.h 42 cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h
43} 43}
44 44
45do_install () { 45do_install () {
diff --git a/meta/packages/glibc/glibc-initial_2.5.bb b/meta/packages/glibc/glibc-initial_2.5.bb
index fb05c9e029..0323debbdd 100644
--- a/meta/packages/glibc/glibc-initial_2.5.bb
+++ b/meta/packages/glibc/glibc-initial_2.5.bb
@@ -31,14 +31,14 @@ do_compile () {
31} 31}
32 32
33do_stage () { 33do_stage () {
34 oe_runmake cross-compiling=yes install_root=${CROSS_DIR}/${TARGET_SYS} prefix="" install-headers 34 oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers
35 35
36 # Two headers -- stubs.h and features.h -- aren't installed by install-headers, 36 # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
37 # so do them by hand. We can tolerate an empty stubs.h for the moment. 37 # so do them by hand. We can tolerate an empty stubs.h for the moment.
38 # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html 38 # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
39 mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/gnu 39 mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu
40 touch ${CROSS_DIR}/${TARGET_SYS}/include/gnu/stubs.h 40 touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h
41 cp ${S}/include/features.h ${CROSS_DIR}/${TARGET_SYS}/include/features.h 41 cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h
42} 42}
43 43
44do_install () { 44do_install () {
diff --git a/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb b/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb
index ff458d3285..6fe67083ec 100644
--- a/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb
+++ b/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb
@@ -32,14 +32,14 @@ do_compile () {
32} 32}
33 33
34do_stage () { 34do_stage () {
35 oe_runmake cross-compiling=yes install_root=${CROSS_DIR}/${TARGET_SYS} prefix="" install-headers 35 oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers
36 36
37 # Two headers -- stubs.h and features.h -- aren't installed by install-headers, 37 # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
38 # so do them by hand. We can tolerate an empty stubs.h for the moment. 38 # so do them by hand. We can tolerate an empty stubs.h for the moment.
39 # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html 39 # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
40 mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/gnu 40 mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu
41 touch ${CROSS_DIR}/${TARGET_SYS}/include/gnu/stubs.h 41 touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h
42 cp ${S}/include/features.h ${CROSS_DIR}/${TARGET_SYS}/include/features.h 42 cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h
43} 43}
44 44
45do_install () { 45do_install () {