summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc
diff options
context:
space:
mode:
authorRobert Bragg <bob@openedhand.com>2008-06-07 01:07:18 +0000
committerRobert Bragg <bob@openedhand.com>2008-06-07 01:07:18 +0000
commit3dbb2c002e38ef34918c2fc7114aa903f8fe9ec5 (patch)
tree7281131edef59e5bdbe6c7281751eaa51d7d37f5 /meta/packages/glibc
parentdd5ed4b3ada9581b72f493b5d3e9b774d9b4e7bc (diff)
downloadpoky-3dbb2c002e38ef34918c2fc7114aa903f8fe9ec5.tar.gz
Newer versions of gcc have multiple internal header directories and when
glibc builds using -nostdinc, it must also add all these internal directories via -system. This adds a patch to make sure the toolchain's "include-fixed" directory gets included in glibc_2.5 builds (if it exists) git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4612 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/glibc')
-rw-r--r--meta/packages/glibc/glibc-2.4/glibc-include-fixed.patch54
-rw-r--r--meta/packages/glibc/glibc_2.5.bb3
2 files changed, 56 insertions, 1 deletions
diff --git a/meta/packages/glibc/glibc-2.4/glibc-include-fixed.patch b/meta/packages/glibc/glibc-2.4/glibc-include-fixed.patch
new file mode 100644
index 0000000000..a8e87609f2
--- /dev/null
+++ b/meta/packages/glibc/glibc-2.4/glibc-include-fixed.patch
@@ -0,0 +1,54 @@
1With the -nostdinc that we get --with-headers, we need to pull in GCC
24.3's include-fixed subdir too, because that's what contains limits.h
3and syslimits.h now.
4
5
6for ChangeLog
72008-01-30 Alexandre Oliva <aoliva@redhat.com>
8
9 * configure.in (SYSINCLUDES): Add GCC's include-fixed after include.
10 * configure: Rebuilt.
11
12Index: configure
13===================================================================
14--- configure.orig 2008-01-30 15:40:55.000000000 -0200
15+++ configure 2008-01-31 03:24:36.000000000 -0200
16@@ -5066,7 +5066,12 @@ echo "$as_me: WARNING:
17 # thing on a system that doesn't need fixincludes. (Not presently a problem.)
18 if test -n "$sysheaders"; then
19 ccheaders=`$CC -print-file-name=include`
20- SYSINCLUDES="-nostdinc -isystem $ccheaders \
21+ if test -d "${ccheaders}-fixed"; then
22+ fixedccheaders="-isystem ${ccheaders}-fixed"
23+ else
24+ fixedccheaders=
25+ fi
26+ SYSINCLUDES="-nostdinc -isystem $ccheaders $fixedccheaders \
27 -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
28 if test -n "$CXX"; then
29 cxxversion=`$CXX -dumpversion 2>&5` &&
30Index: configure.in
31===================================================================
32--- configure.in.orig 2008-01-30 15:40:55.000000000 -0200
33+++ configure.in 2008-01-31 03:24:30.000000000 -0200
34@@ -915,7 +915,12 @@ test -n "$aux_missing" && AC_MSG_WARN([
35 # thing on a system that doesn't need fixincludes. (Not presently a problem.)
36 if test -n "$sysheaders"; then
37 ccheaders=`$CC -print-file-name=include`
38- SYSINCLUDES="-nostdinc -isystem $ccheaders \
39+ if test -d "${ccheaders}-fixed"; then
40+ fixedccheaders="-isystem ${ccheaders}-fixed"
41+ else
42+ fixedccheaders=
43+ fi
44+ SYSINCLUDES="-nostdinc -isystem $ccheaders $fixedccheaders \
45 -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
46 if test -n "$CXX"; then
47 cxxversion=`$CXX -dumpversion 2>&AS_MESSAGE_LOG_FD` &&
48
49--
50Alexandre Oliva http://www.lsd.ic.unicamp.br/~oliva/
51FSF Latin America Board Member http://www.fsfla.org/
52Red Hat Compiler Engineer aoliva@{redhat.com, gcc.gnu.org}
53Free Software Evangelist oliva@{lsd.ic.unicamp.br, gnu.org}
54
diff --git a/meta/packages/glibc/glibc_2.5.bb b/meta/packages/glibc/glibc_2.5.bb
index cfb1974b2d..8a46d2fb85 100644
--- a/meta/packages/glibc/glibc_2.5.bb
+++ b/meta/packages/glibc/glibc_2.5.bb
@@ -54,7 +54,8 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \
54 file://generic-bits_time.h \ 54 file://generic-bits_time.h \
55 file://etc/ld.so.conf \ 55 file://etc/ld.so.conf \
56 file://generate-supported.mk \ 56 file://generate-supported.mk \
57 file://glibc-arm-no-procinfo_h.patch;patch=1" 57 file://glibc-arm-no-procinfo_h.patch;patch=1 \
58 file://glibc-include-fixed.patch;patch=1;pnum=0"
58 59
59 60
60# Build fails on sh3 and sh4 without additional patches 61# Build fails on sh3 and sh4 without additional patches