diff options
author | Richard Purdie <richard@openedhand.com> | 2007-10-21 19:12:24 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2007-10-21 19:12:24 +0000 |
commit | c6c94fab5ef5fe3db448bfc8e1e1e56d628d14ec (patch) | |
tree | 0c0c3eb7701af7e67a510660ca356aa0081b6695 /meta/packages/glibc | |
parent | 6e60bdc61280cc458a75c62266d2aa8570a02061 (diff) | |
download | poky-c6c94fab5ef5fe3db448bfc8e1e1e56d628d14ec.tar.gz |
glibc-initial: Factor code into common .inc file
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2941 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/glibc')
-rw-r--r-- | meta/packages/glibc/glibc-initial.inc | 45 | ||||
-rw-r--r-- | meta/packages/glibc/glibc-initial_2.4.bb | 46 | ||||
-rw-r--r-- | meta/packages/glibc/glibc-initial_2.5.bb | 45 | ||||
-rw-r--r-- | meta/packages/glibc/glibc-initial_csl-2005q3-2.bb | 46 |
4 files changed, 48 insertions, 134 deletions
diff --git a/meta/packages/glibc/glibc-initial.inc b/meta/packages/glibc/glibc-initial.inc new file mode 100644 index 0000000000..9355320b3a --- /dev/null +++ b/meta/packages/glibc/glibc-initial.inc | |||
@@ -0,0 +1,45 @@ | |||
1 | SECTION = "libs" | ||
2 | DEPENDS = "linux-libc-headers" | ||
3 | PROVIDES = "virtual/${TARGET_PREFIX}libc-initial" | ||
4 | FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}" | ||
5 | |||
6 | PACKAGES = "" | ||
7 | PACKAGES_DYNAMIC = "" | ||
8 | |||
9 | do_configure () { | ||
10 | sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure | ||
11 | chmod +x ${S}/configure | ||
12 | CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \ | ||
13 | --without-cvs --disable-sanity-checks \ | ||
14 | --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \ | ||
15 | --enable-hacker-mode | ||
16 | if grep -q GLIBC_2.3 ${S}/ChangeLog; then | ||
17 | # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler. | ||
18 | # Fortunately, we don't need errlist-compat.c, since we just need .h files, | ||
19 | # so work around this by creating a fake errlist-compat.c and satisfying its dependencies. | ||
20 | # Another workaround might be to tell configure to not use any cross options to $(CC). | ||
21 | # The real fix would be to get install-headers to not generate errlist-compat.c. | ||
22 | make sysdeps/gnu/errlist.c | ||
23 | mkdir -p stdio-common | ||
24 | touch stdio-common/errlist-compat.c | ||
25 | fi | ||
26 | } | ||
27 | |||
28 | do_compile () { | ||
29 | : | ||
30 | } | ||
31 | |||
32 | do_stage () { | ||
33 | oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers | ||
34 | |||
35 | # Two headers -- stubs.h and features.h -- aren't installed by install-headers, | ||
36 | # so do them by hand. We can tolerate an empty stubs.h for the moment. | ||
37 | # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html | ||
38 | mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu | ||
39 | touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h | ||
40 | cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h | ||
41 | } | ||
42 | |||
43 | do_install () { | ||
44 | : | ||
45 | } | ||
diff --git a/meta/packages/glibc/glibc-initial_2.4.bb b/meta/packages/glibc/glibc-initial_2.4.bb index 861478f7d5..d3dc4b587a 100644 --- a/meta/packages/glibc/glibc-initial_2.4.bb +++ b/meta/packages/glibc/glibc-initial_2.4.bb | |||
@@ -1,47 +1,3 @@ | |||
1 | SECTION = "libs" | ||
2 | require glibc_${PV}.bb | 1 | require glibc_${PV}.bb |
2 | require glibc-initial.inc | ||
3 | 3 | ||
4 | DEPENDS = "linux-libc-headers" | ||
5 | PROVIDES = "virtual/${TARGET_PREFIX}libc-initial" | ||
6 | FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}" | ||
7 | |||
8 | PACKAGES = "" | ||
9 | PACKAGES_DYNAMIC = "" | ||
10 | |||
11 | do_configure () { | ||
12 | sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure | ||
13 | chmod +x ${S}/configure | ||
14 | CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \ | ||
15 | --without-cvs --disable-sanity-checks \ | ||
16 | --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \ | ||
17 | --enable-hacker-mode | ||
18 | if grep -q GLIBC_2.3 ${S}/ChangeLog; then | ||
19 | # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler. | ||
20 | # Fortunately, we don't need errlist-compat.c, since we just need .h files, | ||
21 | # so work around this by creating a fake errlist-compat.c and satisfying its dependencies. | ||
22 | # Another workaround might be to tell configure to not use any cross options to $(CC). | ||
23 | # The real fix would be to get install-headers to not generate errlist-compat.c. | ||
24 | make sysdeps/gnu/errlist.c | ||
25 | mkdir -p stdio-common | ||
26 | touch stdio-common/errlist-compat.c | ||
27 | fi | ||
28 | } | ||
29 | |||
30 | do_compile () { | ||
31 | : | ||
32 | } | ||
33 | |||
34 | do_stage () { | ||
35 | oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers | ||
36 | |||
37 | # Two headers -- stubs.h and features.h -- aren't installed by install-headers, | ||
38 | # so do them by hand. We can tolerate an empty stubs.h for the moment. | ||
39 | # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html | ||
40 | mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu | ||
41 | touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h | ||
42 | cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h | ||
43 | } | ||
44 | |||
45 | do_install () { | ||
46 | : | ||
47 | } | ||
diff --git a/meta/packages/glibc/glibc-initial_2.5.bb b/meta/packages/glibc/glibc-initial_2.5.bb index 0323debbdd..d3dc4b587a 100644 --- a/meta/packages/glibc/glibc-initial_2.5.bb +++ b/meta/packages/glibc/glibc-initial_2.5.bb | |||
@@ -1,46 +1,3 @@ | |||
1 | require glibc_${PV}.bb | 1 | require glibc_${PV}.bb |
2 | require glibc-initial.inc | ||
2 | 3 | ||
3 | DEPENDS = "linux-libc-headers" | ||
4 | PROVIDES = "virtual/${TARGET_PREFIX}libc-initial" | ||
5 | FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}" | ||
6 | |||
7 | PACKAGES = "" | ||
8 | PACKAGES_DYNAMIC = "" | ||
9 | |||
10 | do_configure () { | ||
11 | sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure | ||
12 | chmod +x ${S}/configure | ||
13 | CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \ | ||
14 | --without-cvs --disable-sanity-checks \ | ||
15 | --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \ | ||
16 | --enable-hacker-mode | ||
17 | if grep -q GLIBC_2.3 ${S}/ChangeLog; then | ||
18 | # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler. | ||
19 | # Fortunately, we don't need errlist-compat.c, since we just need .h files, | ||
20 | # so work around this by creating a fake errlist-compat.c and satisfying its dependencies. | ||
21 | # Another workaround might be to tell configure to not use any cross options to $(CC). | ||
22 | # The real fix would be to get install-headers to not generate errlist-compat.c. | ||
23 | make sysdeps/gnu/errlist.c | ||
24 | mkdir -p stdio-common | ||
25 | touch stdio-common/errlist-compat.c | ||
26 | fi | ||
27 | } | ||
28 | |||
29 | do_compile () { | ||
30 | : | ||
31 | } | ||
32 | |||
33 | do_stage () { | ||
34 | oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers | ||
35 | |||
36 | # Two headers -- stubs.h and features.h -- aren't installed by install-headers, | ||
37 | # so do them by hand. We can tolerate an empty stubs.h for the moment. | ||
38 | # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html | ||
39 | mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu | ||
40 | touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h | ||
41 | cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h | ||
42 | } | ||
43 | |||
44 | do_install () { | ||
45 | : | ||
46 | } | ||
diff --git a/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb b/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb index 6fe67083ec..d3dc4b587a 100644 --- a/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb +++ b/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb | |||
@@ -1,47 +1,3 @@ | |||
1 | SECTION = "libs" | ||
2 | require glibc_${PV}.bb | 1 | require glibc_${PV}.bb |
2 | require glibc-initial.inc | ||
3 | 3 | ||
4 | DEPENDS = "linux-libc-headers" | ||
5 | PROVIDES = "virtual/${TARGET_PREFIX}libc-initial" | ||
6 | FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}" | ||
7 | |||
8 | PACKAGES = "" | ||
9 | PACKAGES_DYNAMIC = "" | ||
10 | |||
11 | do_configure () { | ||
12 | sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure | ||
13 | chmod +x ${S}/configure | ||
14 | CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \ | ||
15 | --without-cvs --disable-sanity-checks \ | ||
16 | --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \ | ||
17 | --enable-hacker-mode | ||
18 | if grep -q GLIBC_2.3 ${S}/ChangeLog; then | ||
19 | # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler. | ||
20 | # Fortunately, we don't need errlist-compat.c, since we just need .h files, | ||
21 | # so work around this by creating a fake errlist-compat.c and satisfying its dependencies. | ||
22 | # Another workaround might be to tell configure to not use any cross options to $(CC). | ||
23 | # The real fix would be to get install-headers to not generate errlist-compat.c. | ||
24 | make sysdeps/gnu/errlist.c | ||
25 | mkdir -p stdio-common | ||
26 | touch stdio-common/errlist-compat.c | ||
27 | fi | ||
28 | } | ||
29 | |||
30 | do_compile () { | ||
31 | : | ||
32 | } | ||
33 | |||
34 | do_stage () { | ||
35 | oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers | ||
36 | |||
37 | # Two headers -- stubs.h and features.h -- aren't installed by install-headers, | ||
38 | # so do them by hand. We can tolerate an empty stubs.h for the moment. | ||
39 | # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html | ||
40 | mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu | ||
41 | touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h | ||
42 | cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h | ||
43 | } | ||
44 | |||
45 | do_install () { | ||
46 | : | ||
47 | } | ||