summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc/glibc_2.4.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-08-19 16:18:28 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-20 16:07:43 +0100
commit735210556dc709b3c2367389fa6ea9c0109412b1 (patch)
treeb042ff7f78c7850460e6994d78b49a60be7db544 /meta/packages/glibc/glibc_2.4.bb
parent7e8f14d2d8c11d57ccd77974672bd959f8e95e35 (diff)
downloadpoky-735210556dc709b3c2367389fa6ea9c0109412b1.tar.gz
glibc: remove all old recipes
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/glibc/glibc_2.4.bb')
-rw-r--r--meta/packages/glibc/glibc_2.4.bb137
1 files changed, 0 insertions, 137 deletions
diff --git a/meta/packages/glibc/glibc_2.4.bb b/meta/packages/glibc/glibc_2.4.bb
deleted file mode 100644
index ad6840e9bf..0000000000
--- a/meta/packages/glibc/glibc_2.4.bb
+++ /dev/null
@@ -1,137 +0,0 @@
1require glibc.inc
2
3PR = "r14"
4
5# the -isystem in bitbake.conf screws up glibc do_stage
6BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
7TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
8
9FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-2.4"
10
11GLIBC_ADDONS ?= "ports,nptl,libidn"
12
13GLIBC_BROKEN_LOCALES = "sid_ET tr_TR mn_MN gez_ET bn_BD gez_ER te_IN"
14
15#
16# For now, we will skip building of a gcc package if it is a uclibc one
17# and our build is not a uclibc one, and we skip a glibc one if our build
18# is a uclibc build.
19#
20# See the note in gcc/gcc_3.4.0.oe
21#
22
23python __anonymous () {
24 import bb, re
25 uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
26 if uc_os:
27 raise bb.parse.SkipPackage("incompatible with target %s" %
28 bb.data.getVar('TARGET_OS', d, 1))
29}
30
31# file://noinfo.patch;patch=1
32# file://ldconfig.patch;patch=1;pnum=0
33# file://arm-machine-gmon.patch;patch=1;pnum=0 \
34# \
35# file://arm-ioperm.patch;patch=1;pnum=0 \
36# file://ldd.patch;patch=1;pnum=0 \
37SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-2.4.tar.bz2 \
38 ftp://ftp.gnu.org/pub/gnu/glibc/glibc-ports-2.4.tar.bz2 \
39 ftp://ftp.gnu.org/pub/gnu/glibc/glibc-libidn-2.4.tar.bz2 \
40 file://arm-memcpy.patch;patch=1 \
41 file://arm-longlong.patch;patch=1 \
42 file://fhs-linux-paths.patch;patch=1 \
43 file://dl-cache-libcmp.patch;patch=1 \
44 file://nptl-crosscompile.patch;patch=1 \
45 file://glibc-2.4-compile.patch;patch=1 \
46 file://fixup-aeabi-syscalls.patch;patch=1 \
47 file://zecke-sane-readelf.patch;patch=1 \
48 file://generic-bits_select.h \
49 file://generic-bits_types.h \
50 file://generic-bits_typesizes.h \
51 file://generic-bits_time.h \
52 file://etc/ld.so.conf \
53 file://generate-supported.mk"
54
55# Build fails on sh3 and sh4 without additional patches
56SRC_URI_append_sh3 = " file://no-z-defs.patch;patch=1"
57SRC_URI_append_sh4 = " file://no-z-defs.patch;patch=1"
58
59S = "${WORKDIR}/glibc-2.4"
60B = "${WORKDIR}/build-${TARGET_SYS}"
61
62EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
63 --without-cvs --disable-profile --disable-debug --without-gd \
64 --enable-clocale=gnu \
65 --enable-add-ons=${GLIBC_ADDONS} \
66 --with-headers=${STAGING_INCDIR} \
67 --without-selinux \
68 ${GLIBC_EXTRA_OECONF}"
69
70EXTRA_OECONF += "${@get_glibc_fpu_setting(bb, d)}"
71
72do_munge() {
73 # Integrate ports and libidn into tree
74 mv ${WORKDIR}/glibc-ports-${PV} ${S}/ports
75 mv ${WORKDIR}/glibc-libidn-${PV} ${S}/libidn
76
77 # Ports isn't really working... Fix it
78 # Some of this is rather dirty, but it seems to be the only
79 # quick way to get this cruft to compile
80 rm -rf ${S}/ports/sysdeps/unix/sysv/linux/arm/linuxthreads
81 ln -s nptl ${S}/ports/sysdeps/unix/sysv/linux/arm/linuxthreads
82 cp ${S}/sysdeps/unix/sysv/linux/i386/bits/wchar.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/
83 cp ${S}/sysdeps/wordsize-32/bits/wordsize.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/
84 cp ${WORKDIR}/generic-bits_select.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/select.h
85 cp ${WORKDIR}/generic-bits_types.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/types.h
86 cp ${WORKDIR}/generic-bits_typesizes.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/typesizes.h
87 cp ${WORKDIR}/generic-bits_time.h ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/time.h
88 # Copy in generic stuff for not yet implemented headers
89 for i in ${S}/bits/*.h; do
90 F=`basename $i`
91 [ "$F" = "local_lim.h" ] && continue
92 [ "$F" = "errno.h" ] && continue
93 test -e ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/$F || test -e ${S}/ports/sysdeps/arm/bits/$F || test -e ${S}/sysdeps/unix/sysv/linux/bits/$F || test -e ${S}/sysdeps/ieee754/bits/$F || cp $i ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/
94 done
95 # This is harmful; we need to get the one from nptl/sysdeps/pthreads
96 rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/libc-lock.h
97 # Obsoleted by sysdeps/arm/{fpu,eabi}/bits/fenv.h
98 rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/fenv.h
99 # Obsoleted by sysdeps/gnu/bits/utmp.h
100 rm -f ${S}/ports/sysdeps/unix/sysv/linux/arm/bits/utmp.h
101}
102
103addtask munge before do_patch after do_unpack
104
105do_configure () {
106# override this function to avoid the autoconf/automake/aclocal/autoheader
107# calls for now
108# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
109# version check and doesn't really help with anything
110 if [ -z "`which rpcgen`" ]; then
111 echo "rpcgen not found. Install glibc-devel."
112 exit 1
113 fi
114 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
115 CPPFLAGS="" oe_runconf
116}
117
118rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
119 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
120 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
121
122do_compile () {
123 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
124 unset LDFLAGS
125 base_do_compile
126 (
127 cd ${S}/sunrpc/rpcsvc
128 for r in ${rpcsvc}; do
129 h=`echo $r|sed -e's,\.x$,.h,'`
130 rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
131 done
132 )
133}
134
135require glibc-stage.inc
136
137require glibc-package.inc