diff options
author | Tomas Frydrych <tf@openedhand.com> | 2006-09-18 15:23:13 +0000 |
---|---|---|
committer | Tomas Frydrych <tf@openedhand.com> | 2006-09-18 15:23:13 +0000 |
commit | 02059b7a72b03de846f78ab9a2c24d660b29d59e (patch) | |
tree | 5b059c6d2a705c596e72604c572d866aa4afee2b /meta/packages/glibc/glibc-initial_csl-2005q3-2.bb | |
parent | de35d836b450951eddb505acb4b60de18d368df1 (diff) | |
download | poky-02059b7a72b03de846f78ab9a2c24d660b29d59e.tar.gz |
files for using csl2005q3-2 toolchain
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@723 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/glibc/glibc-initial_csl-2005q3-2.bb')
-rw-r--r-- | meta/packages/glibc/glibc-initial_csl-2005q3-2.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb b/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb new file mode 100644 index 0000000000..9ba2ac37cc --- /dev/null +++ b/meta/packages/glibc/glibc-initial_csl-2005q3-2.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | SECTION = "libs" | ||
2 | require glibc_${PV}.bb | ||
3 | |||
4 | DEPENDS = "linux-libc-headers" | ||
5 | PROVIDES = "virtual/${TARGET_PREFIX}libc-initial" | ||
6 | FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}" | ||
7 | |||
8 | PACKAGES = "" | ||
9 | |||
10 | do_configure () { | ||
11 | sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure | ||
12 | chmod +x ${S}/configure | ||
13 | CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \ | ||
14 | --without-cvs --disable-sanity-checks \ | ||
15 | --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \ | ||
16 | --enable-hacker-mode | ||
17 | if grep -q GLIBC_2.3 ${S}/ChangeLog; then | ||
18 | # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler. | ||
19 | # Fortunately, we don't need errlist-compat.c, since we just need .h files, | ||
20 | # so work around this by creating a fake errlist-compat.c and satisfying its dependencies. | ||
21 | # Another workaround might be to tell configure to not use any cross options to $(CC). | ||
22 | # The real fix would be to get install-headers to not generate errlist-compat.c. | ||
23 | make sysdeps/gnu/errlist.c | ||
24 | mkdir -p stdio-common | ||
25 | touch stdio-common/errlist-compat.c | ||
26 | fi | ||
27 | } | ||
28 | |||
29 | do_compile () { | ||
30 | : | ||
31 | } | ||
32 | |||
33 | do_stage () { | ||
34 | oe_runmake cross-compiling=yes install_root=${CROSS_DIR}/${TARGET_SYS} prefix="" install-headers | ||
35 | |||
36 | # Two headers -- stubs.h and features.h -- aren't installed by install-headers, | ||
37 | # so do them by hand. We can tolerate an empty stubs.h for the moment. | ||
38 | # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html | ||
39 | mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/gnu | ||
40 | touch ${CROSS_DIR}/${TARGET_SYS}/include/gnu/stubs.h | ||
41 | cp ${S}/include/features.h ${CROSS_DIR}/${TARGET_SYS}/include/features.h | ||
42 | } | ||
43 | |||
44 | do_install () { | ||
45 | : | ||
46 | } | ||