summaryrefslogtreecommitdiffstats
path: root/meta/packages/glibc/files
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/glibc/files
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/glibc/files')
-rw-r--r--meta/packages/glibc/files/5090_all_stubs-rule-fix.patch39
-rw-r--r--meta/packages/glibc/files/etc/ld.so.conf3
-rw-r--r--meta/packages/glibc/files/fhs-linux-paths.patch11
-rw-r--r--meta/packages/glibc/files/generate-supported.mk11
4 files changed, 64 insertions, 0 deletions
diff --git a/meta/packages/glibc/files/5090_all_stubs-rule-fix.patch b/meta/packages/glibc/files/5090_all_stubs-rule-fix.patch
new file mode 100644
index 0000000000..c445a5296e
--- /dev/null
+++ b/meta/packages/glibc/files/5090_all_stubs-rule-fix.patch
@@ -0,0 +1,39 @@
1Index: Makerules
2===================================================================
3RCS file: /cvs/glibc/libc/Makerules,v
4retrieving revision 1.430
5diff -u -r1.430 Makerules
6--- libc/Makerules 5 Mar 2005 19:24:32 -0000 1.430
7+++ libc/Makerules 22 Apr 2005 18:31:27 -0000
8@@ -1390,15 +1390,26 @@
9 $(addprefix $(objpfx),$(extra-objs))
10 $(objpfx)stubs: $(objs-for-stubs)
11 ifneq (,$(strip $(objs-for-stubs)))
12- $(OBJDUMP) -h $^ | \
13- $(AWK) '/\.gnu\.glibc-stub\./ { \
14- sub(/\.gnu\.glibc-stub\./, "", $$2); \
15- stubs[$$2] = 1; } \
16- END { for (s in stubs) print "#define __stub_" s }' > $@T
17+ $(stub-obj-list)
18+ cat $@L | xargs \
19+ $(OBJDUMP) -h | \
20+ $(AWK) '/\.gnu\.glibc-stub\./ { \
21+ sub(/\.gnu\.glibc-stub\./, "", $$2); \
22+ stubs[$$2] = 1; } \
23+ END { for (s in stubs) print "#define __stub_" s }' \
24+ > $@T
25+ -rm -f $@L
26 mv -f $@T $@
27 else
28 > $@
29 endif
30+
31+define stub-obj-list
32+-@rm -f $@L
33+-@echo "Generating stub obj list..."
34+$(foreach file,$^,
35+@echo >> $@L '$(file)')
36+endef
37
38 # This information is not used for making distributions any more.
39 # But it's used by MakeTAGS for making TAGS files and the .pot files.
diff --git a/meta/packages/glibc/files/etc/ld.so.conf b/meta/packages/glibc/files/etc/ld.so.conf
new file mode 100644
index 0000000000..fb1aab516d
--- /dev/null
+++ b/meta/packages/glibc/files/etc/ld.so.conf
@@ -0,0 +1,3 @@
1/usr/local/lib
2/opt/QtPalmtop/lib
3/usr/X11R6/lib
diff --git a/meta/packages/glibc/files/fhs-linux-paths.patch b/meta/packages/glibc/files/fhs-linux-paths.patch
new file mode 100644
index 0000000000..1f32f6d7f2
--- /dev/null
+++ b/meta/packages/glibc/files/fhs-linux-paths.patch
@@ -0,0 +1,11 @@
1--- glibc-2.1.1/sysdeps/unix/sysv/linux/paths.h~ Thu May 27 13:16:33 1999
2+++ glibc-2.1.1/sysdeps/unix/sysv/linux/paths.h Thu May 27 13:17:55 1999
3@@ -71,7 +71,7 @@
4 /* Provide trailing slash, since mostly used for building pathnames. */
5 #define _PATH_DEV "/dev/"
6 #define _PATH_TMP "/tmp/"
7-#define _PATH_VARDB "/var/db/"
8+#define _PATH_VARDB "/var/lib/misc/"
9 #define _PATH_VARRUN "/var/run/"
10 #define _PATH_VARTMP "/var/tmp/"
11
diff --git a/meta/packages/glibc/files/generate-supported.mk b/meta/packages/glibc/files/generate-supported.mk
new file mode 100644
index 0000000000..d2a28c2dc6
--- /dev/null
+++ b/meta/packages/glibc/files/generate-supported.mk
@@ -0,0 +1,11 @@
1#!/usr/bin/make
2
3include $(IN)
4
5all:
6 rm -f $(OUT)
7 touch $(OUT)
8 for locale in $(SUPPORTED-LOCALES); do \
9 [ $$locale = true ] && continue; \
10 echo $$locale | sed 's,/, ,' >> $(OUT); \
11 done