diff options
author | Ross Burton <ross@openedhand.com> | 2007-08-01 18:56:03 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2007-08-01 18:56:03 +0000 |
commit | 5c53fff8cc6a533e661b5228208cce2f8650f2de (patch) | |
tree | c0176ecc34f91d87e96b7d93e7dd17df07a144ae /meta/packages/glib-2.0 | |
parent | f90f6b05791657c2dca5f0be5c7728b37254d88f (diff) | |
download | poky-5c53fff8cc6a533e661b5228208cce2f8650f2de.tar.gz |
Add patch from svn to fix c++ builds
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2299 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/glib-2.0')
-rw-r--r-- | meta/packages/glib-2.0/glib-2.0-2.13.7/casts.patch | 40 | ||||
-rw-r--r-- | meta/packages/glib-2.0/glib-2.0_2.13.7.bb | 6 |
2 files changed, 44 insertions, 2 deletions
diff --git a/meta/packages/glib-2.0/glib-2.0-2.13.7/casts.patch b/meta/packages/glib-2.0/glib-2.0-2.13.7/casts.patch new file mode 100644 index 0000000000..d48072e202 --- /dev/null +++ b/meta/packages/glib-2.0/glib-2.0-2.13.7/casts.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | Index: glib/gthread.c | ||
2 | =================================================================== | ||
3 | --- glib/gthread.c (revision 5636) | ||
4 | +++ glib/gthread.c (revision 5639) | ||
5 | @@ -223,11 +223,11 @@ | ||
6 | g_once_init_leave (volatile gsize *value_location, | ||
7 | gsize initialization_value) | ||
8 | { | ||
9 | - g_return_if_fail (g_atomic_pointer_get (value_location) == 0); | ||
10 | + g_return_if_fail (g_atomic_pointer_get ((void**) value_location) == 0); | ||
11 | g_return_if_fail (initialization_value != 0); | ||
12 | g_return_if_fail (g_once_init_list != NULL); | ||
13 | |||
14 | - g_atomic_pointer_set (value_location, initialization_value); | ||
15 | + g_atomic_pointer_set ((void**) value_location, (void*) initialization_value); | ||
16 | g_mutex_lock (g_once_mutex); | ||
17 | g_once_init_list = g_slist_remove (g_once_init_list, (void*) value_location); | ||
18 | g_cond_broadcast (g_once_cond); | ||
19 | @@ -255,7 +255,7 @@ | ||
20 | g_mutex_lock (g_once_mutex); | ||
21 | |||
22 | if (!(*mutex)) | ||
23 | - g_atomic_pointer_set (mutex, g_mutex_new()); | ||
24 | + g_atomic_pointer_set ((void**) mutex, g_mutex_new()); | ||
25 | |||
26 | g_mutex_unlock (g_once_mutex); | ||
27 | |||
28 | Index: glib/gthread.h | ||
29 | =================================================================== | ||
30 | --- glib/gthread.h (revision 5636) | ||
31 | +++ glib/gthread.h (revision 5639) | ||
32 | @@ -332,7 +332,7 @@ | ||
33 | G_INLINE_FUNC gboolean | ||
34 | g_once_init_enter (volatile gsize *value_location) | ||
35 | { | ||
36 | - if G_LIKELY (g_atomic_pointer_get (value_location) !=0) | ||
37 | + if G_LIKELY (g_atomic_pointer_get ((void**) value_location) !=0) | ||
38 | return FALSE; | ||
39 | else | ||
40 | return g_once_init_enter_impl (value_location); | ||
diff --git a/meta/packages/glib-2.0/glib-2.0_2.13.7.bb b/meta/packages/glib-2.0/glib-2.0_2.13.7.bb index be296be20c..7542ed2e14 100644 --- a/meta/packages/glib-2.0/glib-2.0_2.13.7.bb +++ b/meta/packages/glib-2.0/glib-2.0_2.13.7.bb | |||
@@ -1,6 +1,8 @@ | |||
1 | require glib.inc | 1 | require glib.inc |
2 | 2 | ||
3 | PR = "r1" | ||
4 | |||
3 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/glib/2.13/glib-${PV}.tar.bz2 \ | 5 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/glib/2.13/glib-${PV}.tar.bz2 \ |
4 | file://glibconfig-sysdefs.h \ | 6 | file://glibconfig-sysdefs.h \ |
5 | file://configure-libtool.patch;patch=1" | 7 | file://configure-libtool.patch;patch=1 \ |
6 | 8 | file://casts.patch;patch=1;pnum=0" | |