summaryrefslogtreecommitdiffstats
path: root/meta/packages/glib-2.0/glib-2.0-2.24.1
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-06-25 15:07:01 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-07-02 15:32:28 -0700
commit31180a56d1b6981fa9d5588ad3538f34e339e0fe (patch)
tree2e4bb97f22d2d02357f316c8a628dea6af1059ff /meta/packages/glib-2.0/glib-2.0-2.24.1
parent6b81c6dbb55d57a0f8d96ee5e3f5d1e6148850b1 (diff)
downloadpoky-31180a56d1b6981fa9d5588ad3538f34e339e0fe.tar.gz
glib-2.0: upgrade to 2.24.1
(borrow from OE 2.24.0, with study about reason for detail changes) [Patches-Poky] KEEP _configure-libtool.patch_: fix cross-build env REMOVE _glibconfig-sysdefs.h_: introduced in glib-1.2.10, which is actually not valid today KEEP _glib-gettexize-dir.patch_: another quite old patch added before 2.10.3 add history info, and mark for upstream [Patches-OE] NOTAKE _gio.patch_: a private extension for a window matching library (wncksync) NOTAKE _gvavriant.patch_: in 2.24.1 now NOTAKE _gasync.patch_: in 2.24.1 now TAKE _60_wait-longer-for-threads-to-die.patch: said to fix anonying warning TAKE _gatomic-proper-get-cast.patch_: fix error about type casting. Instead of using OE's patch, I found a better one from latest repo NOTAKE _g_once_init_enter.patch_: in OE since 2.22.1, not quite sure of its purpose, also it's not in upstream yet [Recipe] - fix metadata - keep glib-2.inc which is for python optimization - remove PRIORITY since 'optional' is the default - no need to specially install glibconfig.h in ad hoc path, which is only relied by 'obexpush' which poky doesn't have and can be fixed in 'obexpush' itself as what OE does - no need to manually create glib2.0/glib, which is handled by current code - remove 'acpaths' which only applies to versions before 2.12.4 - below lines are not taken from OE * glib-mkenums tweaks, which exists in OE for a long time but never in poky. since there's no way to find out original commit, keep poky's style instead. * host libtool check. not sure about its purpose, and it's also in OE for quite long time Signed-off-by Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta/packages/glib-2.0/glib-2.0-2.24.1')
-rw-r--r--meta/packages/glib-2.0/glib-2.0-2.24.1/60_wait-longer-for-threads-to-die.patch29
-rw-r--r--meta/packages/glib-2.0/glib-2.0-2.24.1/configure-libtool.patch34
-rw-r--r--meta/packages/glib-2.0/glib-2.0-2.24.1/gatomic-proper-pointer-get-cast.patch37
-rw-r--r--meta/packages/glib-2.0/glib-2.0-2.24.1/glib-gettextize-dir.patch19
4 files changed, 119 insertions, 0 deletions
diff --git a/meta/packages/glib-2.0/glib-2.0-2.24.1/60_wait-longer-for-threads-to-die.patch b/meta/packages/glib-2.0/glib-2.0-2.24.1/60_wait-longer-for-threads-to-die.patch
new file mode 100644
index 0000000000..1676b3e257
--- /dev/null
+++ b/meta/packages/glib-2.0/glib-2.0-2.24.1/60_wait-longer-for-threads-to-die.patch
@@ -0,0 +1,29 @@
1# copy from OE, said to borrow from Ubuntu. Not in glib-2.0 upstream yet. Add for sanity.
2#
3# by Kevin Tian <kevin.tian@intel.com>, 06/25/2010
4--- glib/tests/threadpool-test.c.old 2008-02-12 06:11:21.000000000 +0100
5+++ glib/tests/threadpool-test.c 2008-02-12 06:11:52.000000000 +0100
6@@ -5,8 +5,8 @@
7
8 #include <glib.h>
9
10-#define DEBUG_MSG(x)
11-/* #define DEBUG_MSG(args) g_printerr args ; g_printerr ("\n"); */
12+/* #define DEBUG_MSG(x) */
13+#define DEBUG_MSG(args) g_printerr args ; g_printerr ("\n");
14
15 #define WAIT 5 /* seconds */
16 #define MAX_THREADS 10
17@@ -124,10 +124,10 @@
18 DEBUG_MSG (("[unused] stopping unused threads"));
19 g_thread_pool_stop_unused_threads ();
20
21- DEBUG_MSG (("[unused] waiting ONE second for threads to die"));
22+ DEBUG_MSG (("[unused] waiting FIVE second for threads to die"));
23
24 /* Some time for threads to die. */
25- g_usleep (G_USEC_PER_SEC);
26+ g_usleep (5 * G_USEC_PER_SEC);
27
28 DEBUG_MSG (("[unused] stopped idle threads, %d remain, %d threads still exist",
29 g_thread_pool_get_num_unused_threads (),
diff --git a/meta/packages/glib-2.0/glib-2.0-2.24.1/configure-libtool.patch b/meta/packages/glib-2.0/glib-2.0-2.24.1/configure-libtool.patch
new file mode 100644
index 0000000000..3ba79b8986
--- /dev/null
+++ b/meta/packages/glib-2.0/glib-2.0-2.24.1/configure-libtool.patch
@@ -0,0 +1,34 @@
1# Poky renames libtool to $host_alias-libtool.
2# ./$host_alias-libtool isn't created until after configure runs with libtool >= 2.2.2
3# so we can't call # it at this point. We can safely assume a version is available
4# from PATH though
5
6--- glib-2.12.10/configure.in.orig 2006-06-05 13:34:08.000000000 +0100
7+++ glib-2.12.10/configure.in 2006-06-05 13:34:36.000000000 +0100
8@@ -1174,7 +1174,7 @@
9 G_MODULE_LDFLAGS=
10 else
11 export SED
12- G_MODULE_LDFLAGS=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
13+ G_MODULE_LDFLAGS=`($host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
14 fi
15 dnl G_MODULE_IMPL= don't reset, so cmd-line can override
16 G_MODULE_NEED_USCORE=0
17@@ -1265,7 +1265,7 @@
18 LDFLAGS="$LDFLAGS $G_MODULE_LDFLAGS"
19 dnl *** check for OSF1/5.0 RTLD_GLOBAL brokenness
20 echo "void glib_plugin_test(void) { }" > plugin.c
21- ${SHELL} ./libtool --mode=compile ${CC} -shared \
22+ ${SHELL} $host_alias-libtool --mode=compile ${CC} -shared \
23 -export-dynamic -o plugin.o plugin.c 2>&1 >/dev/null
24 AC_CACHE_CHECK([for RTLD_GLOBAL brokenness],
25 glib_cv_rtldglobal_broken,[
26@@ -1339,7 +1339,7 @@
27
28 AC_MSG_CHECKING(for the suffix of shared libraries)
29 export SED
30-shrext_cmds=`./libtool --config | grep '^shrext_cmds='`
31+shrext_cmds=`$host_alias-libtool --config | grep '^shrext_cmds='`
32 eval $shrext_cmds
33 module=yes eval std_shrext=$shrext_cmds
34 # chop the initial dot
diff --git a/meta/packages/glib-2.0/glib-2.0-2.24.1/gatomic-proper-pointer-get-cast.patch b/meta/packages/glib-2.0/glib-2.0-2.24.1/gatomic-proper-pointer-get-cast.patch
new file mode 100644
index 0000000000..1f3920f03a
--- /dev/null
+++ b/meta/packages/glib-2.0/glib-2.0-2.24.1/gatomic-proper-pointer-get-cast.patch
@@ -0,0 +1,37 @@
1# handle cast warning. borrow from OE, but updated with a better fix from glib
2# developing tree.
3#
4# by Kevin Tian <kevin.tian@intel.com>, 06/25/2010
5commit bf2719c815d719d1899b4bdb1b81ff6798471094
6Author: Lars Ellenberg <lars.ellenberg@linbit.com>
7Date: Thu Apr 15 19:03:05 2010 +0200
8
9 Cast to volatile to avoid warnings from -Wcast-qual
10
11 https://bugzilla.gnome.org/show_bug.cgi?id=457641
12
13diff --git a/glib/gatomic.h b/glib/gatomic.h
14index 7d9c318..22b28d9 100644
15--- a/glib/gatomic.h
16+++ b/glib/gatomic.h
17@@ -64,16 +64,16 @@ void g_atomic_pointer_set (volatile gpointer G_GNUC_MAY_ALI
18 #else
19 # define g_atomic_int_get(atomic) \
20 ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gint) ? 1 : -1]), \
21- (g_atomic_int_get) ((volatile gint G_GNUC_MAY_ALIAS *) (void *) (atomic)))
22+ (g_atomic_int_get) ((volatile gint G_GNUC_MAY_ALIAS *) (volatile void *) (atomic)))
23 # define g_atomic_int_set(atomic, newval) \
24 ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gint) ? 1 : -1]), \
25- (g_atomic_int_set) ((volatile gint G_GNUC_MAY_ALIAS *) (void *) (atomic), (newval)))
26+ (g_atomic_int_set) ((volatile gint G_GNUC_MAY_ALIAS *) (volatile void *) (atomic), (newval)))
27 # define g_atomic_pointer_get(atomic) \
28 ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
29- (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (void *) (atomic)))
30+ (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void *) (atomic)))
31 # define g_atomic_pointer_set(atomic, newval) \
32 ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
33- (g_atomic_pointer_set) ((volatile gpointer G_GNUC_MAY_ALIAS *) (void *) (atomic), (newval)))
34+ (g_atomic_pointer_set) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void *) (atomic), (newval)))
35 #endif /* G_ATOMIC_OP_MEMORY_BARRIER_NEEDED */
36
37 #define g_atomic_int_inc(atomic) (g_atomic_int_add ((atomic), 1))
diff --git a/meta/packages/glib-2.0/glib-2.0-2.24.1/glib-gettextize-dir.patch b/meta/packages/glib-2.0/glib-2.0-2.24.1/glib-gettextize-dir.patch
new file mode 100644
index 0000000000..c44e491556
--- /dev/null
+++ b/meta/packages/glib-2.0/glib-2.0-2.24.1/glib-gettextize-dir.patch
@@ -0,0 +1,19 @@
1# an very old patch cherry-picked in every glib-2.0 patch directory. The earliest container
2# for it is 2.6.5 in OE. The earliest commit for it is c8e5702127e507e82e6f68a4b8c546803accea9d
3# in OE side which ports from previous bitkeeper SCM. In OE side it's only used til 2.12.4.
4#
5# keep it since it's always cleaner to not hardcode destination path. Use @datadir@ is more
6# portable here. mark for upstream
7#
8# by Kevin Tian <kevin.tian@intel.com>, 06/25/2010
9--- glib-2.10.3/glib-gettextize.in.old 2006-06-21 12:46:45.000000000 +0100
10+++ glib-2.10.3/glib-gettextize.in 2006-06-21 12:48:14.000000000 +0100
11@@ -49,7 +49,7 @@
12 ;;
13 esac
14
15-gettext_dir=$prefix/share/glib-2.0/gettext
16+gettext_dir=@datadir@/glib-2.0/gettext
17
18 while test $# -gt 0; do
19 case "$1" in