diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/glib-2.0/files | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/glib-2.0/files')
-rw-r--r-- | meta/packages/glib-2.0/files/atomic_fix.patch | 16 | ||||
-rw-r--r-- | meta/packages/glib-2.0/files/glib-gettextize-dir.patch | 11 | ||||
-rw-r--r-- | meta/packages/glib-2.0/files/glibconfig-sysdefs.h | 6 | ||||
-rw-r--r-- | meta/packages/glib-2.0/files/glibinclude.patch | 18 |
4 files changed, 51 insertions, 0 deletions
diff --git a/meta/packages/glib-2.0/files/atomic_fix.patch b/meta/packages/glib-2.0/files/atomic_fix.patch new file mode 100644 index 0000000000..ddc7ada778 --- /dev/null +++ b/meta/packages/glib-2.0/files/atomic_fix.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | Index: glib-2.10.3/glib/gthread.c | ||
2 | =================================================================== | ||
3 | --- glib-2.10.3.orig/glib/gthread.c 2005-12-01 16:34:26.000000000 +0000 | ||
4 | +++ glib-2.10.3/glib/gthread.c 2006-07-06 08:17:18.000000000 +0100 | ||
5 | @@ -164,10 +164,10 @@ | ||
6 | _g_messages_thread_init_nomessage (); | ||
7 | |||
8 | /* we may run full-fledged initializers from here */ | ||
9 | + _g_atomic_thread_init (); | ||
10 | _g_convert_thread_init (); | ||
11 | _g_rand_thread_init (); | ||
12 | _g_main_thread_init (); | ||
13 | - _g_atomic_thread_init (); | ||
14 | _g_utils_thread_init (); | ||
15 | #ifdef G_OS_WIN32 | ||
16 | _g_win32_thread_init (); | ||
diff --git a/meta/packages/glib-2.0/files/glib-gettextize-dir.patch b/meta/packages/glib-2.0/files/glib-gettextize-dir.patch new file mode 100644 index 0000000000..989211c927 --- /dev/null +++ b/meta/packages/glib-2.0/files/glib-gettextize-dir.patch | |||
@@ -0,0 +1,11 @@ | |||
1 | --- glib-2.6.2/glib-gettextize.in.old 2005-02-15 02:43:17.000000000 +0000 | ||
2 | +++ glib-2.6.2/glib-gettextize.in 2005-02-15 02:43:18.000000000 +0000 | ||
3 | @@ -43,7 +43,7 @@ | ||
4 | |||
5 | # Directory where the sources are stored. | ||
6 | prefix=@prefix@ | ||
7 | -gettext_dir=@prefix@/share/glib-2.0/gettext | ||
8 | +gettext_dir=@datadir@/glib-2.0/gettext | ||
9 | |||
10 | while test $# -gt 0; do | ||
11 | case "$1" in | ||
diff --git a/meta/packages/glib-2.0/files/glibconfig-sysdefs.h b/meta/packages/glib-2.0/files/glibconfig-sysdefs.h new file mode 100644 index 0000000000..1329e7f21c --- /dev/null +++ b/meta/packages/glib-2.0/files/glibconfig-sysdefs.h | |||
@@ -0,0 +1,6 @@ | |||
1 | #define GLIB_SYSDEF_POLLIN =1 | ||
2 | #define GLIB_SYSDEF_POLLOUT =4 | ||
3 | #define GLIB_SYSDEF_POLLPRI =2 | ||
4 | #define GLIB_SYSDEF_POLLERR =8 | ||
5 | #define GLIB_SYSDEF_POLLHUP =16 | ||
6 | #define GLIB_SYSDEF_POLLNVAL =32 | ||
diff --git a/meta/packages/glib-2.0/files/glibinclude.patch b/meta/packages/glib-2.0/files/glibinclude.patch new file mode 100644 index 0000000000..5413e50e00 --- /dev/null +++ b/meta/packages/glib-2.0/files/glibinclude.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
4 | # | ||
5 | |||
6 | --- glib-2.0-2.4.6-r1/glib-2.4.6/glib/Makefile.am~glibinclude.patch | ||
7 | +++ glib-2.0-2.4.6-r1/glib-2.4.6/glib/Makefile.am | ||
8 | @@ -157,8 +157,8 @@ | ||
9 | gprintf.h | ||
10 | |||
11 | install-data-local: install-ms-lib install-libtool-import-lib | ||
12 | - @if test -f $(glibincludedir)/glist.h ; then \ | ||
13 | - echo "*** Old headers found in $(glibincludedir). You should remove the" ; \ | ||
14 | + @if test -f $(DESTDIR)$(glibincludedir)/glist.h ; then \ | ||
15 | + echo "*** Old headers found in $(DESTDIR)$(glibincludedir). You should remove the" ; \ | ||
16 | echo "*** contents of this directory and type 'make install' again." ; \ | ||
17 | false ; \ | ||
18 | fi | ||