summaryrefslogtreecommitdiffstats
path: root/meta/packages/gettext/gettext_0.17.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-08-18 18:14:09 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-08-18 18:14:09 +0100
commitd3983072bc481df2803c12944f2eca6f7aa79809 (patch)
tree2249ca95498e58fb8edcc8cc072af7bfc7860c77 /meta/packages/gettext/gettext_0.17.bb
parentb2d195641dcbd4939680c1ab7bd51863b68bcc55 (diff)
downloadpoky-d3983072bc481df2803c12944f2eca6f7aa79809.tar.gz
Add gettext 0.17 (from OE.dev)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gettext/gettext_0.17.bb')
-rw-r--r--meta/packages/gettext/gettext_0.17.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/packages/gettext/gettext_0.17.bb b/meta/packages/gettext/gettext_0.17.bb
new file mode 100644
index 0000000000..83d1e24a91
--- /dev/null
+++ b/meta/packages/gettext/gettext_0.17.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "The GNU internationalization library."
2HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
3SECTION = "libs"
4LICENSE = "GPLv3"
5PR = "r2"
6DEPENDS = "gettext-native virtual/libiconv ncurses expat"
7PROVIDES = "virtual/libintl"
8
9SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
10 file://autotools.patch;patch=1 \
11 file://wchar-uclibc.patch;patch=1 \
12 file://use_open_properly.patch;patch=1 \
13 "
14
15SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"
16SRC_URI_append_linux-uclibcgnueabi = " file://gettext-error_print_progname.patch;patch=1"
17
18PARALLEL_MAKE = ""
19
20inherit autotools_stage
21
22EXTRA_OECONF += "--without-lispdir \
23 --disable-csharp \
24 --disable-libasprintf \
25 --disable-java \
26 --disable-native-java \
27 --disable-openmp \
28 --with-included-glib \
29 --without-emacs \
30 "
31
32acpaths = '-I ${S}/autoconf-lib-link/m4/ \
33 -I ${S}/gettext-runtime/m4 \
34 -I ${S}/gettext-tools/m4'
35
36
37# these lack the .x behind the .so, but shouldn't be in the -dev package
38# Otherwise you get the following results:
39# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
40# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
41# because gettext depends on gettext-dev, which pulls in more -dev packages:
42# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
43# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
44# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
45# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
46
47PACKAGES =+ "libgettextlib libgettextsrc"
48FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
49FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"