diff options
author | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-07-21 10:10:31 +0000 |
commit | b2f192faabe412adce79534e22efe9fb69ee40e2 (patch) | |
tree | 7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/gettext/gettext-native_0.14.1.bb | |
parent | 2cf0eadf9f730027833af802d7e6c90b44248f80 (diff) | |
download | poky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz |
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gettext/gettext-native_0.14.1.bb')
-rw-r--r-- | meta/packages/gettext/gettext-native_0.14.1.bb | 53 |
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/packages/gettext/gettext-native_0.14.1.bb b/meta/packages/gettext/gettext-native_0.14.1.bb new file mode 100644 index 0000000000..07c9361a19 --- /dev/null +++ b/meta/packages/gettext/gettext-native_0.14.1.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | include gettext_${PV}.bb | ||
2 | S = "${WORKDIR}/gettext-${PV}" | ||
3 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gettext-${PV}" | ||
4 | inherit native | ||
5 | PROVIDES = "" | ||
6 | |||
7 | M4 = "\ | ||
8 | lib-ld.m4 \ | ||
9 | lib-link.m4 \ | ||
10 | lib-prefix.m4 \ | ||
11 | codeset.m4 \ | ||
12 | gettext.m4 \ | ||
13 | glibc21.m4 \ | ||
14 | iconv.m4 \ | ||
15 | intdiv0.m4 \ | ||
16 | intmax.m4 \ | ||
17 | inttypes.m4 \ | ||
18 | inttypes_h.m4 \ | ||
19 | inttypes-pri.m4 \ | ||
20 | isc-posix.m4 \ | ||
21 | lcmessage.m4 \ | ||
22 | longdouble.m4 \ | ||
23 | longlong.m4 \ | ||
24 | nls.m4 \ | ||
25 | po.m4 \ | ||
26 | printf-posix.m4 \ | ||
27 | progtest.m4 \ | ||
28 | signed.m4 \ | ||
29 | size_max.m4 \ | ||
30 | stdint_h.m4 \ | ||
31 | uintmax_t.m4 \ | ||
32 | ulonglong.m4 \ | ||
33 | wchar_t.m4 \ | ||
34 | wint_t.m4 \ | ||
35 | xsize.m4 \ | ||
36 | " | ||
37 | |||
38 | do_stage_append() { | ||
39 | for i in ${M4}; do | ||
40 | src="gettext-runtime/m4/$i" | ||
41 | if [ ! -f $src ]; then | ||
42 | src="gettext-tools/m4/$i" | ||
43 | fi | ||
44 | if [ ! -f $src ]; then | ||
45 | src="autoconf-lib-link/m4/$i" | ||
46 | fi | ||
47 | if [ ! -f $src ]; then | ||
48 | echo "can't find $i" >&2 | ||
49 | exit 1 | ||
50 | fi | ||
51 | install -m 0644 $src ${STAGING_DATADIR}/aclocal/$i | ||
52 | done | ||
53 | } | ||