diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-12-02 11:35:35 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-12-02 11:35:35 +0000 |
commit | 7bb37ffb35d9786b8da2aa9c6cd98e15cb8ba785 (patch) | |
tree | ba611a1b9caab5b3e2ddfef2113b1de460c5809c /meta/packages/gdb | |
parent | 4248fbef9fbaad7b49f3eee508b4389d57a73535 (diff) | |
download | poky-7bb37ffb35d9786b8da2aa9c6cd98e15cb8ba785.tar.gz |
gdb: Clean up recipe and don't inherit cross for cross-canadian
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gdb')
-rw-r--r-- | meta/packages/gdb/gdb-common.inc | 21 | ||||
-rw-r--r-- | meta/packages/gdb/gdb-cross-canadian_6.8.bb | 4 | ||||
-rw-r--r-- | meta/packages/gdb/gdb-cross.inc | 11 | ||||
-rw-r--r-- | meta/packages/gdb/gdb-cross_6.8.bb | 4 | ||||
-rw-r--r-- | meta/packages/gdb/gdb.inc | 28 | ||||
-rw-r--r-- | meta/packages/gdb/gdb_6.8.bb | 2 |
6 files changed, 31 insertions, 39 deletions
diff --git a/meta/packages/gdb/gdb-common.inc b/meta/packages/gdb/gdb-common.inc index 266c8fe6b2..49231a525d 100644 --- a/meta/packages/gdb/gdb-common.inc +++ b/meta/packages/gdb/gdb-common.inc | |||
@@ -3,6 +3,7 @@ HOMEPAGE = "http://www.gnu.org/software/gdb/" | |||
3 | LICENSE="GPLv3+" | 3 | LICENSE="GPLv3+" |
4 | SECTION = "devel" | 4 | SECTION = "devel" |
5 | PRIORITY = "optional" | 5 | PRIORITY = "optional" |
6 | DEPENDS = "ncurses readline" | ||
6 | 7 | ||
7 | inherit autotools | 8 | inherit autotools |
8 | 9 | ||
@@ -18,3 +19,23 @@ export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}" | |||
18 | 19 | ||
19 | B = "${WORKDIR}/build-${TARGET_SYS}" | 20 | B = "${WORKDIR}/build-${TARGET_SYS}" |
20 | 21 | ||
22 | EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'" | ||
23 | |||
24 | EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x \ | ||
25 | --with-curses --disable-multilib --with-readline --disable-sim \ | ||
26 | ${GDBPROPREFIX}" | ||
27 | GDBPROPREFIX = "--program-prefix=''" | ||
28 | |||
29 | do_configure () { | ||
30 | # override this function to avoid the autoconf/automake/aclocal/autoheader | ||
31 | # calls for now | ||
32 | (cd ${S} && gnu-configize) || die "failure in running gnu-configize" | ||
33 | oe_runconf | ||
34 | } | ||
35 | |||
36 | PACKAGES =+ "gdbserver" | ||
37 | FILES_gdbserver = "${bindir}/gdbserver" | ||
38 | |||
39 | RRECOMMENDS_gdb_append_linux = " glibc-thread-db " | ||
40 | RRECOMMENDS_gdb_append_linux-gnueabi = " glibc-thread-db " | ||
41 | |||
diff --git a/meta/packages/gdb/gdb-cross-canadian_6.8.bb b/meta/packages/gdb/gdb-cross-canadian_6.8.bb index badcba2533..5de6547f85 100644 --- a/meta/packages/gdb/gdb-cross-canadian_6.8.bb +++ b/meta/packages/gdb/gdb-cross-canadian_6.8.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | require gdb-cross.inc | 1 | require gdb-common.inc |
2 | 2 | ||
3 | DEPENDS = "ncurses-nativesdk expat-nativesdk" | 3 | DEPENDS = "ncurses-nativesdk expat-nativesdk" |
4 | 4 | ||
5 | inherit cross-canadian | 5 | inherit cross-canadian |
6 | |||
7 | PR = "r8" | ||
diff --git a/meta/packages/gdb/gdb-cross.inc b/meta/packages/gdb/gdb-cross.inc index 1618c80bec..11784e0d2b 100644 --- a/meta/packages/gdb/gdb-cross.inc +++ b/meta/packages/gdb/gdb-cross.inc | |||
@@ -2,15 +2,8 @@ require gdb-common.inc | |||
2 | 2 | ||
3 | DEPENDS = "ncurses-native" | 3 | DEPENDS = "ncurses-native" |
4 | 4 | ||
5 | EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'" | 5 | #EXTRA_OEMAKE += "LDFLAGS='${BUILD_LDFLAGS}'" |
6 | 6 | ||
7 | EXTRA_OECONF = "--with-curses --with-readline" | 7 | GDBPROPREFIX = "" |
8 | |||
9 | do_configure () { | ||
10 | # override this function to avoid the autoconf/automake/aclocal/autoheader | ||
11 | # calls for now | ||
12 | (cd ${S} && gnu-configize) || die "failure in running gnu-configize" | ||
13 | oe_runconf | ||
14 | } | ||
15 | 8 | ||
16 | inherit cross | 9 | inherit cross |
diff --git a/meta/packages/gdb/gdb-cross_6.8.bb b/meta/packages/gdb/gdb-cross_6.8.bb index 8462b6cb86..19c2da23f8 100644 --- a/meta/packages/gdb/gdb-cross_6.8.bb +++ b/meta/packages/gdb/gdb-cross_6.8.bb | |||
@@ -1,7 +1,5 @@ | |||
1 | require gdb-cross.inc | 1 | require gdb-cross.inc |
2 | 2 | ||
3 | inherit cross | ||
4 | |||
5 | SRC_URI += "file://sim-install-6.6.patch;patch=1" | 3 | SRC_URI += "file://sim-install-6.6.patch;patch=1" |
6 | 4 | ||
7 | PR = "r2" | 5 | PR = "r3" |
diff --git a/meta/packages/gdb/gdb.inc b/meta/packages/gdb/gdb.inc index 8c9bfa7267..e1acceb2f6 100644 --- a/meta/packages/gdb/gdb.inc +++ b/meta/packages/gdb/gdb.inc | |||
@@ -1,33 +1,11 @@ | |||
1 | require gdb-common.inc | 1 | require gdb-common.inc |
2 | 2 | ||
3 | DEPENDS = "ncurses readline" | ||
4 | |||
5 | PACKAGES =+ "gdbserver" | ||
6 | FILES_gdbserver = "${bindir}/gdbserver" | ||
7 | |||
8 | RRECOMMENDS_gdb_append_linux = " glibc-thread-db " | ||
9 | RRECOMMENDS_gdb_append_linux-gnueabi = " glibc-thread-db " | ||
10 | |||
11 | inherit gettext | 3 | inherit gettext |
12 | 4 | ||
13 | SRC_URI += "file://kill_arm_map_symbols.patch;patch=1 \ | 5 | SRC_URI += "file://kill_arm_map_symbols.patch;patch=1 \ |
14 | file://gdbserver-cflags-last.diff;patch=1;pnum=0 \ | 6 | file://gdbserver-cflags-last.diff;patch=1;pnum=0 \ |
15 | file://ignore_whitespace_changes.patch;patch=1 " | 7 | file://ignore_whitespace_changes.patch;patch=1 " |
16 | #FIXME file://uclibc.patch;patch=1 \ | ||
17 | |||
18 | EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'" | ||
19 | |||
20 | EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x \ | ||
21 | --with-curses --disable-multilib --with-readline --disable-sim \ | ||
22 | --program-prefix=''" | ||
23 | |||
24 | LDFLAGS_append = " -s" | ||
25 | export CFLAGS_append=" -L${STAGING_LIBDIR}" | ||
26 | 8 | ||
27 | do_configure () { | 9 | #LDFLAGS_append = " -s" |
28 | # override this function to avoid the autoconf/automake/aclocal/autoheader | 10 | #export CFLAGS_append=" -L${STAGING_LIBDIR}" |
29 | # calls for now | ||
30 | (cd ${S} && gnu-configize) || die "failure in running gnu-configize" | ||
31 | CPPFLAGS="" oe_runconf | ||
32 | } | ||
33 | 11 | ||
diff --git a/meta/packages/gdb/gdb_6.8.bb b/meta/packages/gdb/gdb_6.8.bb index 5c395650cb..6495d6cdca 100644 --- a/meta/packages/gdb/gdb_6.8.bb +++ b/meta/packages/gdb/gdb_6.8.bb | |||
@@ -1,3 +1,3 @@ | |||
1 | require gdb.inc | 1 | require gdb.inc |
2 | 2 | ||
3 | PR = "r5" | 3 | PR = "r7" |