diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-03 20:04:33 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-03 20:04:33 +0100 |
commit | ec8f5299d96d938b56c68d4ffa701b0c8a061de6 (patch) | |
tree | ad27e2213266eb3b425a36f5c6f990c78938ba35 /meta/packages/gcc | |
parent | b3e41b5d1ec003908610a79648528246d467a053 (diff) | |
download | poky-ec8f5299d96d938b56c68d4ffa701b0c8a061de6.tar.gz |
cross-canadian: Move binaries into a subdirectory of bin to allow multimachine installs and update users accordingly
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r-- | meta/packages/gcc/gcc-cross-canadian_4.3.3.bb | 2 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-package-sdk.inc | 16 |
2 files changed, 8 insertions, 10 deletions
diff --git a/meta/packages/gcc/gcc-cross-canadian_4.3.3.bb b/meta/packages/gcc/gcc-cross-canadian_4.3.3.bb index 7cc202363e..981452b7a7 100644 --- a/meta/packages/gcc/gcc-cross-canadian_4.3.3.bb +++ b/meta/packages/gcc/gcc-cross-canadian_4.3.3.bb | |||
@@ -5,7 +5,7 @@ require gcc-cross-canadian.inc | |||
5 | require gcc-configure-sdk.inc | 5 | require gcc-configure-sdk.inc |
6 | require gcc-package-sdk.inc | 6 | require gcc-package-sdk.inc |
7 | 7 | ||
8 | PR = "r16" | 8 | PR = "r17" |
9 | 9 | ||
10 | DEPENDS += "gmp-nativesdk mpfr-nativesdk" | 10 | DEPENDS += "gmp-nativesdk mpfr-nativesdk" |
11 | RDEPENDS_${PN} += "mpfr-nativesdk" | 11 | RDEPENDS_${PN} += "mpfr-nativesdk" |
diff --git a/meta/packages/gcc/gcc-package-sdk.inc b/meta/packages/gcc/gcc-package-sdk.inc index cdce1da1c7..23b9a48eb3 100644 --- a/meta/packages/gcc/gcc-package-sdk.inc +++ b/meta/packages/gcc/gcc-package-sdk.inc | |||
@@ -7,10 +7,7 @@ PACKAGES = "${PN} ${PN}-doc" | |||
7 | 7 | ||
8 | FILES_${PN} = "\ | 8 | FILES_${PN} = "\ |
9 | ${bindir}/* \ | 9 | ${bindir}/* \ |
10 | ${libexecdir}/gcc/${TARGET_SYS}/${BINV}/cc1 \ | 10 | ${libexecdir}/gcc/${TARGET_SYS}/${BINV}/* \ |
11 | ${libexecdir}/gcc/${TARGET_SYS}/${BINV}/collect2 \ | ||
12 | ${libexecdir}/gcc/${TARGET_SYS}/${BINV}/f771 \ | ||
13 | ${libexecdir}/gcc/${TARGET_SYS}/${BINV}/cc1plus \ | ||
14 | ${gcclibdir}/${TARGET_SYS}/${BINV}/*.o \ | 11 | ${gcclibdir}/${TARGET_SYS}/${BINV}/*.o \ |
15 | ${gcclibdir}/${TARGET_SYS}/${BINV}/specs \ | 12 | ${gcclibdir}/${TARGET_SYS}/${BINV}/specs \ |
16 | ${gcclibdir}/${TARGET_SYS}/${BINV}/lib* \ | 13 | ${gcclibdir}/${TARGET_SYS}/${BINV}/lib* \ |
@@ -44,11 +41,12 @@ do_install () { | |||
44 | rm -f ${D}${prefix}/${TARGET_SYS}/lib/libiberty.a | 41 | rm -f ${D}${prefix}/${TARGET_SYS}/lib/libiberty.a |
45 | rm -f ${D}${libdir}/libiberty.a | 42 | rm -f ${D}${libdir}/libiberty.a |
46 | 43 | ||
47 | # Create the ${prefix}/${TARGET_SYS}/bin/* symlinks | 44 | # Insert symlinks into libexec so when tools without a prefix are searched for, the correct ones are |
48 | install -d ${D}${prefix}/${TARGET_SYS}/bin/ | 45 | # found. |
49 | for l in ${D}${bindir}/*; do | 46 | dest=${D}${libexecdir}/gcc/${TARGET_SYS}/${BINV}/ |
50 | ln -sf "${bindir}/`basename $l`" "${D}${prefix}/${TARGET_SYS}/bin/`basename $l | sed -e 's,${TARGET_PREFIX},,'`" | 47 | install -d $dest |
48 | for t in ar as ld nm objcopy objdump ranlib strip g77 gcc cpp gfortran; do | ||
49 | ln -sf ${bindir}/${TARGET_PREFIX}$t $dest$t | ||
51 | done | 50 | done |
52 | ln -sf "${bindir}/${TARGET_PREFIX}gcc" "${D}${prefix}/${TARGET_SYS}/bin/cc" | ||
53 | } | 51 | } |
54 | 52 | ||